none
Authenticator App only receives push notifications if open RRS feed

  • Question

  • Hello all,

    I am sure this has been brought up already,  but I don't know how to fix it, other then turning off 2FA and turning it back on, and I would rather not do that. 

    I have a user that has all the correct settings in both Office 365 and the App to get push notifications.  On my app,  if the Authenticator app is open or not, I get the push notification. For my user, the Authenticator app needs to be open to get the push notification. 

    I have had the user delete the account in the app and reconfigure it,  but this did not fix the issue.  I am unsure how to move forward, since there are no real settings in either the app or Office 365 to help with this. 

    Any suggestions are appreciated. 

    Thanks. 

    Thursday, September 28, 2017 8:58 PM

All replies

  • Hi scottylat2486

    What is the version of your Phone and Microsoft Authenticator App?

    Microsoft Authenticator App needs permission Run at start.

    Run at startup: If you restart your phone, this permission ensures that you continue you receive notifications to verify your identity.

    Please refer to this link.

    I suggest you could upgrade Microsoft Authenticator App to latest version.

    Regards,

    Walter


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 29, 2017 5:46 AM
  • Hi Walter,

    I have checked out that link and it has no information that helps me.  That is why I am on the forums.  I will get the version of Android, and the version of the app the phone is on. 

    How do you make sure the app has run at start permissions?  There is nothing on the link you sent that explains that. 

    Thanks. 

    Friday, September 29, 2017 2:26 PM
  • Hi

    For different Android Phone, the configuration “Run at startup” method may be different, you could search it on google. When you start your Phone, you check background service, Microsoft authenticator app process is running?

    Also, you could try delete and re-install Microsoft authenticator app.

    Regards,

    Walter


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 2, 2017 2:40 AM
  • I know this is coming 2.5 years after the original question, but maybe it will help someone else currently having the same issue. The following fixed it for me:

    • Go into your phone's Settings and select Apps & Notifications > Authenticator > Notifications
    • Tap the words "All Notifications", not the checkbox
    • Tap Behavior and select "Make sound and pop on screen" (Show silently seems to only display on notification bar with no pop-up notification)
    • If you still want to get the pop-up notification while on Do Not Disturb, select Advanced and turn on "Override Do Not Disturb"

    I have a Motorola G6 with Android 9.

    Friday, March 27, 2020 6:49 PM