none
Template is missing when trying to associate to an EPT in MS Project Server 2016 RRS feed

  • Question

  • Hello! 
    After moving Project Server 2013 to Project Server 2016, I had a problem. I can not find the site template and language template (not even by default) when trying to associate to an EPT (as shown in the screenshots). Now you can not "update" the current instance of Project using the Upgrade-SPProjectWebInstance command, and it did not work for me. Mass update of connected SharePoint sites also does not help to solve this problem. How to fix this problem?

    -------------------------------------------------------------------------------------------

    shb01_error

    --------------------------------------------------------------------------------------------

    shb02_error


    - dr. Freeman

    Wednesday, November 14, 2018 4:12 PM

Answers

  • Hello,

    I had this problem before when I created a new instance of PWA and I discovered that disabling and re-enabling the pwa site feature fixed this issue. I assume that something was not provisioned correctly during the initial enabling of the pwa site feature. Try the following cmdlets to see if they resolve your issue:

    Disable-SPFeature pwasite -URL http://yourserver/pwa

    then:

    Enable-SPFeature pwasite -URL http://yourserver/pwa

    • Marked as answer by dr. Freeman Monday, November 19, 2018 9:42 AM
    Thursday, November 15, 2018 9:38 PM

All replies

  • Hello,

    I had this problem before when I created a new instance of PWA and I discovered that disabling and re-enabling the pwa site feature fixed this issue. I assume that something was not provisioned correctly during the initial enabling of the pwa site feature. Try the following cmdlets to see if they resolve your issue:

    Disable-SPFeature pwasite -URL http://yourserver/pwa

    then:

    Enable-SPFeature pwasite -URL http://yourserver/pwa

    • Marked as answer by dr. Freeman Monday, November 19, 2018 9:42 AM
    Thursday, November 15, 2018 9:38 PM
  • Thanks for Your reply! Your decision really helped. The error is now fixed!

    - dr. Freeman


    • Edited by dr. Freeman Monday, November 19, 2018 9:42 AM edit
    Monday, November 19, 2018 9:42 AM