none
Exchange 2010 Send As Permissions Dropping RRS feed

  • Question

  • We are finding send as rights are dropping even though they are still appearing in the send As Rights Permissions box. This has been happeneing intermittently for a few weeks now, has anyone experienced something similar?

    Thanks

    Friday, October 10, 2014 1:29 PM

Answers

  • Hi,

    From your description, I recommend you use the following cmdlet to verify if this user has send as permission to the specified user.

    Get-Mailbox | Get-ADPermission | where {($_.ExtendedRights -like "*Send-As*") -and -not ($_.User -like “NT AUTHORITY\SELF”)} | FT -Wrap

    Best regards,


    Amy Wang
    TechNet Community Support

    Monday, October 13, 2014 7:33 AM
    Moderator
  • Hi,

    We have encountered the same. Can you confirm if the issues mostly occured on sites where the Exchange servers are not on premise?

    What Microsoft Premier Services advised is as below

    1) Install a dummy mailbox server on the affected sites

    2) Remove and reassign the send as permissions to the affected mailbox

    It seems bizarre but it worked for us.


    Blog: http://theinfraguys.com

    Follow me at Facebook The Infra Guys Facebook Page

    Please remember to click Mark as Answer on the answer if it helps you in anyway

    Tuesday, October 14, 2014 3:22 AM

All replies

  • I have not.

    What happens when someone attempts to send as someone else?

    I suppose there is an error message?

    When you say they are "dropping" what does that mean?

    Permissions worked at one time and then stopped working?

    Can you re-establish permissions, for example, by removing the user (or group) and then adding it again?

    One more thing: are those affected domain administrators or members of any other admin group (enterprise, schema admins)?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Saturday, October 11, 2014 4:41 PM
  • Hi,

    From your description, I recommend you use the following cmdlet to verify if this user has send as permission to the specified user.

    Get-Mailbox | Get-ADPermission | where {($_.ExtendedRights -like "*Send-As*") -and -not ($_.User -like “NT AUTHORITY\SELF”)} | FT -Wrap

    Best regards,


    Amy Wang
    TechNet Community Support

    Monday, October 13, 2014 7:33 AM
    Moderator
  • Hi,

    We have encountered the same. Can you confirm if the issues mostly occured on sites where the Exchange servers are not on premise?

    What Microsoft Premier Services advised is as below

    1) Install a dummy mailbox server on the affected sites

    2) Remove and reassign the send as permissions to the affected mailbox

    It seems bizarre but it worked for us.


    Blog: http://theinfraguys.com

    Follow me at Facebook The Infra Guys Facebook Page

    Please remember to click Mark as Answer on the answer if it helps you in anyway

    Tuesday, October 14, 2014 3:22 AM
  • Hi,

    As per the information and details provided by you, Send As permission is Dropping in Exchange 2010.

    Please follow these steps to setup Send As Permission in Exchange Server2010: -

    • In Exchange 2010, Click on Start> Programs> Microsoft Exchange> and then click Active Directory Users and Computers.
    • In the View menu, click on the Advanced Features.
    • Expend Users, then right click the Mailbox Owner object where you want to grant the permission, and then click Properties.
    • Click on the Security tab, and then click on Advanced.
    • In the Access Control Setting for Mailbox Owner dialog box, click on Add.
    • In the Select User, Computer, or Group dialog box, click the user account or the group that you want to grant Send As permission to and then click OK.
    • In the Permission entry for Mailbox Owner dialog box, click This Object Only in the Apply onto list.
    • In the Permission list, locate Send As, and then click to select the Allow check box.
    • Click OK three times to close the dialog boxes.

    I hope this information will be helpful for you.

    Thanks and regards

    Ashish@S 


    Ashish@V

    Tuesday, October 14, 2014 12:24 PM