none
Windows 7 is not prompting for PEAP username and password on the wired network

    Question

  • I'm not getting the "additional logon information" (credentials) popup for my wired network configured for PEAP authentication.  Windows 7 is joined to the Active Directory domain. 802.1X is enabled on the Wired Network.  "Remember my credentials for this connection" is disabled. "Automatically use my Windows logon name" is disabled. The authentication mode is "User authentication" with the credentials deleted.  I expect to see the credential popup when I disable and then enable the wired network.  Note that authentication succeeds when the credentials are saved in the 802.1X setting tab.  Also, the Network credentials popup does appear for wireless networks. Thanks.

    Wednesday, February 13, 2013 9:11 AM

All replies

  • Hi,

    Did you mean you want authentication windows pop up when you connect to the wireless network?

    If yes, please refer to the toipic about how to configure PEAP authentication in Windows 7, more information see:

    https://supportforums.cisco.com/docs/DOC-17544

    If I am misunderstand, please point out my mistake.

    Regards.


    Spencer
    TechNet Community Support

    Thursday, February 14, 2013 5:11 AM
    Moderator
  • Hi,

    Thank you  for responding. No, this is a WIRED network.  (Wireless works.)  Here's the scenario:

    1. Go to "Change adapter settings"

    2. Right click on the Wired network and go to Properties. 

    3. In the authentication tab enable 802.1X and select PEAP. Enable Validate server certificate. Select EAP-MSCHAP v2 as the authentication method and DISABLE "Automaticaly use my Windows logon name and password". Specify the Authentication mode as "User authentication" and DO NOT Save Credentials.

    4. Right click on the WIRED network. DISABLE it then ENABLE it.  A popup requesting additional logon information (credentials) should appear, but it does not.  The same is true for EAP-TLS where  I expect a popup requesting that I select the appropriate user certificate, but no such popup appears.

    Thursday, February 14, 2013 8:57 AM
  • Hi,

    I’d first like to clarify the authentication mode part, so if we want to make users to authenticate by using the credentials of current logged user, we’d need to set to use “User re-authentication” . This compact has been explained in the session “Wired authentication modes” in the link below:
     
    Planning for Recommended Wired Security Configurations
     
    http://technet.microsoft.com/en-us/library/dd378927(WS.10).aspx
     
    Maybe we should recheck the current settings with following our sample guide below and see if any improvement:
     
    Configure Wired Computers Running Windows Vista for 802.1X Authenticated Access
     
    http://technet.microsoft.com/en-us/library/dd348442(WS.10).aspx
     
     
     
    For more information please refer to the link below:
    802.1X Authenticated Wired Access
     
    http://technet.microsoft.com/en-us/library/cc753354(WS.10).aspx

    Regards. 
     


    Spencer
    TechNet Community Support


    Friday, February 15, 2013 5:10 AM
    Moderator
  • Unfortunately, the links you gave me are for Windows servers.

    I'm using my Windows 7 as a supplicant to test various authentication profiles.  Each time I authenticate I would like to use a different user. So, no I do not want to authenticate by using the credentials of a current logged user. 

    I have this working on other Windows 7 supplicants, just on this one it's not working.  Is there something I need to enable/disable/delete in order to get the credentials popup working again?  I only see the popup after I do a restart.

    Wednesday, February 20, 2013 1:38 PM
  • Hi Nancy, we share the same problem even on Windows 10.

    I created a batch script to import wired do1x user authentication and the window pops up to put credentials and it connects fine! However when I logoff I loose network connectivity! after fiddling and researching on the internet I found that the popup balloon to put credentials does not actually save credentials on the network card thus loosing my connection when I logoff, however if I go to the network settings and click on the "Save Credentials" and put my credentials it saves it somewhere and i Can logoff and logon without loosing any network connectivity.

    I can seem to be able to find a way to let the Balloon popup to input credential act as the "Save Credential" button!

    this is frustrating...


    Friday, June 2, 2017 3:02 PM