locked
Unable to get windows update from WSUS from some computers RRS feed

  • Question

  • Hi,

    I have a couple of machines (servers and computers) on an internal network (no internet). I bring in the windows update via a WSUS. All my servers are running on windows Server 2012 R2 while the computers are running on Windows 10 (various version).

    All my servers can get the update from the WSUS but only some of the computers can get the update.

    Of all the computers that can get the update, they are version 1607. But the rest (running on ver 1511 and earlier) can't get the updates. I am not sure whether is it caused by a problem with earlier Windows version or some other problems.

    I have tried running SolarWind for WSUS and the result seems ok (aside from the usual incorrect proxy configuration and port 8530 error).

    The WSUS is running on Windows Server 2012 R2. The WSUS version 6.3.6900.18324.

    Any ideas on how to get all the computers to receive the updates?

    Thanks in advance

    Stanley


    • Edited by Stanley.Ho Wednesday, March 15, 2017 8:12 AM Corrected WSUS Version. Help shows a different version from dashboard
    Wednesday, March 15, 2017 6:53 AM

All replies

  • Hi Stanley.Ho,

    1. Do the affected clients report to the WSUS server correctly? Do you approve updates for these machines on WSUS server;

    2. Do you get any error when the affected clients check update from the WSUS server? Check WindowsUpdate.log on client side in C:\Windows\WindowsUpdate.log;

    3. Try reset windows update components on affected clients:

    https://support.microsoft.com/en-us/kb/971058

    4. Also run Server Cleanup Wizard on WSUS server.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 15, 2017 9:46 AM
  • Thanks for the reply.

    1. The client appears in the unassigned computers with a warning sign. It states the computer has yet to report. I have approved all the updates for for unassigned computer.


    2. Yes but the error code serve no meaning 0x800705b4. It means unknown error. As for the log, out of 4 computers that has problems updating, 3 of them only contains unknown GUID. I even tried to decode the log using tracefmt but to no avail. The last computer windowsupdate.log does not gives any clue.


    3. I will try to reset the WU component.


    4. I might not be able to clean up the updates but I can do it for the computers. Reason is the current WSUS is also serving as a WU server for another network with a replica WSUS server. If I do the cleanup, I am afraid it will remove all the updates that is not use in this network but is required in the other network.

    Thursday, March 16, 2017 12:52 AM
  • I tried to reset one of the WU component. But the result is the same.

    I tried to get those affected clients to connect to the internet and get the updates but the results (error code: 0x800705b4) are the same. I could neither get the update from the WSUS or from the internet.

    I also tried running Windows update troubleshooter tool.

    It reported

    ---------

    Potential Windows update database error detected....fixed

    Some security settings are  missing or have been changed......fixed

    Service registration is missing or corrupted......fixed

    windows update components must be repaired.....fixed

    ---------

    However, regardless of how many times i run the tool, it keeps giving me the same result.

    I tried running the same tool on the working computer and it return s the same result less the security and registration problems.

    Friday, March 17, 2017 9:38 AM
  • Hi Stanley.Ho,

    Check windows update on the affected clients, then post the related windows update log here, let's troubleshoot the issue deeply.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 23, 2017 2:34 AM