none
An error has occurred when saving your project to the server(project server 2013) RRS feed

  • Question

  • Hi,

    recently i had migrated EPM 20010 to EPM 2013,after migration many project in project centre are not able to update by project manger,below error message shows to user.

    "an error has occurred when saving your project to the server,.."

    after opening in MSP 2013 sam eproject problem has been resolved however we have 200 project max project have same issue,please let me know any suitable solution.HJS


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Tuesday, October 20, 2015 12:56 PM

Answers

All replies

  • before the migration did you check to ensure all the projects were checked in?

    Is this happening only on specific projects, or all?

    In the administration section of PWA you can force check in objects... Server Settings -> Force Check-in Enterprise Objects -> select the projects and check them in

    Edit: did you also perform bulk update of project sites?

    HTH 

    if this answers your question please mark as answer


    • Edited by kbwrecker Tuesday, October 20, 2015 2:15 PM added bulk update
    Tuesday, October 20, 2015 2:14 PM
  • Hi Kb,

    Yes befor migration,i checkin all project and also after migration i had bulk update project site.This issue is coming frequently many projects


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Thursday, October 22, 2015 5:03 AM
  • Try the below first - it seemed users had this issue in 2010 and the below worked for some...

    do you have the latest patches applied (sp1 and october pu)?  Have you run sharepoint configuration management? 

    applies to 2010 but might be a good resource

    https://social.technet.microsoft.com/Forums/projectserver/en-US/6f4401de-ee42-46b4-a788-e8d5fd8993dc/an-error-has-occurred-when-saving-your-project-to-the-server-any-idea-why-i-would-get-this?forum=projectserver2010general

    The below might apply too - but doing this for 200+ projects might be a lot of work...

    http://epmainc.com/blog/project-server-2010-save-error

    if this answers your question please mark as answer

    Thursday, October 22, 2015 11:28 AM
  • Hi,

    When you said that opening the project with Microsoft Project Professional solved the issue, what do you do exactly? Do you edited and published the project with MSP 2013 or just published it?

    Thursday, October 22, 2015 11:34 AM
  • Hi Josh,

    Yes only in MSP 2013 edit ,save and publish.After that problem has been resolved.But many project have facing same issue.


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Thursday, October 22, 2015 11:49 AM
  • Have you tried a PowerShell script to do this in every Project? Edit the project Title (setting the same), saving the project and publishing it...

    Here are some examples:

    https://gallery.technet.microsoft.com/projectserver/Server-2010-Publish-all-45ba385b

    https://pwmather.wordpress.com/2012/05/31/updated-publish-all-projects-in-projectserver-using-powershell-msproject-ps2010-sp2010/

    Hope this helps!

    Monday, October 26, 2015 12:57 PM
  • I had the same problem last week.

    When users opend any project the error occured every time.
    They were not able to save or publish any data.

    I found the solution by checking the names of the projects.

    One user deleted the "Name *" (mandatory field) of a project.

    This stopped the work of the project queue service (service was still started but not processing any jobs).

    I think it is a bug. You cannot create a new project with empty name but after creating it you are able to delete the name of the project.

    MS Project 2013 - June 2015 CU - working only via GUI (customized PDP)

    Sunday, December 13, 2015 7:13 PM
  • Still facing same issue,MSP 2013 trick is also not working,after opening in MSP 2013,unable to update ,same issue occurring. only way to create new project and delete existing one.

    Please let me knwo if any have proper solution.It may be Project Server 2013 bug.


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Tuesday, December 15, 2015 5:02 AM
  • Hi,

    Use below steps and update SP,Problem will resolve.

    Please find below the packages including SharePoint Server 2013 SP1 and Project Server 2013 SP1:

    https://support.microsoft.com/en-us/kb/2880556

    List of all Service Pack 1 (SP1) updates for Microsoft SharePoint Server 2013 and related server products

     

    Microsoft SharePoint Server 2013 Service Pack 1

    DownloadDownload the 64-bit update now.

    2880552 Description of Microsoft SharePoint Server 2013 Service Pack 1 (SP1)

    Microsoft Project Server 2013 Service Pack 1

    DownloadDownload the 64-bit update now.

    2880553 Description of Microsoft Project Server 2013 Service Pack 1 (SP1)

     

    https://support.microsoft.com/en-us/kb/3114345

    December 8, 2015, cumulative update for SharePoint Server 2013 (KB3114345)

     

    https://support.microsoft.com/en-us/kb/3114341

    December 8, 2015, cumulative update for Project Server 2013 (KB3114341)

     

    After installing all these patches please run the SharePoint Products Configuration Wizard to complete the installation as described in https://technet.microsoft.com/en-us/library/dd239177(v=office.14).aspx


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Thursday, March 3, 2016 5:15 AM