locked
ConfigMgr 2012 Setup Failed when creating primary site database RRS feed

  • Question

  • Hey all,

    Having trouble creating a brand new primary site... ConfigMgr 2012 setup gets past all the prerequisites, but when creating the site database, it fails with the following in the logs:

    INFO: Starting InstallDatabase()  $$<Configuration Manager Setup><04-25-2012 13:50:26.220+300><thread=2760 (0xAC8)>
    *** [08001][-2146893022][Microsoft][SQL Server Native Client 10.0]SSL Provider: The target principal name is incorrect.~~  $$<Configuration Manager Setup><04-25-2012 13:50:26.220+300><thread=2760 (0xAC8)>
    ERROR: SQL Server error: [08001][-2146893022][Microsoft][SQL Server Native Client 10.0]SSL Provider: The target principal name is incorrect.~~  $$<Configuration Manager Setup><04-25-2012 13:50:26.220+300><thread=2760 (0xAC8)>
    *** [08001][-2146893022][Microsoft][SQL Server Native Client 10.0]Client unable to establish connection  $$<Configuration Manager Setup><04-25-2012 13:50:26.220+300><thread=2760 (0xAC8)>
    ERROR: SQL Server error: [08001][-2146893022][Microsoft][SQL Server Native Client 10.0]Client unable to establish connection  $$<Configuration Manager Setup><04-25-2012 13:50:26.220+300><thread=2760 (0xAC8)>*** Failed to connect to the SQL Server.  $$<Configuration Manager Setup><04-25-2012 13:50:26.220+300><thread=2760 (0xAC8)>INFO:  SQL Connection failed. Connection: SQLCLUSTERNAME.mydomain.com MASTER, Type: Secure  $$<Configuration Manager Setup><04-25-2012 13:50:26.220+300><thread=2760 (0xAC8)>

    ... etc

    SQL Database server is a two-node SQL Cluster, with SQLCLUSTERNAME as the name.  In addition to being used for the primary site db, SQLCLUSTERNAME also has the WSUS database (WSUS is set up on the primary site server as it will have a SUP).  I also installed SSRS on the primary site server (with the Reporting databases also hosted on SQLCLUSTERNAME) for future use as a reporting point.  This is very strange, as SCCM setup worked perfectly when I initially created a CAS (I later realized I didn't need a CAS, so I uninstalled it... The CAS was hosted on a different server than the standalone primary, and has since been decommissioned).  All Oses are Windows 2008 R2 SP1, and the SQL Cluster is a 2-node  SQL Cluster 2008 R2 SP1 with CU4.


    Things I've tried so far:

    - Making sure the CAS was completely uninstalled by removing the HKLM\Software\Microsoft\SMS key on both nodes of the SQL Cluster, checking for ConfigMgr related services, and local users and groups. 

    - Thinking the SSRS install might have confused matters, I have uninstalled SSRS from the primary site, with no change.

    - Ensuring the SPN for the service account the SQL cluster is running on is correct:

    MSSQLSvc\SQLCLUSTERNAME.mydomain.com

    MSSQLSvc\SQLCLUSTERNAME.mydomain.com:1433

    Any other ideas?

    Thanks,

    Julian Rodriguez

    Thursday, April 26, 2012 5:14 PM

Answers

All replies

  • Hey Julian,

    What is the version of SQL Native Client on the primary site? We have seen some issues with a SQL 2008 R2 Native Client talking to a cluster. If you are using the R2 SNAC, remove from the primary site and install the SQL 2008 SNAC and see if the issue continues.

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=16177

    Best Regards,

    Jason Adams

    Thursday, April 26, 2012 5:38 PM
  • Jason,

    Yep, that was it.   So this effectively means the primary site can't be used as a Reporting Point, correct? (That's how the 2008 R2 Native Client got installed in the first place, when I installed SSRS).

    Julian

    Thursday, April 26, 2012 8:02 PM
  • The SNAC is distinct from the other SQL components, so once the Reporting Services are installed, you should be able to downgrade the SNAC with no issues.
    Friday, April 27, 2012 4:51 PM
  • I encountered the same issue using SQLNCLI version 2008 R2 SP1 CU6.  Reverting to 2008 SP3 CU4 allowed the connection.

    It would be nice if Microsoft would address this in the first CfgMgr Service Pack or the next CU for SQL, especially since SQL 2008 R2 is listed as a supported platform, which means IT people should be able to assume that it will work.

    Monday, May 14, 2012 6:47 PM
  • I'd like to point out that we struggled with the exact same issue.  2008R2 SP1 cu6 SSRS on our Primary site with MP on sccm 2012, with backend SQL server 2008 R2 SP1 CU6 cluster.  However the way I noticed was a 500 error via the mpcontrol.log.  So frustrating because I reinstalled everything from scratch when the MP wasn't working the first time, because I thought IIS was broken.


    Wednesday, May 30, 2012 11:58 PM
  • I have been struggling with the same issue as well, and tried everything but that downgrade.  So the R2 Management Objects are okay?  But the Native Client is more stable if its 2008 but not R2?
    Tuesday, July 10, 2012 1:15 AM
  • Hi All,

    Sorry to drag up an old issue but I was experiencing the same issue and downgrading the client was not an option (SSRS R2 installation needs R2 Native Client) and thought I'd post an alternative solution in case anyone else is having this issue.

    The issue is that the SCCM installation generates a self-signed SSL certificate on the SQL Server and configures SQL to use this for SCCM-SQL transport encryption. The older SQL 2008 Native Client appears not to have any issues with this but the newer 2008 R2 Native Client refuses to connect using this self-signed certificate due to the enforcing of CRL checking and the lack of a CRL for self-signed certificates. By setting up the SQL Server to use a new SSL certificate from either an internal CA or using a trusted third-party CA (there are plenty of documents available on how to do this) SCCM 2012 connects successfully using the SQL 2008 R2 Native Client and will even work with a SQL Cluster instance.

    Regards,

    Adrian


    Monday, September 10, 2012 3:09 AM
  • Hi everyone,

    Another drag up because i experiencing the exact same problem.

    The reporting service is installed on the SCCM 2012 server and the SCCM database is clustered.

    This combination lead to the "[SQL Server Native Client 10.0]Client unable to establish connection  $$<Configuration Manager Setup>" error in setup log.

    Contacting Ms Support, the issue will be corrected in System Center SP1 (will be available probably in early 2013).

    The actual workaround available :

    1- Ovoid design a SCCM 2012 primary site server with any SQL component (Rerporting, WSUS Db etc.) when you want to use a SCCM clustered DB.

    2- Use SQL 2008 SP1 CU#7 instead of SQL 2008 R2

    http://blogs.msdn.com/b/sqlreleaseservices/archive/2010/03/15/cumulative-update-7-for-sql-server-2008-service-pack-1.aspx

    Regards.

    Ced


    • Edited by Cédric Bravo Friday, October 19, 2012 2:41 PM
    • Proposed as answer by AntanasGi Friday, January 4, 2013 9:27 AM
    Thursday, October 11, 2012 2:26 PM
  • Hi guys,

    Thanks for the thread.  This helped me find the issue.  The SQL 2008 R2 SP2 Native client is not compatible on the primary (or cas), period. I do not run a clustered SQL instance at all, but when I tried to put down SSRS and appy SP2, it overwrote the original native client.  Needed to remove that client and reinstall the one recommended for RC.

    I will have to just put up a new server for strictly SSRS.

    Thursday, November 29, 2012 10:59 PM