none
SSRS 2008R2 crashes when previewing. No error msg RRS feed

  • Question

  • The BIDS console closes when I hit preview. No error message pops up from within BIDS but the application log has the following

    .NET Runtime version 2.0.50727.3643 - Fatal Execution Engine Error (7A05B200) (80131506)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    How do I fix this? Googling showed a 2008 (not R2) fix and something about redgate which I dont have installed


    Adelaide, Australia

    Monday, March 25, 2013 3:45 AM

Answers

  • No local admin on the work pc

    I did manage to resolve it though. I started it up in safe mode and tried the add toolbox items dialog. It loaded up and actually gave an error message w/o crashing this time. it turns out there were some bad directx dlls (explains why it was crashing when trying to preview). It worked after that - i guess safe mode flags bad dlls and doesn't try tot load them anymore.

    I reinstalled directx 9c as well and it's all good


    Adelaide, Australia

    Tuesday, March 26, 2013 11:57 AM

All replies

  • Hey mate.. is it just one report that crashes it or any of them?

    Have you tried installing the latest service pack? Failing that, you could try reinstalling BIDS


    Thanks! Josh

    Monday, March 25, 2013 4:59 AM
  • All reports. They were working a few weeks ago. This error is consistent across at least 2 of the dev machines here.

    The reinstall has been tried with no success


    Adelaide, Australia

    Monday, March 25, 2013 10:57 PM
  • Hi Adelaide,

    Based on my research, the issue may be resolved after installing SQL Server 2008 R2 SP2. First, please give the SQL Server 2008 R2 SP2 a try. 

    If it is not the case, try to run the Visual Studio in safe mode:

    1. Click Start -> Visual Studio 2008 -> Visual Studio tools -> Visual Studio Command Prompt to start the command line tool.

    2. Run the command to see whether the issue occurs in Visual Studio Safe Mode:

         devenv /safemode

    3. If it can run properly, please run the following command lines and run the Visual studio again to see whether it can solve this issue:

         devenv /resetSettings

    If the issue persists, you can try to apply the following fix:
    http://support.microsoft.com/kb/981108

    Regards,


    Mike Yin
    TechNet Community Support

    Tuesday, March 26, 2013 2:15 AM
    Moderator
  • Please review the report service logs. Try to see where exactly this server crashed. Sometimes you get a clue on what exactly is the issue in the logs.

    Logs may be huge. But really useful for this kind of situations.


    Please Mark posts as answers or helpful so that others can more easily find the answers they seek.

    Tuesday, March 26, 2013 3:17 AM
  • Hi Mike,

    How do I find which SP version of bids I have installed?

    Microsoft SQL Server Reporting Services Designers
    Version 10.50.1600.1

    This is a controlled environment so I won't be able to install anything. I did try the reports on another dev machine and they did work, so it's some local setting on a few of the workstations - the workstations of the developers that actually use BIDS daily. All machines have the same version of SSRS

    I can't try your other suggestion because I dont have a visual studio command prompt option in my start menu

    I tried running devenv /safemode from the VS 9.0\common\ide\ directory (the path to which the BIDS shortcut points to) but it wouldn't let me open the project. It said that .dtproj is an unsupported type

    I also tried /resetSettings and this time i was able to open it the project but it didn't fix my issue. The report closes when I click on the Preview pane.

    Is a sql server 2008 sp1 hotfix compatible with sql server 2008r2? The version number would be lower and i doubt it would let me install

    edit: I also can't open certain VS dialog boxes. I get an errorless crash/close when I go to tools | choose toolbox items...

    • Edited by jakubk Tuesday, March 26, 2013 5:15 AM more info
    Tuesday, March 26, 2013 4:51 AM
  • 10.50.1600.1 = SQL 2008 R2 RTM. 

    So you should install the SP2 Service Pack. 

    If you cannot install anything, how was BIDS installed on your machine in the first place?


    Thanks! Josh

    Tuesday, March 26, 2013 10:21 AM
  • No local admin on the work pc

    I did manage to resolve it though. I started it up in safe mode and tried the add toolbox items dialog. It loaded up and actually gave an error message w/o crashing this time. it turns out there were some bad directx dlls (explains why it was crashing when trying to preview). It worked after that - i guess safe mode flags bad dlls and doesn't try tot load them anymore.

    I reinstalled directx 9c as well and it's all good


    Adelaide, Australia

    Tuesday, March 26, 2013 11:57 AM