none
Task Updates By Team Members In Project Server 2013 but not reflects in MSP 100% completed RRS feed

  • Question

  • Hi,

    My problem is related to Project Server & Project Professional 2013

    My scenario is like that Project Manager publish the project plan, and respective team member get their task. And Team Member is updated the task,then send to  the Project Manager for approval. Project Manager is approved the task. But, while opening my project in MSP 2013, it is not synced means, in msp it is not showing task 100% completed.

    Please solve this problem, I am waiting for your response.

    Thanks

    Saikat 

    Consultant

    Wednesday, March 4, 2015 11:59 AM

All replies

  • Hi Saikat,

    Do you use the timesheet or just the task update? Have the project plan been published after the task updates approval? Did you see any error message in the PWA queue?

    First of all, the fact that the team member updates the task does not mean that he marks the task as 100% complete. In this case, it would be normal that the task is not 100% completed in MS Project.

    Then there might be more than 1 resource on a task which means that even a resource completed his assignment, there might have some work left for others resources, making the task imcompleted.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Wednesday, March 4, 2015 12:14 PM
    Moderator
  • Hi Saikat,

    Please find below link for your reference might you will get solution. I tried before i got solution.

    https://support.office.com/en-au/article/Percent--Complete-fields-84ec5068-4a34-497c-97eb-e12b6dc47cc5


    Thanks and Regards, Rangnath Mali

    • Marked as answer by Saikat1903 Wednesday, March 4, 2015 12:34 PM
    • Unmarked as answer by Saikat1903 Wednesday, March 4, 2015 12:35 PM
    • Marked as answer by Saikat1903 Wednesday, March 4, 2015 12:35 PM
    • Unmarked as answer by Saikat1903 Wednesday, March 4, 2015 12:36 PM
    Wednesday, March 4, 2015 12:32 PM
  • Hi Saikat,

    It looks like a corrupted assignment. Project cannot update the assignment because it sees it as locked. Refer to this thread with a SQL query (might need to be adapted) to find corrupted assignments. If you find some corrupted assignments, set the publish column to no, publish the project, set back the publish value to yes and publish again. Run again the SQL query to ensure there are no more corrupted assignments.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, March 5, 2015 9:55 AM
    Moderator
  • Hi Guillaume,

    I have tried your procedure, but not get any solution.

    Yes, two errors are showing while opening in MSP like:

    1) The following job type failed to complete, Job Type -Load. Could not load project. Please try after sometime.

    <detail><ServerExecutionFault xmlns="http://Microsoft.Office.Project.Interfaces/" xmlns:i="http://www.w3.org/2001/XMLSchema-instance"><Actor i:nil="true"/><LastError>1032</LastError><Message/><Source/><StackTrace/><TargetSite i:nil="true"/><ExceptionDetails><errinfo xmlns=""><general><class name="ProjectHasWriteLock"><error id="1030" name="ProjectHasWriteLock" uid="c9095c9e-cfbc-e411-940a-000c299e9fb7"/></class><class name="ProjectHasNoReadLock"><error id="1032" name="ProjectHasNoReadLock" uid="ca095c9e-cfbc-e411-940a-000c299e9fb7"/></class></general></errinfo></ExceptionDetails></ServerExecutionFault></detail>

    2) Second error are showing in Queue like "Skipped for Optimization" and "Failed But Not Blocking Corelation"

    Please give me the ultimate solution to solve this.

    Thanks and Regards

    Saikat

    Consultant.

    Thursday, March 5, 2015 9:58 AM