locked
Cluster Disks are not able to discover in SCOM RRS feed

  • Question

  • Hello All,

    Any helps will be thankful.

    I am not able to discover the cluster drives,I already imported the MP Windows Server Cluster Disks Monitoring(6.0.7297.0).

    Regards...

    ANU_SCORCH

    Tuesday, July 19, 2016 1:57 PM

Answers

  • You should enable proxy for all agents, if this fixes it for you. it's not a security risk and it's stupid that they still have agent proxying. I have a script that runs 2x/day that sets proxy=enabled.

    import-module OperationsManager
    new-SCOMmanagementgroupconnection "scomms01"
    Get-SCOMAgent | Where-Object {$_.ProxyingEnabled.Value -eq $False} | Enable-SCOMAgentProxy


    "Fear disturbs your concentration"


    • Edited by andyinsdca Monday, July 25, 2016 3:24 PM
    • Proposed as answer by Microsoft Jim Thursday, July 28, 2016 10:06 AM
    • Marked as answer by Elton_Ji Friday, August 5, 2016 6:59 AM
    Monday, July 25, 2016 3:24 PM

All replies

  • Do you have any of the parent discoveries disabled, like Windows Cluster (disk monitoring)? Follow the target for each class discovery "up" the chain and make sure they're working. For example, if "Windows Cluster (disk monitoring)" isn't working, check the "Virtual Server" discovery, etc.

    "Fear disturbs your concentration"

    Wednesday, July 20, 2016 3:33 PM
  • Hi Sir,

    Have you tried the solution in the similar thread:

    "Solved after enable proxy agent"

    https://social.technet.microsoft.com/Forums/en-US/129c827b-446f-4a72-a361-2adca8ac9553/csv-and-cluster-disks-are-not-discovered-scom-2012-sp1-using-windows-server-cluster-disk?forum=operationsmanagermgmtpacks

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .

    • Proposed as answer by Microsoft Jim Thursday, July 28, 2016 10:04 AM
    Thursday, July 21, 2016 6:44 AM
  • You should enable proxy for all agents, if this fixes it for you. it's not a security risk and it's stupid that they still have agent proxying. I have a script that runs 2x/day that sets proxy=enabled.

    import-module OperationsManager
    new-SCOMmanagementgroupconnection "scomms01"
    Get-SCOMAgent | Where-Object {$_.ProxyingEnabled.Value -eq $False} | Enable-SCOMAgentProxy


    "Fear disturbs your concentration"


    • Edited by andyinsdca Monday, July 25, 2016 3:24 PM
    • Proposed as answer by Microsoft Jim Thursday, July 28, 2016 10:06 AM
    • Marked as answer by Elton_Ji Friday, August 5, 2016 6:59 AM
    Monday, July 25, 2016 3:24 PM
  • Elton and Andy are right, chances are this is an Agent Proxy (not enabled) issue. Andy's script will work a treat - twice a day seems a little excessive though! How many agents a day are you repairing\deploying!?

    You might also want to look at the "OpsMgr 2012 Self Maintenance Management Pack" by the Frankly god-like Tao Yang http://blog.tyang.org/2015/09/16/opsmgr-self-maintenance-management-pack-2-5-0-0 Which has a rule built in (disabled by default) called "OpsMgr 2012 Self Maintenance Enable Agent Proxy Rule". By enabling this rule Agent Proxy will be enabled everywhere once a day at about midnight if I recall.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember, if you see a post that helped you please click "Vote as Helpful", and if it answered your question, please click "Mark as Answer". I do not work for Microsoft, I manage a large estate in the private sector, my views are generally first hand production experiences.

    • Proposed as answer by Microsoft Jim Thursday, July 28, 2016 10:12 AM
    Thursday, July 28, 2016 10:12 AM
  • I only run it twice a day because it keeps the customers quiet. "IS MY NEW SERVER DISCOVERED? DO YOU SEE ALL OF THE DRIVES!?!?!?!?" Otherwise, it'd just be a daily thing.

    "Fear disturbs your concentration"

    Thursday, August 4, 2016 3:53 PM