none
IE 11 Failed to install RRS feed

  • General discussion

  • I am trying to install IE11 via WSUS at my workplace and it is failing to install on random PC because update KB is not detected as installed. I have tried install the problem KB and reinstalling it manually or via wsus and it still fails to install.

    Why is IE11 such a hassle to install? Why is everything I seem to do with MS a hassle? Nothing ever goes through smoothly.

    I am not the only one affected by this problem as there are many reports from 2012 of exactly the same issue. The fix is to install IE11 as a download rather than through windows update. This might work for a home user but I have 1000 users to push ie11 out to.

    The stupid update is 1.6mbyte but it takes 3 reboots and 20 mins loading to uninstall and install.

    00:41.059:
    ERROR:   WMI query for Hotfixes timed out. Query string: 'Select
    HotFixID from Win32_QuickFixEngineering WHERE
    HotFixID="KB2729094"'  Error: 0x00040004 (262148).
    
    00:41.059:
    INFO:    KB2729094 could not be download is not installed.
    As you can see from the search https://www.google.co.uk/search?q=0x00009C47

    It is a common problem. Why has this problem still not bee resolved 3 years after it was identified?

    Thursday, May 19, 2016 3:01 PM

All replies

  • Hi John, this is only a guess....

    on a problem machine type

    shell:fonts

    in either a windows explorer or internet explorer address bar..... this should open a file explorer window at the windows>fonts folder.

    Click the "Font settings" hyperlink (on the rhs) and uncheck the option to "Allow fonts to be installed using a shortcut"

    also

    check what permissions have been set on the Windows/Fonts folder and also the permissions and available space to the Windows/temp folder.

    from a command prompt (cmd.exe) type the path command to display its value.... if present, either the windows/fonts or the windows/temp folders should not be listed in the Path variable.

    see https://support.microsoft.com/en-us/kb/2729094

    as I said I am only guessing.... I trust it is helpful.


    Rob^_^

    Friday, May 20, 2016 1:54 AM
  • OK so how exactly do you suggest doing this on 1000 pc?


    Surely the ie11 setup that is deployed through windows update needs to be updated to resolve this update problem.


    The update KB2729094 is already installed on the affected pc but ie11 install is not detecting it. I uninstalled it and reinstall it manually and it made no difference.

    That setting in fonts is not set and the permissions on temp and fonts is fine as well.

    • Edited by Johnmclain Friday, May 20, 2016 10:53 AM
    Friday, May 20, 2016 10:48 AM
  • Hi John,

    these are peer to peer support forums... MSMVP's do not work for nor represent MS... I am looking for a reason why the required font updates aren't taking in the update....

    There WAS a security zone setting to allow fonts to be installed on demand (which I think was removed from IE9), so my second guess is that in order for the update to take (and assuming that the IE11 setup is looking for that security zone setting to determine if IT CAN install fonts)...

    On an unpatched machine, open internet options>Security tab, and view the settings for the intranet zone and look for a security zone setting for Installing fonts on demand.

    see https://www.windows-security.org/70ed188411ffd8f44e5d6cec886c406f/allow-install-on-demand-internet-explorer

    also examine your existing GPO security zone settings and enabled it if it is turned off.... again, its only a guess.

    you can always open a support ticket at support.microsoft.com to allow a support engineer to RAS one of your machines to examine its current configuration to glean a possible or known reason.

    Regards.


    Rob^_^

    Saturday, May 21, 2016 3:23 AM