App-V 5.0 Problem sequencing package that contains *.lnk file

    General discussion

  • Today i tried sequence program that contains file that ends .lnk.

    Programs .lnk file is not valid shortcut file it contains something that program needs. Program cannot work without the file.

    When sequencer compares what has done it fails. If I delete file or rename files extension packages saving works.

    Problem can be easily replicated by renaming any files extension to .lnk.

    I think sequencer is attempting creating program from the .lnk file and fails when it don't find normal shortcut information from it.

    Thursday, March 07, 2013 2:54 PM

All replies

  • Hello,

    Have you tried to create a copy script that copies the file into the virtual environment?

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, March 07, 2013 2:56 PM
  • Do you mean during sequencing or when i run application on client?

    Thursday, March 07, 2013 3:02 PM
  • Hello,

    When using the package on the client - to avoid having to capture the file

    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, March 07, 2013 3:03 PM
  • I have to test that it could be workaround.

    During sequencing i did this (what is almost same thing):

    1. During capturing i renamed lnk extension.

    2. On configuring software step i renamed it back -> everything works

    3. After that save package failed (what was not surprise:))

    I think that is going to work. I will be back and report what happened.

    Thursday, March 07, 2013 3:15 PM
  • Ok I done some testing.

    1. I opened CMD inside app-v package

    2. There is file called disclaimer.txt in package

    3. I run command rename disclaimer.txt disclaimer.old -> everything ok

    4. I run command rename disclaimer.old disclaimer.lnk -> I get access denied error

    5. I create shortcut file to my desktop -> Copy to package folder -> access denied

    I am getting a feeling .lnk files are not allowed to be inside package. Only workaround is copy file to it's real location outside package. If i have to do this kind compromise there is no reason to virtualize this software. I think i can manage this better by doing MSI installation.

    Thursday, March 07, 2013 5:36 PM