none
drive letter missing RRS feed

  • Question

  •  

    I have a two-node 2008 SP1 Failover Cluster.

    I got a problem today:

    Drive letter of a cluster volume is lost when I move the cluster disk to another node.

     

    “Cluster Disk 1” had one volume with drive letter “R:”. I assigned another drive letter “F:” to it on node 1.

    Then I moved Cluster Disk 1 to node 2.

    Its drive letter was gone!

    I tried to assign a new drive letter to it. But it was gone every time I moved it to another node.

     

    It never happens before.

    Could anyone please tell me why it happens and how to fix it?

     

    By the way, I installed latest windows updates yesterday.

    Friday, January 23, 2009 4:15 PM

All replies

  • You changed the drive letter in Failover cluster manager or in Disk Manager.  If in FC manager, Offline and then Online the disk and see if the problem repros.  If yes, do it in Disk Manager and Offline and Online the disk and see if it repros.  If it does not repro in an Offline and Online sequence, then fail the group over to the other node and see what happens with the drive letter.  Ensure while you are doing this, there really are no drive letter collisions on the nodes...like with the DVD\CD drive.
    Chuck Timon Senior, Support Escalation Engineer (SEE) Microsoft Corporation
    Tuesday, January 27, 2009 2:19 AM
  • I was moving drive letter and other cluster information from volume 1 of "Cluster Disk 1" to volume 2 of "Cluster Disk 2".
    ("Cluster Disk 1" is deleted from the cluster after it's done.)

    All my operations are done by an application:
      Drive letter is moved by GetVolumeMountPoints() and IOCTL_MOUNTMGR_CREATE_POINT;
      Cluster information is copied by CLUSCTL_RESOURCE_GET_PRIVATE_PROPERTIES, CLUSCTL_RESOURCE_SET_PRIVATE_PROPERTIES, 
      CLUSCTL_RESOURCE_GET_COMMON_PROPERTIES, and CLUSCTL_RESOURCE_SET_COMMON_PROPERTIES.

    They are completed successfully. 
    When I move "Cluster Disk 2" to another node or Offline and Online it, drive letter of volume 2 is lost!
    I assign a new drive letter to volume 2, but it will also be lost if "Cluster Disk 2" is moved or offlined.

    I also try to move drive letter by CLUSCTL_RESOURCE_STORAGE_SET_DRIVELETTER. It has the same problem.

    I am sure there is no drive letter conllisions on the nodes.
    Could me please tell me the root cause and how to fix it?

    Saturday, January 31, 2009 8:20 AM
  • Does Microsoft have a forum for Cluster API or Cluster programming?
    How can I get the answer?
    Wednesday, February 11, 2009 9:48 AM
  • Did anyone complain about it before?
    Thursday, February 12, 2009 2:19 PM
  • I have not seen this behaviour before with normal Microsoft cluster management tools.
    Saying that I never coded an application to do this type of operation.

    In order to answer the question if there is a specific forum for Cluster API programming, I don't think so.
    I would advice you to post your question in the forum of the programming language you are using.

    sorry that I cannot help you further than this
    Rgds,
    Edwin.
    Wednesday, February 18, 2009 4:43 PM
    Moderator
  • You ever find a solution for this.? I have a similar issue.. If I failover my drive letter drops.. I can re-add it, but only from disk mgr not cluster mgr.. (clu mgr does not give me that disk as an option).. I don't see this drive used anywhere else so not sure why it wont let me add it via clu mgr!!.
    Thursday, May 19, 2016 6:41 PM