locked
column headers gone when not in 'detail view' RRS feed

  • Question

  • Since about a week, the column headers are gone when Explorer is not set to detail view.
    I'm able to sort the file list by name, size, type etc in detail view, and it sticks to that when I change the view to List, Thumbnails etc. But the column headers for all folders are gone except in detail view.

    This used to work until about a week ago and it was quite handy (I need to sort files in some folders in whatever view mode).

    I install all updates. Is this an "optimization" introduced in any of the recent updates?
    Saturday, March 14, 2009 4:27 PM

Answers

  •  

    Hi Andy, let's try deleting a registry entry and check the result:

     

    1.       Click Start, go to Start Search.

    2.       Type regedit and press Enter.

    3.       Locate the following entry and delete it:

     

                    HKLM\Software\Microsoft\Windows\CurrentVersion\PropertySystem\PropertySchema\@CachedSchema

     

    4.       Then, please restart the computer.

     

    Hope this helps!

     


    Sean Zhu - MSFT
    Monday, March 16, 2009 9:15 AM
    Moderator

All replies

  •  

    Hi Andy, let's try deleting a registry entry and check the result:

     

    1.       Click Start, go to Start Search.

    2.       Type regedit and press Enter.

    3.       Locate the following entry and delete it:

     

                    HKLM\Software\Microsoft\Windows\CurrentVersion\PropertySystem\PropertySchema\@CachedSchema

     

    4.       Then, please restart the computer.

     

    Hope this helps!

     


    Sean Zhu - MSFT
    Monday, March 16, 2009 9:15 AM
    Moderator
  • Hi Sean, thanks for the info.
    Deleting the key worked for the very first folder I opened after reboot, but that's the only folder where it works. I now see column headers in that one folder, they go away when I navigate to any other folder and they're not there when I open any other folder...
    The registry entry is still gone too.

    I'm on a fresh Vista install, I noticed this after I reinstalled and downloaded all updates ca. one week ago.
    Monday, March 16, 2009 12:42 PM
  •  

    Thanks for the update. Let's try a clean boot this time and check the result:

     

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

     

    Note: Please click Continue if the "User Account Control" window pops up.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test the issue.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    Please test this issue in the Clean Boot environment. If the issue disappears, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.


    Sean Zhu - MSFT
    Wednesday, March 18, 2009 6:24 AM
    Moderator
  • I did those steps but the problem is still there.

    There weren't much non-MS services to disable: 'Ati External Event Utility' and two services used by Photoshop (LM Service and FlexNet).

    I kept the Avast antivir services running though, but I doubt they have anything to do with the issue.
    Friday, March 27, 2009 10:13 PM
  • So why is this marked s fixed when it's clearly not.
    I solved it with a bullet prove method that works all the time: reinstall.
    Wednesday, April 15, 2009 8:55 PM