none
Timesheet keeps loading when saved or sent for approval RRS feed

  • Question

  • Of late we are having issue with users while trying to save timesheet and send timesheet for approval. On selecting these buttons the timesheet keeps on showing 'loading' message and when user clicks on any other link in PWA page a pop-up comes up 'You are naviating away from this page, your changes will be lost'.

    Most the users facing this issue are either using IE 9 or IE 10 and for some users changing Browser mode to IE 9 in F12 Developer Tools worked but some users responded back saying issue still persists. But for the same users timesheet save and submit timesheet worked fine in Mozilla and Chrome browsers. Cache issue might not be present in IE as this issue happened even after clearing browser cache in IE.

    The similar is issue was faced by some PMs accessing Project Center. Also there is no entry for this behavior in ULS logs.

    Environment is Project Server 2010 SP2.

    Wednesday, August 6, 2014 10:25 PM

All replies

  • For users in IE10 can you add the PWA site in Compatibility View and then Check.

    Go to Tools in IE > Compatibility View Settings. Add the Site.



    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.


    Wednesday, August 6, 2014 10:48 PM
  • Hi Dinesh,
    Your workaround does explain the behavior involving IE 10 which I too found out. However the same is not applicable for IE 9. End-User is using IE9 and still faces these issues. However user seems to have no issue with Mozilla and Chrome browsers.
    Sunday, August 10, 2014 10:44 PM
  • After lot of research it seems like the issue is related to IE rendering modes than compatibility. We noticed that Browser Mode and Document Mode of IE8 In F12/Developer options is resolving this issue. To make sure that individual users do not need to make this change, we have added the browser mode in IIS config file.
    • Proposed as answer by Srivatsava Saturday, December 6, 2014 5:16 AM
    Saturday, December 6, 2014 5:16 AM