locked
Home Networking W/ Windows 7 & Windows XP RRS feed

  • General discussion

  • I have spent hours trying to make it so that I can access the files on my Win 7 Desktop from my Win XP Media Edition laptop.  I have changed so many setting such as:

    • Changing the advance sharing settings
    • Changing the Workgroup to MSHOME
    • I have set up homegroups and deleted them
    • I have gone directly to the folders and tried to share them

    All I want is the same easy set up that I had with XP.  All I had to do was walk through the wizard and afterwards, I could access my computer's shared files from any other computer in the house.  With win 7 it either asks me for a password or just flat tells me that I can't do it.

    Can anyone help me on this matter or can something be done to make it as easy as it was?
    • Changed type Mark L. Ferguson Thursday, February 5, 2009 11:18 PM thread abandonded by OP.
    Sunday, January 18, 2009 4:40 PM

All replies

  • Leave the homegroup and change the network location to "work network".  I did this and I can finally see all the shares on the WIN 7 PC from my XP machine
    Sunday, January 18, 2009 5:21 PM
  • Thanks for the info.  I really can't seem to get it right though.  I right clicked Computer and went to properties and clicked on change setting to the right of the screen and changed the Network ID to Work but I still get nothing.  I have also made sure that I don't have a homegroup.  Where else do I need to click or check?

    Edit:  I found out how to turn the "View your active networs" to Work Network but I still can't get it working...
    Sunday, January 18, 2009 6:00 PM
  • Start Menu / Computer / Right click network / properties / where you see view your active networks - click on home network and change it to "work network".  It will probably tell you that you are leaving the home network and you won't be able to share files with other home network users....who cares!  :-)   Unless you have all your machines on Win 7 the home network setting doesn't seem to be working with other OS's.  Hope this helps.
    Sunday, January 18, 2009 6:29 PM
  • Yeah I have that completed and when I try to get to my shaded files on my win 7 computer from my XP computer, I get this:

    You might not have permission from the network resource.  Login failed.

    I need to find out why it is even looking for log in credentials when I have it set not to using the advanced sharing settings.

    Thank you very much for your help thus far.


    Sunday, January 18, 2009 6:49 PM
  • you need to turn on all file sharing (home and public)  in advanced settings.  I also have "allow windows to manage homegroup" checked

    Sunday, January 18, 2009 7:04 PM
  • I have all that as well checked and I still can't get into my shared folder from any other computer in the house.  I went back and un-checked everything, restarted, and checked it back to the letter the way you said to and it still isn't working.

    Looks like my network is just going to be a royal pain in the butt.
    Sunday, January 18, 2009 7:14 PM
  •  I am using a desktop with Win7 and a notebook with XP pro & a router,try to make a homegroup,but you can not be able to see the C on win7,only the partition ,or other hdd if you share that of course,you need adm rights on both machine,in share choose specific people,Advance Sharing/permission/check all 3 boxes/in Group or user names ,must be EVERYONE
    Sunday, January 18, 2009 7:48 PM
  • yes all those are checked and no, I am trying to share a folder on a completely different drive than the one that I have Win 7 installed on.  Thank you for your help as well.   I am still unable to get into my folders from any other computer on the same network.
    Sunday, January 18, 2009 8:07 PM
  • I spend more than 6hrs on the phone with a consultant of Microsoft to solve the same problem,but under Vista (notebook) and XP (desktop),one of the problem can be your antivirus (I use avg free 8..) win7,try to disable on both machine the antivirus and firewall,But if you are  not able to see another partition or hdd,i think you did not make the corect settings in Network places/share.In My Network places(XP) you must be able to see another hdd shared,other than C ( I think you receive a message ...is not accesible.You not have permission....and bla bla bla....Access is denied) when you try to access it

    Sunday, January 18, 2009 8:32 PM
  • Hi

    I agree with Brhams.

    Another possible cause is incorrect policy settings. Please let us know if you have created same username/password on all computers include the Windows 7 beta to share resources, or enabled Guest account in the Windows 7 beta. I suggest that you launch gpedit.msc->Computer Configuration->Windows Settings->Security Settings ->Local Policies->User Rights Assignment. Check if the policy "Hide entry points for Fast User Switching" is enabled. Open the policy "Access this computer from network", check if the account is in the list. Please note that Guest is not a member of Everyone.


    Arthur Xie - MSFT
    Thursday, January 22, 2009 5:46 AM
  • I think I have the same problem:

    Windows XP SP3 connected by Ethernet to router
    Windows 7 laptop connected by wifi to same router

    W7 laptop can see and read all files on XP computer

    Whatever I do, I cannot get the XP to read files on the Laptop. It can see the laptop but on clicking a link it gives \\Laptop\ is not accessible. You may not have permission to view this network resource etc

    I have disabled homegroup.
    All in same name workgroup
    Advanced settings > no password
    Re-shared all folders
    Access set to Everyone

    I have wasted spent three hours failing to do this simple task.

    What next? It's maddening. What was simple seems to have been made incredibly complicated.
    Monday, February 2, 2009 5:15 PM
  • Hi Peter,

    I suggest that you check related settings. On the Windows 7 beta computer, Launch Network and Sharing Center, select Change advanced sharing settings. Please enable file sharing. If you have create same username/password on the Windows 7 beta computer, keep Password protected sharing on.

    If the issue still occur, temporary disable the firewall on the Windows 7 beta computer.

    If the issue persists, check if the user you are using is allowed to access the computer from network. On the Windows 7 beta computer, launch “gpedit.msc”, navigate to Computer configuration\Windows settings\Local Policies\User Rights Assignment. In the right pane, find the policy Access this computer from the network. Please ensure that the user or the group it belongs to is listed.


    Arthur Xie - MSFT
    Wednesday, February 4, 2009 9:25 AM
  • Thanks - but I had done all these things already. No use.

    "Access this computer from network" gives "Everyone, Administrator, Users, Backup operators"

    Tuesday, February 10, 2009 4:05 PM
  • This problem is driving me batty. I have done and redone everything many times over. I have followed through every walkthrough I can find. I have set and reset every option.

    1. Everything is in one workgroup (have tried three different workgroup names on both machines)
    2. All Documents, Music etc folders are shared and have little people icons. I have even shared whole C drive. Permissions include "Everybody"
    3. I have tried "business" and "home" networks. Homegroup is definitely OFF.
    4. All settings in Advanced settings as suggested.

    Nothing works. The W7 Laptop is seen from XP but shows only a folder for "My name", "Music", "Pictures", "Public" and "Users". Nothing is accessible apart from "Users" which contains a folder "Default" and a number of empty folders inside that. The Documents folder is not even shown, let alone clickable.

    What on earth is preventing a network connection that worked easily before?

    Tuesday, February 10, 2009 9:38 PM
  • Ok it include everybody, but does everybode have access? :)

    Everybody must have at lest read access to that share in order to open it with or without password
    Wednesday, February 11, 2009 3:50 AM
  •  I'm having the same problems.  With XP setting up a network was a breeze.  Vista has been a pain and W7 looks like it's worse.  I understand the need to have security but I would like the option to not use all the security, if I don't need it, and have a simple network configuration proceedure.  The fact that there is so much discussion means that it is not intuitive.  There are a lot of home and small business networks that don't need all of the bells and whistles.
    Wednesday, February 11, 2009 9:31 PM
  • I have not any problems copying from and to W7 computer from XP based computer.

    HopeGropup security does not affect general shares.

    I can share each folder I want from advanced folder sharing options
    Wednesday, February 11, 2009 10:37 PM
  • You can also try to connect from the command line, using the "net use" command. This way you have a bit more control when specifying username (with "domain") and password. 

    If the name of the windows 7 computer is WIN7TEST, you have set up a share FILES, and you have created a local user with name TOM (with rights to access the files), try this from a command prompt:

    net use  * \\WIN7TEST\FILES /user:WIN7TEST\TOM *
    (Now you should get a question about the password)

    If it works, it should reply with a message "X: is now connected to \\WIN7TEST\FILES".
    Wednesday, February 11, 2009 11:23 PM
  •   Hello All

    I too have been thinking about networking my Laptop XP  (wireless) to my multiboot Windows & Desktop (ethernet cabled) and  I came upon another tread where ShockDoctor7 had produced a simple step by step guide. I followed this and within a very few minutes I was up and running (including automatically connecting to my network printers). I hope this link helps:

    ShockDoctor7 -
    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/033c418b-1096-4df7-bfad-fd3d431f3cd5

    Thursday, February 12, 2009 4:22 PM
  • Yes - in my search for an answer I used every step of that Shockdoctor7 walkthrough. No good result.

    My XP simply cannot get through to the Vista laptop, no matter what the settings.

    By the way, I also had a problem using Remote Desktop Connection to my workplace. (http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/860e594c-835a-4886-9810-f92cad8a77e8) I wonder if this is a connected problem.



    Friday, February 13, 2009 4:11 PM
  • Thanks Mushroom99

    That did it for me.  I had it all except adding the "Everyone" account.  FYI, I was working with a Vista machine talking to a W7 machine. 

    Friday, February 13, 2009 4:29 PM
  • The peer to peer networking wizard has never ever worked since XP. I have tried for 7 years to share a printer on this computer and it won't happen. I've been able to share other printers on this network. . . Now I have Beta 7 and the stupid wizard again DOES NOT WORK!!!!! It can not see the peer to peer network already out ther and it can't see the other computers and it won't set up a net work!!!!!! It only took 2 minutes to set up a computer on a network on Windows 98 and ther is absolutely NO REASON for these wizzards especially since they have been nothing but BUG feast for a decade now!!!!!
    Saturday, February 14, 2009 12:38 AM
  • Hi, 

    Microsoft Networking is based on the Ethernet 802.3 standard (Carrier Sense Multiple Access with Collision Detection). The Ethernet 802.3 standard does not specifically forbid the use of crossover cables, but the implementation of crossover cables is beyond the scope of the standard.

     

    Microsoft has an article that explains this behavior.

     

    Using Crossover Cables in Home or Peer-to-Peer Networks


    Arthur Xie - MSFT
    Tuesday, February 17, 2009 2:18 AM
  • The problem now seems to have resolved - but for no very obvious reason.

    The only setting that I seem to have changed is in (right-click a Folder) Properties >> General. There was a setting "Attributes Read Only (only applies to files in a folder)" which had a filled-in shaded box in it (ie not a tick or a cross or nothing). I removed this so that there was nothing in thebox - which then on Ok-ing set applied this to all sub-folders.

    Can this really have been what was preventing me from using networking? (I've never been very clear what the filled-in box means - surely it's either ticked or it isn't???)

    I repeated the setting on other folders and all are now accessible.
    Sunday, February 22, 2009 9:14 PM