none
DPM 2016 agent status bogus error trust relationship failed RRS feed

  • Question

  • Wondering if anyone has run into this with DPM 2016.  After successfully upgrading from DPM 2012 R2, I updated the agents to the latest version.  Agent push seemed to install ok and backups work just fine however the agent status reports a failure that the trust between workstation and primary domain failed.  I have about 20 or so agents being backed up and as soon as the 5.0.158.0 agent got installed each one throws this error.

    Our AD has a disjointed namespace (DNS domain does not match Netbios Name) so I am wondering if that is causing the bogus error.  I know from the below article that DPM does not handle this well even though it's perfectly acceptable to have Active Directory set this way.  KB article below references 2012 but it was definitely not fixed in 2016 either as i had to do the same thing to get 2016 installed.

    https://support.microsoft.com/en-us/kb/2930276

    Thanks!


    KD

    Wednesday, October 26, 2016 9:59 PM

All replies

  • Use the NetBIOS name of the domain when you get asked for credentials, not the FQDN. Domain Contoso.edu.test

    Netbios Name: Contoso

    FQDN: Contoso.edu.test 

    Wednesday, November 2, 2016 4:26 PM
  • Thanks Christian.  I did try both ways and still fails with the error.  Upgrading of existing agents works (but still shows error) and new agents cannot be installed at all.

    It may be because we have disjoined namespace.  Maybe DPM programmers were sloppy and just shaved off the domain names to get to NetBIOS rather than looking it up proper.  That seems to be the case with the installer bug anyways.

    disjoined example

    FQDN:contoso.edu

    NetBIOS Name: CONTEDU


    KD

    Wednesday, November 2, 2016 4:43 PM
  • Could be. Whenever i run into trouble with DPM, using the NetBios name always fixes it for me. When you do an upgrade from DPM 2012R2 to DPM 2016 strange things happen when you use the FQDN instead of the NetBios name.

    Might be worth reporting this as a bug. No clue on how to do that though.

    Thursday, November 3, 2016 1:02 PM
  • Thanks again.  Decided to just rebuild OS from scratch and the reattach/resync with dpmsync to see if that helped.  Looks like its ok now and working without errors.  Initially I did an OS inplace upgrade to 2016 like the DPM TechNet suggests but that may to have caused these agent issues.

    KD

    Thursday, November 3, 2016 8:11 PM
  • Has anyone else since experienced this?

    Just done a DPM2012 Upgrade through to 2016 Update Rollup 4 and the agents updated and have run a full backup. Agents are 5.0.342.0.

    Then a reboot and what seems to be KB4051033 being installed we are now seeing the trust relationship failed issue on all upgraded agents.

    On the management > agent tab, the error is below:Verify that both host-12.DOMAIN.com and the domain controller are responding. Then in Microsoft Management Console (MMC), open the Group Policy Object Editor snap-in for the local computer and verify the local DNS client settings in Local Computer Policy\Computer Configuration\Administrative Templates\Network\DNS Client.

    No local DNS Client policy is set

    Domain policy is not affecting this

    Thanks, Chris


    Update Rollup 4 for SCDPM 2016
    Update Rollup 4 for SCDPM 2016
    Friday, December 15, 2017 10:51 AM
  • Same issues here on Microsoft Direct Access after upgrade from Server 2012R2 to 2016 as supported. We're not able to load the Direct Access Console due to this. I've tried resetting the Computer Password, flushing DNS and rebooting to no avail. Anyone have another suggestion?

    -Scott


    Tuesday, August 14, 2018 7:23 PM