locked
Vodafone 3G USB Modem & Vista RRS feed

  • Question

  • Hi,

     

    I have an HPnx9420 with Vista Ultimate 32-bit.  I regularly use three different NIC's: all of both the on-board cable LAN (Broadcom netXtreme Gigabit); the on-board WLAN (Intel PRO/100 3945 ABG) and a LinkSys WPC300N PCMCIA card.  Not all at the same time, obviously.  Everything installed fine and was working well.

     

    Then I puchased and installed a Vodem (Huawei E220) using the VMC software v9.1.0.4345 - as advised by Vodafone TechSupport.

     

    Once I installed the VMC software, all my other NIC's stop working.  The symptoms are:

    • all of the network connections (wired and wireless) are reported by the Network and Sharing centre as "Local Access Only";
    • I can't get internet access through any of the regular network connections;
    • none of the network connections are accepting DHCP IP addresses any longer (they all have a 169.254 subnet Microsoft default address);  and
    • if I set a static address on a network connection through Properties/IPv4, then I can ping local devices (eg, router, printer, other computers), but I can't ping the internet side of the router or any of the public web-sites.

    These problems persist, even if I uninstall the VMC software.  The only way to fix the problem is to perform a System Restore to the restore point immediately before the VMC was installed.  If I do this, then everything all my regular NICs and network connections start working again just fine - which kind of rules out the router/ADSL modem and cabling as being the cause(s) of the problem.

     

    I have been dealing with Vodafone 3rd line tech support over the last few days, and re-installed the VMC so we could try a few things.  As expected, as soon as the VMC was installed all the other network connections stopped working.  But then I found that if I re-booted my router the cable connection would start working again, at least until I re-booted the laptop.  Ugly, but at least I could work and could still debug it with Vodafone tech support.

     

    Unfortunatley, yesterday the cable connection stopped responding to the router-reboot trick.  Worse still, the VMC stopped supporting an internet browser session.  I can ping anything in the world from the Vodem connection, but only if I use an IP address.  That is, ping fails if I use a web address as the target (eg, "Ping www.yahoo.com").

     

    I have removed or disabled all the anti-virus, anti-spyware and firewall software on the laptop, including Windows Defender and Firewall, but no change.

     

    I have three other computers in my house, all connected to the internet via the same router (2 wireless and 1 wired).  All of these are working fine (I am typing this from the wired connection).  All of the desktops are running Windows XPSP2.  I have installed the VMC on the desktop that uses the wired connection to the router (Marvell Yukon Gigabit).  I can use the VMC to access the internet just fine, and it has not affected the wired connection at all (I am STILL typing this from the wired connection!).

     

    To my mind, all of that says that the problem is:

    1. related to Vista;  and
    2. related to the VMC.

    Can anyone help??  Vodafone are stumped and it is driving me crazy.

     

     

    Cheers

     

     

    MDL

     

    PS

    I must drop in a vote of extreme satisfaction with the Vodafone tech support guys. They have gone well above and beyond the levels of service and commitment that I have come to expect from hardware product call-centre tech support guys.  One guy (there are two) called Haithim, in partucular has been fantastic, is himself frustrated beyond belief and would love to see the answer pop-out of a forum like this.

     

    Wednesday, April 25, 2007 11:37 AM

All replies

  • Good day,

    I am having the exact same problems, none of my other networks want to work and my 3G/HSPA is not functioning correctly, I am going to re-install XP until to is sorted. I knew getting vista early would be a problem.
    Thursday, August 23, 2007 6:15 AM
  •  

    Excerpt from: http://exertrack.wordpress.com/2006/10/13/solved-windows-vista-and-vodaphone-3g/

     

    had same issue, the following worked for me:

    Start the VMC installer again by using VMC_R9.1.0.4345.exe,
    Choose the Modify option.
    For the ‘Optimisation Software’ choose
    ‘This feature will not be available’.
    and click Next.

    After installation finishes - reboot machine.
    After reboot DHCP should be workin again.

     

    Monday, January 14, 2008 10:47 PM