locked
Backups fail with Volume Shadow Copy operation failure RRS feed

  • Question

  • I know this is a common error, but I have tried everything suggested and it still won't work.

    Event viewer says:

    Error 521
    Volume Shadow Copy Service operation to create a shadow copy of the volumes being backed up failed with following error code '2155348129'

    When I do a "vssadmin list writers" I get this in the output:

    Writer name: 'Microsoft Hyper-V VSS Writer'
       Writer Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
       Writer Instance Id: {65583938-cf07-43a0-be3d-373a772c1a4c}
       State: [5] Waiting for completion
       Last error: Unexpected error

    so the VSS Writer clearly isn't happy.

    I have VMs containing Linux, Windows 2003R2 and Windows XP. I have updated the Hyper-V integration tools on each of the Windows VMs for 2008R2 and rebooted them.

    I have created the registry key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WindowsServerBackup\Application Support\{66841CD4-6DED-4F4B-8F17-FD23F8DDC3DE}
    and created in there a REG_SZ
    Application Identified = Hyper-V VSS Writer
    and rebooted.

    I have removed and re-installed the Windows Server Backup and rebooted.

    The only other thing I get is an error in the log for Microsoft-Windows-Hyper-V-VMMS/Admin which says
    No snapshots to revert were found for virtual machine 'JD jdsql Win2003R2'. (Virtual machine ID CF23E2D8-9A35-457F-B130-461BA4CCF88F)

    I've run out of ideas for things to fix.
    I still cannot backup my server. Before I upgraded from 2008 to 2008R2, all the backups worked fine.

    Please can someone help?
    Monday, August 17, 2009 7:13 PM

Answers

  • Hi,

    Did you upgrade from RTM to R2? If so, it seems a known issue. Development team is working on this issue.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Mervyn Zhang Monday, August 24, 2009 2:25 AM
    Tuesday, August 18, 2009 11:13 AM

All replies

  • You should ask this in the R2 virtualization forum.
    Tuesday, August 18, 2009 1:34 AM
    Moderator
  • Hi,

    Did you upgrade from RTM to R2? If so, it seems a known issue. Development team is working on this issue.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Mervyn Zhang Monday, August 24, 2009 2:25 AM
    Tuesday, August 18, 2009 11:13 AM
  • Hi,

    Having the same problem migrating from 2008 RTM to 2008 R2, unable to use Windows Server Backup utility to backup Hyper-V VM.
    Friday, August 21, 2009 1:41 PM
  • I posted in another thread that seems to be dead but the first post seems to be exactly what I'm seeing. 

    This is a clean install of RTM W2k8 R2.

    If I look at the Hyper-V-VMMS, I see this event.

    No snapshots to revert were found for virtual machine 'machineName-1'. (Virtual machine ID D2550806-423C-4347-83DE-4E53C0E2EE1C)

    Along with this error in the Application Log

    The backup operation that started at '‎2009‎-‎09‎-‎11T16:53:48.805000000Z' has failed because the Volume Shadow Copy Service operation to create a shadow copy of the volumes being backed up failed with following error code '2155348129'. Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

    Happens whether I try to backup system state or just directory in a non boot volume.


    kfrost
    Friday, September 11, 2009 5:06 PM
  • I also experienced this issue on a hardware server upgraded from Windows 2008 SP2 to R2.

    If you experience the unexpected WSB failure mentioned in the original post above, you activate the "automount" feature as follows:

    1. Open a Command Windows in elevated mode.

    2. At the command prompt, type MountVol /E, and then press ENTER.

     

    3. Reboot the server and run WSB again.  Now it should work.

    As an aside, before I began the upgrade, I had to remove the Hyper-V role in order to fully clear network teaming information on adapters, since I planed to re-arrange the NICs post-upgrade.  After upgrading, I installed updated NIC drivers and re-built the teams.  I was able to make a full WSB image before I re-installed the Hyper-V role, but not after - this was when I first got the error described above.  Moreover, when I attached a USB drive containing the VHDs I wanted to import, the disk would not mount because the "automount" feature had become disabled.  This was my first clue that there was an issue, which I did not realize at first, but in retrospect it clearly points it out.

    1010 Mancer
    MCITP-EA

    This thread also discusses the same issue:
    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/681c9e68-a58a-4f7e-b429-85c4f5567314

    Tuesday, January 5, 2010 7:01 PM
  • I also experienced this issue on a hardware server upgraded from Windows 2008 SP2 to R2.

    If you experience the unexpected WSB failure mentioned in the original post above, you activate the "automount" feature as follows:

    1. Open a Command Windows in elevated mode.

    2. At the command prompt, type MountVol /E, and then press ENTER.

     

    3. Reboot the server and run WSB again.  Now it should work.

    As an aside, before I began the upgrade, I had to remove the Hyper-V role in order to fully clear network teaming information on adapters, since I planed to re-arrange the NICs post-upgrade.  After upgrading, I installed updated NIC drivers and re-built the teams.  I was able to make a full WSB image before I re-installed the Hyper-V role, but not after - this was when I first got the error described above.  Moreover, when I attached a USB drive containing the VHDs I wanted to import, the disk would not mount because the "automount" feature had become disabled.  This was my first clue that there was an issue, which I did not realize at first, but in retrospect it clearly points it out.

    1010 Mancer
    MCITP-EA

    This thread also discusses the same issue:
    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/681c9e68-a58a-4f7e-b429-85c4f5567314


    Thank you very very very much for this tip! I tried so much things, but could not get this error resolved.

    When I entered mountvol at the promt the system displayed that it will Auto-Mount new drives. I ignored the message end used mountvol /E and rebooted. Now the message that it will automount new drives is gone and the Backup works, great!

     

    Wednesday, June 30, 2010 7:55 AM