none
Booting from USB CD drive and deploying from USB external drive RRS feed

  • Question

  • Hello,

    In our current setup we put a deployment share onto a USB external hard drive and burn the LiteTouch boot disk to a dvd. The machines we're deploying to do not/will not have network access of any kind so this use of external hard drive with USB optical drive has been the best solution we can come up with.

    The issue I'm seeing comes with one of our deployments that ends up deploying Windows 7. On the boot disk in Windows PE it is in a Windows 10 like environment, after it installs the OS and reboots it goes into Windows 7. When this occurs, sometimes the drive letters of the USB CD drive and the external hard drive get flipped, causing the task sequence to not be found and the deployment to fail(i.e. in PE the external drive was on D:\ after reboot into Win 7 it is now labelled E:\ and the task sequence is not found). To fix this, whoever is deploying must unplug the USB CD drive as soon as Windows PE is loaded, this is a situation we'd prefer to avoid.

    Things I've Tried:
    * Assigning drive letter in Windows PE. I assigned the external drive to R: prior to installation, after booting into Windows 7 the drive letters were all reassigned and the deployment failed.

    * Bootable external drive - I tried making the external drive itself bootable to eliminate the need for the optical drive, it seems the model laptop I'm deploying to emulates uefi boot and this failed. I may try another approach here if there are suggestions.

    Wondering if anyone has run into an issue similar to this? Any suggestions are greatly appreciated. Thanks.

    EDIT/UPDATE: I may have posted this too soon, I've gotten the USB external drive to boot successfully without the CD drive. Hoping this fixes my issue. 

    James


    • Edited by jamesrummel Tuesday, September 4, 2018 5:23 PM
    Tuesday, September 4, 2018 4:48 PM

Answers

  • I seem to have gotten this working via the bootable USB drive so I'll make a quick write up in case this can help someone else.

    The Problem: We were using a USB CD drive to boot the LiteTouch_x64.iso and a USB external drive to store all of the deployment share files and do installations. The OS we were ultimately deploying was Windows 7, the Windows PE environment we would boot into was Windows 10 esque. Both the CD drive and the external USB hard drive would be plugged into the machine at the same time. After the initial installation of the operating system the deployment would reboot. Upon reboot we would enter Windows 7. At this time the drive mapping of the external drive and the CD drive would switch for some reason, perhaps because Windows PE doesn't map CD drives (i.e. if external drive was mapped to D:\ in Windows PE upon reboot into Win7 it would be mapped to E:\). At this point the deployment would fail with "Unable to find the SMS Task Sequencer. The deployment will not proceed."

    The Workaround: I've made the external USB drive bootable which circumvents this issue via the steps found here:  http://www.sysadminlab.net/other/creating-a-bootable-usb-for-installing-windows-7-or-windows-2008-r2

    I encountered another issue with this method with BIOS boot priority where it would continuously boot into the USB drive instead of continuing with the deployment. Despite finding some solutions to this on the internet, they didn't seem to fix my problem so I adjusted the workflow to leave the actual HDD as the main boot device of the machine and do a one-time boot into the external USB hard drive. If that is not an option for you this link might help you, although it did not help me: https://serverfault.com/questions/849483/mdt-v-8443-adk-v-1703-boot-order-changed-after-post-install-using-uefi

    Goodluck.


    • Marked as answer by jamesrummel Tuesday, September 4, 2018 8:12 PM
    • Edited by jamesrummel Tuesday, September 4, 2018 8:33 PM
    Tuesday, September 4, 2018 8:11 PM