locked
Unable to install .NET framework / SFC scan fails / SP1 update not available RRS feed

  • Question

  • Hi All,

    I figure that the 3 issues mentioned in the subject are related. Basically,

    1. Windows update keep trying to install .NET 2.0SP1 onto my Vista Business x64 install (KB110806), but keeps failing with error code 80091007, which I can find no information for. This is in turn not allowing me to install .NET 3.5 via the bootstrapper nor the redist package.
    2. Most solutions to issue one are to run SFC /Scannow, which itself fails at 23% with the error "Windows Resource Protection could not perform the requested operation"
    3. Additionally, however probably related is the issue of Vista Service Pack 1. SP1 has never been available to me on Windows update.
    It's worth noting that I have tried various methods of working around this, including re-installing Vista several times, and using a different DVD, however none of this has helped.

    Where do I go from here? I'm running out of ideas, and it would seem like a waste to have to resort to installing XP or Vista 32-Bit given that I have a fairly high-end system, and I'd lose some RAM availability.

    Many thanks in advance,

    -- Karl Nicoll
    Tuesday, July 22, 2008 6:07 PM

Answers

All replies

  • Vista Service Pack 1 includes the .NET 2.0 SP1.  Install Vista SP1 and your issue should be resolved:

     

    Windows Vista Service Pack 1 Standalone (KB936330)

    http://www.microsoft.com/downloads/details.aspx?FamilyID=b0c7136d-5ebb-413b-89c9-cb3d06d12674&DisplayLang=en

     

    Learn how to install Windows Vista Service Pack 1 (SP1)
    http://windowshelp.microsoft.com/windows/en-us/Help/133c8953-c9cd-4fa5-8883-03e91bb6f2021033.mspx

    Tuesday, July 22, 2008 6:37 PM
  • Well Vista SP1 isn't listed in Windows update, which, according to Microsoft's article means that something is blocking it, but I don't know what. None of the bad drivers apply to me, and Windows update tells me I'm up to date, and I have no hidden updates. Would it be wise to try installing SP1 anyway?
    Tuesday, July 22, 2008 10:18 PM
  • Yes.  Download and install the standalone version of SP1.

     

    Tuesday, July 22, 2008 10:20 PM
  • OK I tried that and I'm getting:

    ---------------------------
    Error
    ---------------------------
    An internal error occurred while installing the service pack.

    Error code: 0x80091007.  See http://go.microsoft.com/fwlink/?LinkId=101139 for details.
    ---------------------------
    OK  
    ---------------------------


    I've tried rebooting, but that hasn't helped, and strangely, shortly after I get the error, SuperFetch crashes. Where do I go from here?

    Thanks for your help so far, I am very grateful!

    Tuesday, July 22, 2008 11:29 PM
  • Wednesday, July 23, 2008 2:06 AM
  • I definately have Vista (x64) SP1 installed - and (finally after much angst) all current updates - however .net 3.5 SP1 still refuses to install, returning 

    [11/09/08,17:15:31] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2146889721
    [11/09/08,17:15:48] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (x64) (CBS) is not installed.

    This is despite the fact that I have got the latest Windows Update & Installers, have run a repair 

    net stop wuauserv
    cd %systemroot%\SoftwareDistribution
    ren Download Download.old
    net start wuauserv
    net stop bits
    net start bits

    as recommended in another forum (by the way this helped me to install a lot of updates that previosuly failed to install

    and even tried Aaron Stebner's suggestions on hist excellent blog.

    I really am at wits end now having burn't yet another weekend of continual re-boots - trying to get .net 3.5SP1 installed so I can use Expression Blend with SP for Silverlight 2.0.

    I am even considering downgrading from Vista Business x64 to x32 (on My t61p thinkpad, I cant use graphics in 32 bit mode anyway because the Nvidia driver is so unstable.

    If anyone has any other ideas before I waste a day loading my machine up again I would be eternally grateful.

    Oh, and the dd_depcheck_NETFX_EXP_35.txt (AppData/Local) seems to think that nothing should be installed.

    [11/09/08,17:15:41] ================================================ [11/09/08,17:15:41] Begin Depchek Component session: gencomp753,{61040379-156d-4ece-b126-ea395a3b2ac7} [11/09/08,17:15:41] This component uses the FileRegVerCheck version check method. It will compare a given version against the version of a regkey on your machine. [11/09/08,17:15:41] Registry key being interrogated: HKLM,SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v3.0\Setup; Value: Version; Version: 3.0.30618.00. [11/09/08,17:15:41] Version on user's machine: 3.0.04506.648 [11/09/08,17:15:41] Version to be installed: 3.0.30618.00 [11/09/08,17:15:41] This component is told to not ignore newer versions. [11/09/08,17:15:41] End. Component is NOT installed [11/09/08,17:15:41] ================================================ [11/09/08,17:15:41] Begin Depchek Component session: gencomp751,{61040379-156d-4ece-b126-ea395a3b2ac7} [11/09/08,17:15:41] This component uses the FileVersionCheck version check method. It will compare a given version against the version of a file on your machine. [11/09/08,17:15:43] The file to be verified is C:\Windows\microsoft.net\framework\v2.0.50727\mscorwks.dll. [11/09/08,17:15:43] Version on user's machine: 2.0.50727.1434 [11/09/08,17:15:43] Version to be installed: 2.0.50727.3053 [11/09/08,17:15:43] This component is told to not ignore newer versions. [11/09/08,17:15:43] End. Component is NOT installed [11/09/08,17:15:44] ================================================ [11/09/08,17:15:44] Begin Depchek Component session: gencomp218 [11/09/08,17:15:44] This component is told to not ignore newer versions. [11/09/08,17:15:44] End. Component is NOT installed

    Help !
    Sunday, November 9, 2008 5:49 PM
  • Hey,

    I don't know if this will apply to you, but the actual problem for me was in fact a defective RAM module, I've since had the module replaced by the supplier, and everything installed beautifully!

    Hope this helps,

    -- Karl Nicoll
    Sunday, November 9, 2008 7:39 PM
  • Thanks Karl,

    You may just be onto something here. I will seriously look into this as yesterday whilst doing some fairly intensive work (hammering the laptop), I had a number of strange msmq related issues I had never seen before. A reboot and all was cured.

    Not totally convinced this will cure my .net 3.5 SP1 install issues - but it might just cure the video issue.

    Will try and sort out my hardware and report back if it also cures the .net issue.

    Thanks for the tip.
    Thursday, November 13, 2008 1:08 PM
  • It sounds to me like you're one of those people who go through laptops like they're going out of fashion!

    I just pity the poor, over-worked, intelligent and astonishingly handsome Sysadmin who needs to sort this out for you. I hope you're giving him money for his help. In my experience, about £50 ought to cover it.
    Thursday, November 13, 2008 1:27 PM
  • The solution for me was installing .net framework 3.5, BEFORE trying to install 3.5 SP1 (event though the SP1 package included the whole 3.5 RTM).
    Thursday, January 22, 2009 2:49 AM