locked
Error 26 RRS feed

  • Question

  • Hi there,
    trying to connect with SQL Server managment studio express (2005) to a SQL Server 2008 (if this already is a problem please say so further reading not nessacery then :p). Basicly the problem i encouter is the following:

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to XXXXXXXXXX.

    ------------------------------
    ADDITIONAL INFORMATION:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1)

    For help, click:
    http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=-1&LinkId=20476

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    I checked the named pipes they are enabled. Also mayed to exception in the firewall port 1433 TCP and 1434 UDP. SQL Browser is running as a service.

    Any ideas?

    Grtz,
    Keepow
    Thursday, February 4, 2010 8:32 AM

Answers

  • That is a browser response on 1434, telling you that the server is listening on port 49229 right now (probably using dynamic ports).  If you specify <ServerName>\SQL2008 in Management studio, it should connect right up with no problems as long as 1434 and 49229 aren't blocked (note that 49229 is only for this execution context and may change on server restart if it is using dynamic ports, which it seems like it is doing).


    Hope that helps,

    John
    This post is provided 'as is' and confers no express or implied warranties or rights.
    Friday, February 5, 2010 2:18 AM

All replies

  • Do you enable and active that port and ip addresses in sql server configuration manager->sql server network configuration->protocols for mssqlserver.
    Double click TCP/IP then configure in IP Addresses tab page?
    Please help us improve this community forum for visitors by marking the replies as answers if they help and unmarking them if they provide no help.
    Thanks.
    Thursday, February 4, 2010 10:55 AM
  • I did, enabled it and put port to 1433 TCP. When i portqry i get this:

    When i portqry on port 1433:

    C:\PortQryV2>portqry -n xxxxxxxxxxxxxxx -p tcp -e 1433

    Querying target system called:

    xxxxxxxxxxxxxxx

    Attempting to resolve IP address to a name...


    IP address resolved to xxxxxxxxxxxxxxx

    querying...

    TCP port 1433 (ms-sql-s service): NOT LISTENING

    When i try it on port 1434:

    C:\PortQryV2>portqry -n xxxxxxxxxxxxxxx -p UDP -e 1434

    Querying target system called:

    xxxxxxxxxxxxx

    Attempting to resolve IP address to a name...


    IP address resolved to xxxxxxxxxxxxx

    querying...

    UDP port 1434 (ms-sql-m service): LISTENING or FILTERED

    Sending SQL Server query to UDP port 1434...

    Server's response:

    ServerName xxxxxxxxxxxxxxx
    InstanceName SQL2008
    IsClustered No
    Version 10.0.2531.0
    tcp 49229
    np \\xxxxxxxxxxxxx\pipe\MSSQL$SQL2008\sql\query

    ^ +`

    ==== End of SQL Server query response ====

    UDP port 1434 is LISTENING
    Thursday, February 4, 2010 11:10 AM
  • That is a browser response on 1434, telling you that the server is listening on port 49229 right now (probably using dynamic ports).  If you specify <ServerName>\SQL2008 in Management studio, it should connect right up with no problems as long as 1434 and 49229 aren't blocked (note that 49229 is only for this execution context and may change on server restart if it is using dynamic ports, which it seems like it is doing).


    Hope that helps,

    John
    This post is provided 'as is' and confers no express or implied warranties or rights.
    Friday, February 5, 2010 2:18 AM
  • Can you double-check that you have typed the correct instance name? And verify that "SQL2008" is the instance you are interested in connecting to?

    Friday, February 5, 2010 5:55 PM
  • Yeah, im off work now :p so check it monday. But i am 100% sure the instance name is correct. Is it an option that the router is blocking the port?
    Thnx for the help so far, hope we figure it out soon :P.
    Friday, February 5, 2010 6:54 PM
  • Given the behavior you described, the only possible reason I can think of is that wrong server name or instancename is specified.  What's the exact info here:
    Cannot connect to XXXXXXXXXX.

    You can hide server name.
    Friday, February 5, 2010 7:47 PM