none
Network adapter metrics do not match adapter orderings after recent Microsoft Updates

    Question

  • Windows 7 Professional 64-bit laptop with WiFi and ethernet network adapters in use.  All available windows updates are installed.  I use Wi-Fi as my primary network connection to our office network and the internet beyond.  I use the ethernet adapter to connect to cellular routers for troubleshooting and configuration.  In this use case, I want ALL my company and internet traffic to go over Wi-Fi and only local on-subnet traffic to go to the cellular router over ethernet.

    On April 2nd, 3 updates from from Microsoft Update were installed:  KB4088881, KB4100480 and KB4099950.  Right after that, I noticed that when I plugged into a cellular router, my internet-directed traffic tried to go out through the cell router.  That router was not connected to a cell carrier (like AT&T or Verizon) at that time, so the traffic could not get anywhere beyond the router.  This was immediately noticeable because my email and other web browsing sessions I had opened suddenly couldn't connect.

    I opened the CMD window and did a ROUTE PRINT.  It showed the ethernet connection (192.168.13.xxx) with a lower metric than the Wi-Fi connection (192.168.128.xxx), even though in Control Panel > Network Connections > Advanced Settings > Adapters and Bindings, the Wireless Network Connection is at the top of the list and the Local Area Connection is at the bottom of the list.

    IPv4 Route Table

    ===========================================================================

    Active Routes:

    Network Destination        Netmask          Gateway       Interface  Metric

              0.0.0.0          0.0.0.0    192.168.XXX.1  192.168.XXX.230     21

              0.0.0.0          0.0.0.0    192.168.XX.31   192.168.XX.100     10

            127.0.0.0        255.0.0.0         On-link         127.0.0.1    306

            127.0.0.1  255.255.255.255         On-link         127.0.0.1    306

      127.255.255.255  255.255.255.255         On-link         127.0.0.1    306

         192.168.XX.0    255.255.255.0         On-link    192.168.XX.100    266

       192.168.XX.100  255.255.255.255         On-link    192.168.XX.100    266

       192.168.XX.255  255.255.255.255         On-link    192.168.XX.100    266

        192.168.XXX.0    255.255.255.0         On-link   192.168.XXX.230    276

      192.168.XXX.230  255.255.255.255         On-link   192.168.XXX.230    276

      192.168.XXX.255  255.255.255.255         On-link   192.168.XXX.230    276

            224.0.0.0        240.0.0.0         On-link         127.0.0.1    306

            224.0.0.0        240.0.0.0         On-link    192.168.XX.100    266

            224.0.0.0        240.0.0.0         On-link   192.168.XXX.230    276

      255.255.255.255  255.255.255.255         On-link         127.0.0.1    306

      255.255.255.255  255.255.255.255         On-link    192.168.XX.100    266

      255.255.255.255  255.255.255.255         On-link   192.168.XXX.230    276

    ===========================================================================

    I have uninstalled the 3 updates and even added a persistent route to set the Wi-Fi default route metric to 1, but that doesn't seem to help.  When I connect a cell router to my ethernet port (which gets a 192.168.x.x DHCP address from the cell router), all traffic goes out that interface (confirmed with traceroutes).

    Persistent Routes:

      Network Address          Netmask  Gateway Address  Metric

              0.0.0.0          0.0.0.0    192.168.XXX.1       1

    This laptop has worked fine for 1.5 years by having Wi-Fi as the higher ordered connection, until last week.  Has anyone seen this kind of behavior?


    Monday, April 9, 2018 9:08 PM

Answers

  • Hi,

    Please try to take following steps to set a specific metric with the Wi-Fi network adapter interface.

    1. Open Control Panel -> Network and Sharing Center -> click Change adapter settings on the left panel.

    2. Right-click Wi-Fi network interface, and then click Properties.

    3. Click Internet Protocol (TCP/IP), and then click Properties.

    4. On the General tab, click Advanced.

    5. On the IP Settings tab, click to clear the Automatic metric check box, and then enter the metric that you want in the Interface Metric field.

    Note: Please hide your IP address with *.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by dtbc Tuesday, April 10, 2018 1:27 PM
    Tuesday, April 10, 2018 8:14 AM

All replies

  • Hi,

    Please try to take following steps to set a specific metric with the Wi-Fi network adapter interface.

    1. Open Control Panel -> Network and Sharing Center -> click Change adapter settings on the left panel.

    2. Right-click Wi-Fi network interface, and then click Properties.

    3. Click Internet Protocol (TCP/IP), and then click Properties.

    4. On the General tab, click Advanced.

    5. On the IP Settings tab, click to clear the Automatic metric check box, and then enter the metric that you want in the Interface Metric field.

    Note: Please hide your IP address with *.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by dtbc Tuesday, April 10, 2018 1:27 PM
    Tuesday, April 10, 2018 8:14 AM
  • Thank-you.  The metric of 1 that I had set on the command line was there, but unchecking the Automatic metric box is what fixed it.  Now the Wi-Fi default route has a better metric than the ethernet default route.
    Tuesday, April 10, 2018 1:27 PM