none
Add-AppvClientPackage Error Code: 0C801F0015

    Question

  • We have multiple apps that are randomly failing to get added/published.  We are adding/publishing app-v 5 apps via group policy and they are using the file streaming method rather than an app-v server.   The error Im seeing is below. 

    Add-AppvClientPackage : Application Virtualization Service failed to complete requested operation.
    Operation attempted: Configure AppV Package.
    AppV Error Code: 0C801F0015. Error module: Streaming Manager. Internal error detail: 4C401C0C801F0015.

    I can logon to 25 PCs and only see it fail on between 1 to 3 of them, it happening on other PCs as well.  It is not the same machines failing each time and not always the same app that fails to be added.  We are running the v5 sp1 client on Windows 7.  I can run the powershell script manaully on the computers that fail and it works.  I added a 5 second delay in the powershell script and it seems to be happening less but still occurs.

    I cant find any reference to 0C801F0015.

    Anyone have any ideas?

     

    Monday, September 23, 2013 7:26 PM

All replies

  • After several attempts I was able to catch the problem with logging enabled.  It still looks like a timing issue to me but we dont have this problem with app-v 4. 

    It looks to me like its trying to create the package about 3 hundredths of a second before the filter is attached to the volume and I dont know why that is.  In this case a second package was succesfully published about a tenth of a second later.  Its not the package or the hardware because it happens with different packages and on numerous PCs.  Waiting 7 seconds before run the powershell to add the package reduces the frequency but it still happens.  I can tell that it has failed 56 times out of 898 attempts to add packages.

    streaming-filter:

    15:12:31.802028700Z
    Eventid 1: Microsoft Windows Streaming Mini-Filter was loaded successfully.

    15:13:49.682826600Z
    EventID 28: Filter might not be attached to the volume. Couldn't find instance for volume \Device\HarddiskVolume2 . Failure Status 0xc01c0015.


    15:13:49.682826600Z
    EventID 40: A create package file message failed. Failure Status 0xc01c0015.


    15:13:49.714887800Z
    EventID 5: Microsoft Windows Streaming Mini-Filter was attached to successfully to volume.


    streaming-manager:

    15:13:49.682826600Z
    EventID 43: Microsoft AppV Streaming Manager failure to create file on Add activity:  Activity Id 0, Package Key {f4d0fbe6-4aec-4b25-aa3f-fc5a9916a034}, Result The system could not find the instance specified., Filename C:\ProgramData\App-V\7FF81AE1-144F-44FA-AEBE-2B4F7BCB8E01\F4D0FBE6-4AEC-4B25-AA3F-FC5A9916A034\.

    15:13:49.779010200Z
    EventID 71: Microsoft AppV Streaming Manager Stage-File succeeded: Package Version {c7a8f673-b92c-4ec5-87e4-aebb21adcf14}, file C:\ProgramData\App-V\D6D3B887-DFC4-4A58-8BED-CAB28FAD7C3E\C7A8F673-B92C-4EC5-87E4-AEBB21ADCF14

    Wednesday, September 25, 2013 5:54 PM
  • Hello,

    I would suggest you retest the scenario with App-V 5.0 SP2 beta.


    Nicke Källén | The Knack| Twitter: @Znackattack

    Thursday, September 26, 2013 8:03 PM
  • So what you need to look at is the filter driver configuration.

    App-V 5 leverages standard HREFs and not the old proprietary Softgrid codes. This is a good thing for research. Take the last 8 digits and that will be your HREF. In this case it is 0x801F0015. This error translates to: ERROR_FLT_INSTANCE_NOT_FOUND

    Run a Command prompt as an admin and run the command "fltmc"

    What is the output?

    I'm curious to see the filter stack. You should see AppVVfs, AppVStream, and AppVVeMgr. What else is there?


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Sunday, September 29, 2013 4:14 AM
  • fltmc output

    Filter Name                     Num Instances    Altitude    Frame
    ------------------------------  -------------  ------------  -----
    AppvVfs                                 0       404700         1
    DFFilter                                        389998.99   <Legacy>
    BHDrvx86                                4       365100         0
    eeCtrl                                  4       329010         0
    SRTSP                                   5       329000         0
    SymEFA                                  5       260600         0
    AppvStrm                                1       180710         0
    luafv                                   1       135000         0
    FileInfo                                5        45000         0
    AppvVemgr                               0        40800         0

    The DFFilter would be deppfreeze.

    Sunday, September 29, 2013 9:03 PM
  • hello,

    Have you tried it without any 3-party filter drivers (such as deepfreeze?)


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, September 30, 2013 11:16 AM
  • Given the dificulty of recreating the problem, no.  With deepfreeze, I can reboot the machines and try to add the package and repeat that process many times (on 25 PCs) to catch the problem.  Adds succeed most of the time so without deepfreeze, I would then have to remove all the packages on all 25 PCs in order to test again.  That would greatly complicate the testing process.  I would also note these machines in are production, if I remove deepfreeze and make any changes, I run the risk of breaking the entire lab.  Yesterday I was only able to catch the problem 3 times out of a few hundred boots but it seems to very.
    Monday, September 30, 2013 12:30 PM
  • Hello,

    OK, lets assume that DeepFreeze breaks everything....

    If you test this on a completely different PC which has nothing todo with the ones you are currently troubleshooting, and this different-PC doesn't have deepfreeze on it.

    Can you repeat the issue?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, October 01, 2013 5:39 AM
  • I have not been able to recreate the problem in my office even with deepfreeze so I havent been able to test that. 
    Wednesday, October 02, 2013 12:28 PM
  • Hello,

    Whats different with your Office-PC and the ones in the lab?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Tuesday, October 08, 2013 5:57 AM
  • Thursday, July 10, 2014 9:22 PM