locked
USB PROBLEMS WITH DRIVERS ON VISTA RRS feed

  • Question

  • I Have recently bought a new laptop with Vista Home Premium.

    Since I have been using it I have had constant problems connecting hardware through the usb ports.

    initially when connected Vista goes through the routine of trying to install the hardware but ends up with the following message.

    "windows encountered a problem insrtalling the driver software for your device"

    "Windows found driver software fro your device but encountered an error while attempting to install it."

    The driver installation file for this device is missing a necessary entry.This may be because the INF was written for windows 95 or later.Contact your hardware vendor."

    I have managed a fix by telling it to manually install from c:windows (ensuring that the subfolders box is checked) but this does not work for all.

    I still cannot connect a USB browser mouse and my Lexmark P6150 printer.

    Any ideas anyone?

    Monday, March 12, 2007 8:38 PM

All replies

  • I've come across at least a dozen different posts on this, and no one can seem to identify the issue. I'm having the same problem, and I'm not convinced that it's a USB issue. I have the same problem with two mice--one USB and the other Bluetooth. And they're Microsoft devices. I just got off the phone with MS hardware support, and they told me it's a Vista issue. I'm about to call Vista support, so they can tell me it's a hardware issue. :)
    Friday, March 23, 2007 10:07 PM
  • hi there, i had the same problem with vista. Heres how i solved it

    go to device manager and go to the properties of the unknown device. then click update driver.

    click on install manually

    next you need to browse to this place

    C:\Windows\System32\DriverStore\FileRepository\

    then find the folder that begins with msmouse open then select this folder

    in the text box it would look something like

    C:\Windows\System32\DriverStore\FileRepository\msmouse.inf_{Some Id Here}

    { Some Id Here } being the id for your computer

    then click next / install

    its a hid - compliant mouse you need not a usb browser mouse

     

     

    Thursday, March 29, 2007 1:53 PM
  • Yes, this is the way to fix it.... Good post.
    Saturday, November 3, 2007 9:02 PM
  • Just to add that I was beating my brains out for about an hour trying to get a laser pointer / page controller to work - nothing on the manufacturer's site of course. However this fix has worked perfectly. Thanks for the excellent post.

     

    Thursday, December 13, 2007 7:43 PM
  • This worked GREAT and got my Targus PAUM01U working like a charm, even though I had deleted the unknown device as I was trying to get things going.  Thanks much crampz!

     

    Wednesday, January 16, 2008 3:42 AM
  •  

    this worked perfect. thankyou for the post. i was beating my brain out for a couple of hours try different things but this works...
    Sunday, March 9, 2008 7:20 PM
  • I found this in a forum and might help you the way it helped me.

    His name was Dragor

    Step 1: Hit Win+f { Hold Windows Key and simultaneously press f} and click on Advanced Search.

     Step 2: In "Locations" Select the drive where Vista is installed and remember to tick mark the "Include non-indexed, hidden, and system files (might be slow" check box.

     Step 3: In the highlighted search box, type "volume*.*" [Obviously, without the quotes] and wait for the search to get completed.

     Step 4: Once u have located the volume.inf file, copy it and paste it in "C:\Windows\Inf" folder. I've used a hack to put Copy to in right click of every file.

    Step 5: Now close everything and come back to desktop. Click on start and type cmd in the Start search box BUT do not click on it or press enter. Instead, right click it and select run as administrator. The Window of Command prompt MUST read "Administrator: Command Prompt".

     Step 6: Now type:

     set devmgr_show_nonpresent_devices=1

     and press enter. Now in that same window type:

     devmgmt.msc  and press enter. Device manager should now open. Now click on View menu and click on show hidden devices menu.

    Step 7: Expand the Disk Drives entry and u should find ur USB flash disk in disabled state. right click it and uninstall it. After
    uninstalling, connect your USB flash disk and voila! The system finds the drivers!
    Tuesday, March 11, 2008 7:58 AM
  • You are truly a genius! I found two entries with msmouseinf. It was the second one. My mouse now works.

    Thanks!
    Monday, December 22, 2008 9:24 PM
  • Im having the same issue but its with a MIDI controller device, and the drivers are located on the cd and after installation, i dont know where the drivers go,

    im trying to install virtual DJ and use Mixtrack pro, everytime the device is plugged in i get the same errors and the drivers have already been installed, the device is technically not even supposed to need drivers, but vista does not recordnize, and the application only runs if the device is plugged in, if i could do the same thing youve just described except with my controller i would greatly appreciate it

    Thursday, April 7, 2011 11:54 PM