locked
Windows 7 + Office 2007 & 2010 VERY slow saving files to on 2008 R2 files shares RRS feed

  • Question

  • OK I have litterally tried everthing in every forum there is to resolve this. It is only happening on our Win 7 workstations that are running Office 2007 or 2010.  Our file shares are on a 2008 R2 server. Opening and saving files on the shares using Office is very slow. I have tried updates and server and workstations are 100% up to date. The server is only running as a file share server. Nothing else on it. We have completely set up new PC's to test with clean Win 7 installs and nothing else except Office. Nothing else on the network is slow at all. I have tried all the hotfixes in the world that could relate to this from many hours of research into possible causes. I have done the EnableShellDataCaching fix, the SMB 2 disable fix, the windows search/indexer fix, the pdfmaker fix, the lookup wizard add-in fix, the go to the newest firmware on the cisco switch fix, update workstation nic driver fix, the Trusted Locations in Excel fix, and about a dozen other fixes. NOTHING WORKS! This has brought our Win 7 and Office 2007/2010 users to a halt in their ability to do their jobs. Our company is suffering badly. And did I mention that our IT dept is getting a lot of heat and criticism about it. FYI we are running an IBM E5450 with dual multi-thread multi-core(8) 3 Mhz Intel Xeon processors with 2008 R2 64-bit, 12 GB ram, and the server is using litterally no resources. Network connected is Gigabit. This has to be a Microsoft issue with 2008/Win 7/Office 2007&2010. This has become a nightmare for out IT dept and has consumed weeks of our time when we need to be working on other projects. Can anyone solve this. Microsoft: Please release a REAL fix for this that we can run on the server or push via GPO to the workstations.

    Wednesday, October 20, 2010 2:39 PM

Answers

  • Hi,

    Take a look at this and see if it helps:

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    also

    Office 2010 components, such as Word 2010?

    At this time, I suggest trying to start Excel in safe mode. Then, open the Excel file or create a new Excel file, and save the file to the network again.

    Start the Excel program in safe mode
    1.       Click Start, point to All Programs, and then point to Microsoft Office.
    2.        Press and hold the CTRL key, and then click the Microsoft Excel.

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Excel program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Excel program:

    Disable add-ins
    ***********
    Click File menu, click Options >  Add-in, click Go button in the Manage: Com-in Add.
    Check if there are any add-ins, clear the checkbox to disable them.
    Close the Office program and restart it.
    Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.
     
    Please take your time to try the suggestions and let me know the results at your earliest convenience.  If anything is unclear or if there is anything I can do for you, please feel free to let me know.
    ====
    Is the performance also slow when you trying to save the Excel file to other network path?

     

    At this time, we can also try to test this issue in the clean boot mode.

     

    Test in Clean boot Mode

    ===============
    Let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.
    Note: If prompted, please click Continue on the User Account Control (UAC) window.
    2.        Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3.       Click the "Startup" tab, click "Disable All" and click "OK".

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This should not affect the system or other programs. We may still manually run these programs later.

    What’s the result now?

    How to return from the Clean Boot state
    --------------------------
    After the troubleshooting, we can return from the clean boot state:
    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.
    Note: If prompted, please click Continue on the User Account Control (UAC) window.
    2.       On the "General" tab, click "Normal Startup - load all device drivers and services".
    3.       Click OK. Click Restart when you are prompted to restart your computer.


    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Cheers, Shane Devenshire
    • Marked as answer by Jennifer Zhan Monday, October 25, 2010 1:40 AM
    Thursday, October 21, 2010 7:14 PM

All replies

  • I too am seeing this exact problem.  My enviroment is a little different but most of the players are the same.  SBS2008 Premium server on a Supermicro super server less than a year old.  ALL other services are just fine, it is only a Windows 7 pc, Office 2007 or 2010 slow to open excel files from a share on the SBS2008 server.  Since SBS 2008 is just Server 2008 it is a very similar enviroment.  Even a brand new pc with Windows7 Professional and Office 2010 has this problem.  I too have tried ALL of the other advice out there on the internet with no luck.

    NOTE: This problem does NOT occur on a Windows XP SP3 pc with Office 2007/2010.

    • Edited by Questor4 Wednesday, October 20, 2010 9:37 PM update with new info
    Wednesday, October 20, 2010 9:35 PM
  • We are having the same issues, just now rolling out windows 7. No problems with XP, and not a problem if you are a domain admin. One suggestion was to "optimize" the share choosing documents, on the properties of the share on the win 7 workstation. I have not tried that yet.
    Thursday, October 21, 2010 5:29 PM
  • Hi,

    Take a look at this and see if it helps:

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    also

    Office 2010 components, such as Word 2010?

    At this time, I suggest trying to start Excel in safe mode. Then, open the Excel file or create a new Excel file, and save the file to the network again.

    Start the Excel program in safe mode
    1.       Click Start, point to All Programs, and then point to Microsoft Office.
    2.        Press and hold the CTRL key, and then click the Microsoft Excel.

    If the problem does not occur in the safe mode, this issue might be related to some third-party add-ins in the Excel program, we can try to disable them. Normally, you could do the following to disable the conflict add-ins in your Excel program:

    Disable add-ins
    ***********
    Click File menu, click Options >  Add-in, click Go button in the Manage: Com-in Add.
    Check if there are any add-ins, clear the checkbox to disable them.
    Close the Office program and restart it.
    Add one check back each time to the list of Add-In, restart the Office program, and repeat the above procedure. Once the issue reappears again, we can determine which add-in causes this problem and then disable it.
     
    Please take your time to try the suggestions and let me know the results at your earliest convenience.  If anything is unclear or if there is anything I can do for you, please feel free to let me know.
    ====
    Is the performance also slow when you trying to save the Excel file to other network path?

     

    At this time, we can also try to test this issue in the clean boot mode.

     

    Test in Clean boot Mode

    ===============
    Let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.
    Note: If prompted, please click Continue on the User Account Control (UAC) window.
    2.        Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).
    3.       Click the "Startup" tab, click "Disable All" and click "OK".

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

    Note: Temporarily disabling the Startup Group only prevents the startup programs from loading at startup. This should not affect the system or other programs. We may still manually run these programs later.

    What’s the result now?

    How to return from the Clean Boot state
    --------------------------
    After the troubleshooting, we can return from the clean boot state:
    1.       Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.
    Note: If prompted, please click Continue on the User Account Control (UAC) window.
    2.       On the "General" tab, click "Normal Startup - load all device drivers and services".
    3.       Click OK. Click Restart when you are prompted to restart your computer.


    If this answer solves your problem, please check Mark as Answered. If this answer helps, please click the Vote as Helpful button. Cheers, Shane Devenshire
    • Marked as answer by Jennifer Zhan Monday, October 25, 2010 1:40 AM
    Thursday, October 21, 2010 7:14 PM
  • I feel your pain! I have gone through nearly the same gauntlet of troubleshooting as you. A Win7 reload, Office reload (2007), clean upgrade to Office 2010, a new and different branded laptop...the works. Even as far as re-cabling with CAT6. And I concur, it had NO problems using WinXP under the same login scripts, same mapped drives, and whatever else has been pointed at as the cause. For what it's worth, the only thread of a clue in the latest attempt, was that I noticed Application Experience service started. It does not make sense but I am drawing desperate straws here, and since the service happened to coincide with the Word "not responding" issue, it's on the chopping block today.

    I will post the results.


    Ranie Sturba
    Monday, October 25, 2010 9:54 PM
  • Well, that idea fizzled. Still having the problem
    Ranie Sturba
    • Proposed as answer by TARSK Tuesday, October 26, 2010 2:13 AM
    Monday, October 25, 2010 10:44 PM
  • Opps lost my reply, thought I was proposing a solution.

    We made progress with our issue.  The security dept changed a local policy: User Account Control: Run all administrators in Admin Approval Mode.  But the server was not re-started as required before the change would take effect.  This was done to disable User Access Control.  After re-starting, our access issues went away. 

    Check your group policy or local policy for this setting and if you have a re-start pending.


    Ted
    Tuesday, October 26, 2010 2:21 AM
  • Thank you for bringing this attention to the forum.  In order to better assist you, can you please check the build and date stamps of the following files on both the client machines and the server:

    MRXSMB.SYS
    Client Build:

    Server Build:


    RDBSS.SYS

    Client Build:

    Server Build:


    a. If the date timestamps do not reflect May 2010 or later please install the following:

    Windows 7
    A computer that is running Windows 7 or Windows Server 2008 R2 takes four minutes to open a Microsoft Office 2003 document from a network share

    http://support.microsoft.com/kb/981872   

    AND

    982860 A computer that is running Windows 7 or Windows Server 2008 R2 takes four minutes to open a Microsoft Office 2003 document from a network share

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;982860  


    Server:
    981964 You experience low performance when you access many small files on an SMB version 1 protocol-enabled remote server from a Windows Vista or Windows Server 2008-based client computer

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;981964   

    AND

    983458 You cannot save documents to a folder or change the permission settings of folders on a SMB 1.0-based remote server from a Windows-based computer that has security update 980232 (MS10-020) installed

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;983458


    2. Do you see a specific message e.g. Document not saved; or Word not responding?
    3. Do you also see latency when double clicking attachments within Outlook; or does opening Word documents across the WAN consistently show latency?
    4. Please test Wordpad, Powerpoint, Excel and Word files - which applications show latency on opening?
    5. Is it only new Word files that show latency? Or existing files that show latency?
    6. Did you recently retire a legacy server when the 2008 Server was brought up


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thanks!
    Adrian
    Microsoft Online Community Support

    • Proposed as answer by GAndraza Wednesday, November 3, 2010 5:14 PM
    Wednesday, October 27, 2010 5:44 PM
  • I followed the advice from Adrian PA and have not had a problem for 4 days now!  I only applied the TWO fixes for the Windows 7 Client to update the MRXSMB.SYS and RDBSS.SYS files.  Time will tell, but it is looking good!
    Kevin
    Monday, November 1, 2010 8:07 PM
  • For what it's worth this thread http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/e71ebf52-a1bd-4e21-8d81-2a612a7cab8b has helped me out so far over the last few days. The user indicates "A work-around which works for our users that I found searching the internet was to turn off Indexing for Offline files.", which was probably the one item that I had not considered. Since we do not use offline files, I took the extra step of not only turning off the offline files indexing, but to disable it completely. As I indicated, so far....it seems to be working.

    Adrian's comments are helpful, but it does not quite hit the mark in my case, which is similar to OhSnap's. I have had no complaints from any XP users or Vista users..just Windows 7 users.


    Ranie
    Wednesday, November 3, 2010 7:41 PM
  • I have now seen this issue on three pairs of Windows 7 computers. For me, the problem is with DOC files. If I change the extension to DOCX, the delay disappears!

    All computers have been using Sunbeltsoftware's VIPRE AV. I just removed Vipre from one machine and the problem went with it. Installed AVG Free. No problem. Installed MSE. No problem.

    Wednesday, November 17, 2010 5:26 PM
  • After extensive testing, it turns out Adrian's solution was in the ball park despite my earlier comment - sorry Adrian! We disabled SMB2 on the server side and the problem finally went away! http://arstechnica.com/microsoft/news/2009/09/microsoft-posts-quick-fix-it-links-for-smb2-flaw-in-vista.ars Was a link we used with a handy FixIt link to automate the process
    Ranie
    • Proposed as answer by JICdbs Wednesday, November 24, 2010 9:12 PM
    Wednesday, November 24, 2010 9:12 PM
  • Hi everybody,

     

    I had the same problem for several months but I finally found a solution that works for me. My environment is very similar: Windows 7 with either Office 2007 or 2010 in a network domain with windows server 2008 R2.  I disabled the SMB2 on the local machines and the network files now opens as fast as the local documents.

     

     

     

    How to disable SMB 2.0 on Windows 7 or Windows Vista:

    From Windows 7.0 you can drop to a command line and issue the following commands (make sure you are an admin, or run CMD.exe as an admin)

    sc config lanmanworkstation depend= bowser/mrxsmb10/nsi sc config mrxsmb20 start= disabled

    reboot the client

     

    How to disable SMB 2.0 on Server 2008:

    BEFORE YOU PROCEED! Note that disabling SMB 2.0 on your problem Windows 7 or Windows Vista machines is enough to stop SMB 2.0 from being used. You should only disable SMB 2.0 on Server 2008 if disabling the client desktops using the command above has failed!

    Open Regedit and browse to this key…

    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

    Add the DWORD key with the name Smb2 and set the value to 0 to disable SMB 2.0.

    Reboot the server.

     

    Hope this helps

    Thanks,

    Angelo

    Wednesday, January 5, 2011 12:46 AM
  •  

     

    Hi! I was in about the same boat as you and I called IBM's support... we were working from new lenovo workstations with microsoft office 2010 and windows 7 installed. Our server was an eserver 520 running i5 OS and all of our office products were hanging for AT THE MINIMUM 1 minute 30 seconds just opening files. What they told me to do not only worked instantly (no more lag time at all), but might work for you.

     

    Right click on Computer

    Click Manage (use administrator priveleges if you aren't already signed on as administrator)

    Go to Services and Applications

    Go to Services

    Scroll Down to Web Client

    Right click and if it is turned off.... turn it on. If it is turned on... turn it off.

    Test saving or opening files with office now.

    If it worked... dont forget to right click on Web Client... go to Properties and make sure to set the startup type

    Wednesday, August 17, 2011 6:08 PM
  •  I too have litterally tried everthing.....for months.....I knew it had to do with Windows7 and Office 2010 or 2007 because other computers in the same office did not have the same saving files delay!  Thank you so much incupirsi for posting this suggestion to "start" Web Client!  Not sure why, but it also helped us! 
    Wednesday, November 2, 2011 8:24 PM
  • This is NOT a networking issue.  It also happens on removable drives.  It can take up to 30 seconds for saves to take place.  There is also something happening in the background, possibly automatic saves, which will lock up the Office apps until finished.  The same issue happens with an external USB drive attached.  If you move the office files to the computer's local hard drive, this problem disappears.  Sounds like an Office bug.  I haven't tried Office 2010 on an XP machine, but it definitely happens to Windows 7 machines.  None of the fixes posted here corrects the problem with external drives.
    Wednesday, February 15, 2012 7:09 PM
  • got the same Problem

    tryed all the below stuff still no go any other idears

    Friday, May 4, 2012 10:53 PM
  • were you able to find answer???
    Sunday, May 6, 2012 2:48 AM
  • same here still not going any idears
    Sunday, May 6, 2012 2:48 AM
  • Smoke and mirrors. just say it u don't know
    Tuesday, December 31, 2013 3:25 AM
  • I resolved the same issue this week with the following scenario:

    Windows 8.1 Pro workstation with Microsoft Office 2007, saving to shares on Windows Server 2008.  I could open files from the shares just fine, but saving would take anywhere from 20 to 60 seconds.

    I had already tried disabling SMB 2.0 on the client workstation, and uninstalling a "Microsoft Office File Validation Addin" (an update which had installed itself just a few days ago, that has been known to give trouble when opening files from shares).  Again though, my issue was with SAVING files to the network shares, not with OPENING them.

    It was not until I disabled SMB 2.0 on the SERVER (and rebooted it) that things began working.  Now keep in mind that in addition to this, I had also gone back to the workstation, and enabled SMB 2.0 again (which I had to do to keep other things working) and rebooted the workstation, but it WORKED.  Saving is near instant.

    Just thought I would post the steps I went through, in case someone else wants to follow along in the order I did.

    As for the enabling/disabling of SMB on the different OS's, I followed the steps from this tech article:

    http://support.microsoft.com/kb/2696547

    Wednesday, March 5, 2014 8:12 PM