locked
Set Associations for this Program? RRS feed

  • Question


  • "MODERN PROGRAMMING is deficient in elementary ways BECAUSE of problems INTRODUCED by MODERN PROGRAMMING." Me

    Well I would but the association for .sln files are wrong and there doesn't seem to be any way that it will allow me to change it on 8.1.

    Renee


    Thursday, March 6, 2014 9:00 PM

Answers

  • Hi,

    If the issue persists, please open the registry and navigate the following location:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    And then find the .sln, check the "open with list" key.

    Regards,


    Kelvin Xu
    TechNet Community Support

    • Marked as answer by Renee Culver Friday, March 7, 2014 4:51 PM
    Friday, March 7, 2014 8:46 AM
  • Hey Renee, try this:

    • Start File Explorer and navigate to where you have a .sln file on disk.
    • Right-click a .sln file.
    • Choose Open With to expand the menu to the right.
    • Click Choose Default Program.
    • Check the Use this app for all .sln files box
    • Choose the Microsoft Visual Studio Version Selector or just Microsoft Visual Studio if you only have the one version instdalled.

     

     

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    • Proposed as answer by kelvin_hsu Friday, March 7, 2014 8:45 AM
    • Marked as answer by Renee Culver Friday, March 7, 2014 4:51 PM
    Thursday, March 6, 2014 11:31 PM

All replies

  • do you mean that you can't tick a box (and you want to)?
    or, the box you want to tick is not presented?
    or, the program you want to associate with a filetype is not presented?

    you can dig into the usage of "ftype" and "assoc" - these are console utilities which still exist and can list out as well as create/modify file-type-associations.

    e.g.

    C:\Users\Don>assoc .txt
    .txt=txtfile

    C:\Users\Don>ftype txtfile
    txtfile=%SystemRoot%\system32\NOTEPAD.EXE %1

    C:\Users\Don>


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)


    • Edited by DonPick Thursday, March 6, 2014 9:22 PM
    • Proposed as answer by ZigZag3143x Thursday, March 6, 2014 9:49 PM
    Thursday, March 6, 2014 9:19 PM
  • Don,

    Checking the box has no effect period. I will try your suggestion.

    Renee


    "MODERN PROGRAMMING is deficient in elementary ways BECAUSE of problems INTRODUCED by MODERN PROGRAMMING." Me

    Thursday, March 6, 2014 9:24 PM
  • Assoc shows the association to be correct although it's not.

    Renee


    "MODERN PROGRAMMING is deficient in elementary ways BECAUSE of problems INTRODUCED by MODERN PROGRAMMING." Me


    Thursday, March 6, 2014 9:31 PM
  • Here, Explorer clearly shows that .sln files are associated with notepad....

    Renee


    "MODERN PROGRAMMING is deficient in elementary ways BECAUSE of problems INTRODUCED by MODERN PROGRAMMING." Me

    Thursday, March 6, 2014 9:38 PM
  • Hey Renee, try this:

    • Start File Explorer and navigate to where you have a .sln file on disk.
    • Right-click a .sln file.
    • Choose Open With to expand the menu to the right.
    • Click Choose Default Program.
    • Check the Use this app for all .sln files box
    • Choose the Microsoft Visual Studio Version Selector or just Microsoft Visual Studio if you only have the one version instdalled.

     

     

     

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options

    • Proposed as answer by kelvin_hsu Friday, March 7, 2014 8:45 AM
    • Marked as answer by Renee Culver Friday, March 7, 2014 4:51 PM
    Thursday, March 6, 2014 11:31 PM
  • Hi,

    If the issue persists, please open the registry and navigate the following location:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    And then find the .sln, check the "open with list" key.

    Regards,


    Kelvin Xu
    TechNet Community Support

    • Marked as answer by Renee Culver Friday, March 7, 2014 4:51 PM
    Friday, March 7, 2014 8:46 AM
  • Thank both of you! It worked

    Renee


    "MODERN PROGRAMMING is deficient in elementary ways BECAUSE of problems INTRODUCED by MODERN PROGRAMMING." Me

    Friday, March 7, 2014 4:52 PM