none
Client Networked printers showing offline after remote desktop session

    Question

  • Hi,

    I seem to have an issue that I can't seem to find a similar forum or solution for.

    Windows 8 clients on our network connecting to networked printers on a 2012 print server. Normally they talk to the printers perfectly. However, *after a remote desktop session to a client machine*, the printer shows as offline and the print spooler needs restarting for the printer to show as online again.

    Now, while this is a workaround, I'd love to know of a fix. Most of our users are not local admins on their machines, so restarting the spooler isn't normally an option unless I do it for them.

    Does anyone have any advice on the above?

    Chris

    Thursday, November 21, 2013 1:49 AM

Answers

  • Hi, 

    For this issue, we can try following steps: 

    First give yourself ownership and full access to c:\windows\system32\spoolsv.exe

    1.       Start Search > services.msc
    2.       If spooler is not on, turn it on. If after turn on, it turn off automatically, proceed to step 3, if can turn on go to step 4
    3.       Start > Start Search > C:\Windows\System32\spoolsv.exe (Right click > Properties)
    4.       Click on Security Tab > Advanced > Owner. Take ownership of the file and give full permission to the file. Once done, close everything and try to start the service again.
    5.       Start > Start Search > cmd (Run as Admin)
    6.       del /Q C:\WINDOWS\system32\spool\PRINTERS\*.* > Press Enter
    7.       Once done, try to start the spooler in Services

    Then, try to update printer firmware by contacting the manufacturer. 

    Hope these would be helpful.

    Kate Li
    TechNet Community Support

    • Marked as answer by AntAdmin Wednesday, November 27, 2013 10:37 PM
    Friday, November 22, 2013 9:34 AM
    Owner

All replies

  • Hi, 

    For this issue, we can try following steps: 

    First give yourself ownership and full access to c:\windows\system32\spoolsv.exe

    1.       Start Search > services.msc
    2.       If spooler is not on, turn it on. If after turn on, it turn off automatically, proceed to step 3, if can turn on go to step 4
    3.       Start > Start Search > C:\Windows\System32\spoolsv.exe (Right click > Properties)
    4.       Click on Security Tab > Advanced > Owner. Take ownership of the file and give full permission to the file. Once done, close everything and try to start the service again.
    5.       Start > Start Search > cmd (Run as Admin)
    6.       del /Q C:\WINDOWS\system32\spool\PRINTERS\*.* > Press Enter
    7.       Once done, try to start the spooler in Services

    Then, try to update printer firmware by contacting the manufacturer. 

    Hope these would be helpful.

    Kate Li
    TechNet Community Support

    • Marked as answer by AntAdmin Wednesday, November 27, 2013 10:37 PM
    Friday, November 22, 2013 9:34 AM
    Owner
  • This seems to work, thank you.

    However, it's a bug that obviously needs to be looked at. I do hope it's marked as one for attention in a later patch/release.

    Chris

    Wednesday, November 27, 2013 10:40 PM
  • Thanks to whoever asked the question originally, to whoever answered the question (and to Google for finding this post).

    I read the solution and figured out that I needed to find the "Print Spooler" service, and not just the "spooler" service. After stopping it and restarting it, the printer showed as online!

    Thanks!


    • Edited by jofosa Friday, March 23, 2018 9:42 PM
    Friday, March 23, 2018 9:41 PM