none
Change in Calendar Calendar Hours Per Day not automatically updating Work Hours RRS feed

  • Question

  • Hello,

    I initially had the defauly Hours per day to 8 hours per day and the hours per week to 40 hours per week in File > Options > Schedule. Additionally, I set the 'Work Hours' in 'Change Working Time' for a Custom Calendar I created to Monday through Friday 5PM - 7PM. After setting the resource units for each task across 9 resources, I get a summary of the work hours for each resource for the entirety of the project in the 'Resource Usage' view. As an example, I see Program Manager with 134.02 hrs.

    I noticed I used the wrong work time information and I had to change it. I should have set up 4 hour work days across both of these settings so as to have 4 hours worked per day in File > Options > Schedule as well as having the 'Work Hours' in 'Change Working Time' set to M-F 5PM-9PM.

    Once I realized this, I changed both of these and made sure that each Resource was set to this new custom Base Calendar. What I wanted to happen was for Work ('Work' column) to double since my work days are now 4 hours (5-9PM) vs. 2 hours (5-7PM). As an example, Program Manager should go from 134.02 hrs to 268.04 hrs. This did not occur, and Program Manager maintained its value of 134.02.

    What do I need to do for this to change automatically? All tasks should have their Work change automatically. I have all tasks set to 'Fixed Duration'.

    Thanks, -D

    Thursday, January 21, 2016 4:34 PM

Answers

  • Figured out how to do it after fiddling with MSP for a while.

    It is resolved by:

    - Setting first adding a column to the Gantt Chart View that for 'Work'.
    - Click a task and set it to Manual Schedule.
    - Manually set its Work value to '0'.
    - Re-set the task Auto Schedule.
    - Editing Duration should now automatically change the Work hrs as well as the cost associated to it.

    Regards,

    -D

    • Marked as answer by Dee Nolovich Thursday, January 21, 2016 10:25 PM
    Thursday, January 21, 2016 10:25 PM

All replies

  • Figured out how to do it after fiddling with MSP for a while.

    It is resolved by:

    - Setting first adding a column to the Gantt Chart View that for 'Work'.
    - Click a task and set it to Manual Schedule.
    - Manually set its Work value to '0'.
    - Re-set the task Auto Schedule.
    - Editing Duration should now automatically change the Work hrs as well as the cost associated to it.

    Regards,

    -D

    • Marked as answer by Dee Nolovich Thursday, January 21, 2016 10:25 PM
    Thursday, January 21, 2016 10:25 PM
  • Dee,

    I'm glad you figured out a way to get what you needed. However, let me clarify something. The option setting for "hours per day" has nothing to do with the Work field, rather it simply determines how the Duration field will display a "day".

    John

    Friday, January 22, 2016 1:59 AM
  • Thanks. That's good to know, Ill keep that in mind.

    -D

    Friday, January 22, 2016 4:39 PM