none
GPO "Redirect Folders" and "Offline Folders"

    Question

  • Hello,

    I have a problem with offline folders that don't synchronise automaticly. Here is my configuration :

    • Windows server 2012 R2 named "SERVER" domain "DOMAIN.COM"
    • Client : Windows 7 SP1 (with all updates)
    • GPO to redirect Desktop folders for all user in Z:\\SERVER\GROUP\%USERNAME%\DESKTOP

    Everything is good when i am online, folders create on Desktop are on the server's folder.

    When i open my session elsewhere and i create a folder on desktop, when latter i open my session on my domain, folders are not automaticly synchronize with share folder. I have to manualy synchronize doing a right clic on my network drive Z:

    I've tried different option in GPO with slow connection but it doen't work.

    Monday, December 15, 2014 9:09 AM

Answers

  • > latter i open my session on my domain, folders are not automaticly
    > synchronize with share folder. I have to manualy synchronize doing a
    > right clic on my network drive Z:
     
    Most probably this is a result of wrong permissions in one of the
    directories involved. Users need at least "read" permission for each
    directory in the redirection path.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    • Marked as answer by mabrox Tuesday, December 16, 2014 3:05 PM
    Monday, December 15, 2014 12:38 PM
  • I've found a solution, Martin was right, it was permission problem. I've found a solution in :

    http://technet.microsoft.com/en-us/library/cc782799(v=WS.10).aspx

    And more important :

    http://technet.microsoft.com/en-us/library/cc775853(v=ws.10).aspx

    I have create a new share folder with exactly the same permissions and everything is good. You have nothing to do, for example when you create a folder offline in user Desktop, it'll automatically sync with server when he'll be online.

    Its important to let system create user folder.

    Tuesday, December 16, 2014 3:05 PM

All replies

  • Hello,

    Please go through this link which would help you.

    http://technet.microsoft.com/en-in/library/cc732275.aspx

    Please mark as answer once solved.

    Regards

    Biswajeet

    Monday, December 15, 2014 9:13 AM
  • Did you install the hotfix KB 977397 and 981872?

     

    Also, please check if there is a network issue and if there is restrictive NTFS permissions on the server.

     

    Was the settings “How Often to Check for a Slow Connection” configured:

     

    1)    Open the Control Panel from the Start menu.

    2)    Open Sync Center in the Control Panel.

    3)    Click Manage offline files in the left column of the Sync Center window.

    4)    Click the Network tab in the Offline Files window.

    5)    Confirm if the “On slow connections, automatically work offline” box is checked and how frequency you configured the Offline Files to check for a slow network connection.

     

    Please check if you are running into the scenarios in the following link:

     

    Configuring New Offline Files Features for Windows 7 Computers Step-by-Step Guide

    Monday, December 15, 2014 9:20 AM
  • Thanks for you answers, i'll read and try that. If it solve my problem i'll mark it as solved asap.
    Monday, December 15, 2014 10:05 AM
  • > latter i open my session on my domain, folders are not automaticly
    > synchronize with share folder. I have to manualy synchronize doing a
    > right clic on my network drive Z:
     
    Most probably this is a result of wrong permissions in one of the
    directories involved. Users need at least "read" permission for each
    directory in the redirection path.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    • Marked as answer by mabrox Tuesday, December 16, 2014 3:05 PM
    Monday, December 15, 2014 12:38 PM
  • I can tell you from experience that Offline Folders don't work well with more than one client. You can use Redirected Folders on two or more clients without problems, but only one client (e.g. your laptop) should have Offline Files enabled. It may work, but it will give you a lot of support issues over time.

    And as Martin mentions it is very important that both share and NTFS permissions are set properly.


    Boudewijn Plomp | BPMi Infrastructure & Security

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember, if you see a post that helped you please click "Vote as Helpful", and if it answered your question, please click "Mark as Answer".

    Monday, December 15, 2014 3:32 PM
  • Here what i tried :

    @ Sabdeeo Poonia

    I've try to install KB 977397 and 981872 but i can't (with a message this KB can't be install on your computer)

    On my Sync Center the box "On slow connections, automatically work offline" is checked and verify evevry 5mn if its a slow connection

    @ Martin Binder

    I've tried to add "Evryone" in total control in my folder where every users have their folders redirected, but i have the same problem

    @ biswajeetpattnaik

    I've tried to had a Roaming profil for a test user because they say : "... When you deploy Folder Redirection with Roaming User Profiles, the data synchronized with Folder Redirection is not part of the roaming profile and is synchronized in the background by using Offline Files after the user has logged on. Therefore, the user does not have to wait for this data to be synchronized when they log on or log off as is the case with Roaming User Profiles."

    I allways have the same problem. Even if i had everyone in control total in my security tab for my redirected share folder. Even if i had a Roaming profil in this share folder. All files created offline are not automaticly sync with my share folder.

    At the moment my only solution is to right clic my network drive to sync manually.

    Monday, December 15, 2014 3:51 PM
  • I've found a solution, Martin was right, it was permission problem. I've found a solution in :

    http://technet.microsoft.com/en-us/library/cc782799(v=WS.10).aspx

    And more important :

    http://technet.microsoft.com/en-us/library/cc775853(v=ws.10).aspx

    I have create a new share folder with exactly the same permissions and everything is good. You have nothing to do, for example when you create a folder offline in user Desktop, it'll automatically sync with server when he'll be online.

    Its important to let system create user folder.

    Tuesday, December 16, 2014 3:05 PM
  • That is correct, but not more then one host at a time.

    Boudewijn Plomp | BPMi Infrastructure & Security

    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember, if you see a post that helped you please click "Vote as Helpful", and if it answered your question, please click "Mark as Answer".

    Tuesday, December 16, 2014 7:54 PM