locked
IBCM clients - connection errors RRS feed

  • Question

  • I know there are lots of threads on this issue, but everyone I've read is a little bit different than what I'm seeing.

    ClientIDManagerStartup.log:

    Over and over:

    [RegTask] - Client is not registered.  Sending registration request for GUID:...

    RegTask: Failed to send registration request message. Error: 0x87d00231

    RegTask: Failed to send registration request. Error: 0x87d00231

    [RegTask]  - Sleeping for...

    CCMMessaging.log:

    [CCMHTTP] ERROR: URL=https://ibcm.fqdn/ccm_system/request, Port=443, Options=448, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE

    [CCMHTTP] ERROR INFO: StatusCode=501 StatusText=Invalid Request

    Raising event:

    lots of entries, but these seem to be the important ones:

    HRESULT = "0x87d0027e";

    StatusCode = 501

    Successfully queued event on HTTP/HTTPS failure for server 'ibcm.fqdn'.

    Post to https://ibcm.fqdn/ccm_system_windowsauth/request failed with 0x87d00231.

    ClientLocation.log starts its cycle with:

    Unable to retrieve AD forest + domain membership. Error 0x8007054b (Warning)

    Failed in WinHttpSendRequest API, ErrorCode = 0x2ee7

    It then shows an error trying to connect to the site server/MP, which is fine, as it is disconnected, then in the same second gives the same type of error going to ibcm:

    [CCMHTTP] ERROR: UR:=https://ibcm.fqdn/SMS_MP/.sms_aut?SITESIGNCERT, Port=443, Options=448, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE

    Domain joined client is in Unknown location

    If I open a browser on the disconnected client machine, and type in https://ibcm.fqdn, I get the IIS splash screen, and the cert is valid.  I just recently got HTTPS communications working internally, and really need to get IBCM working ASAP, as we're testing desktop updates tomorrow.  Any help/advice/tips will be greatly appreciated.

    Wednesday, May 13, 2020 12:14 AM

Answers

  • Issue Resolved:

    We use Kemp Loadmasters in front of the web server.  They were not configured correctly.  As soon as they were fixed, IBCM started communicating and working correctly.

    Friday, May 29, 2020 2:13 PM

All replies

  • Hi,

    Have you tried the solution in another thread:
    Try to uncheck the check box "Client check the certificate revocation list (CRL) for site system" from Site Properties which disable CRL check and reinstalled client with /NoCRLCheck CCMHOSTNAME=InternetFQDN with SMSSite code switches to see if it helps.

    For more discussion of this question, we may refer to:
    https://social.technet.microsoft.com/Forums/en-US/907fe750-3282-4f9e-b75a-f6e29696c30c/regtask-failed-to-send-registration-request-message-error-0x87d00231?forum=configmanagerdeployment

    Regards,
    Allen

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 13, 2020 7:54 AM
  • That box has already been unchecked, yes.

    I have not manually reinstalled the client, no, but that would be disastrous if that is needed, as we are currently around 70% telework currently.  I am desperately trying to find a solution that does not require reinstalling the client on endpoints.  These are our options in the console, for when we do push the client:

    SMSSITECODE=XXX FSP=HQSCCM2 DISABLESITEOPT=TRUE  CCMHOSTNAME="ibcm.fqdn" SMSCACHESIZE=8000

    I was looking to include the /NoCRLCheck in these settings, but wasn't sure if this is where it was needed, or if it would work here.

    Wednesday, May 13, 2020 1:30 PM
  • In IIS on the SCCM site server, for the CCM_System, under SSL Settings, for those that have this working, what do you have set?  I assume the checkbox Require SSL is selected, but what about the Client certificates setting?
    Wednesday, May 13, 2020 3:11 PM
  • Issue Resolved:

    We use Kemp Loadmasters in front of the web server.  They were not configured correctly.  As soon as they were fixed, IBCM started communicating and working correctly.

    Friday, May 29, 2020 2:13 PM
  • Hi,

    Thanks for your update and we are glad that the issue is solved now.

    Regards,
    Allen

    Please remember to mark the replies as answers if they help.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 2, 2020 6:17 AM