locked
Exchange 2010 public folder admin RRS feed

  • Question

  • Does a user have to be mail-enabled to use the Public folder management console or powershell public folder commands such as get-publicfolder? (Exchange 2010) I am trying to set up a administrative user with no mailbox to manage exchange public folders. They are a member of Exchange Public Folder Administrators group, they can connect to the server but cant open the public folder tree.

    Tuesday, April 3, 2012 3:00 AM

Answers

All replies



  • Hi

       I test it on my lab server.

       I create new user through AD without mailbox. I grant Organization Management, Recipient Management, Public Folder Management exchange permission to this user.

       I log on it and I can access public folder tree. Maybe it is only permission problem.

       I can read “Public Folder Permissions” paragraph of this article.

       http://technet.microsoft.com/en-us/library/dd638132.aspx

       TechNet Subscriber Support in forum

      If you have any feedback on our support, please contact tngfb@microsoft.com



    Terence Yu

    TechNet Community Support

    Wednesday, April 4, 2012 2:21 AM
  • Hi
       Do you have any update on your issue ?

    Terence Yu

    TechNet Community Support

    Thursday, April 5, 2012 12:56 AM
  • It seems like permissions, but im having trouble finding what is incorrect. If I add my test user to Organization Management, Recipient Management, Public Folder Management. They still are not able to open the folders. If im reading the article right I should only really need public folder management.

    if I run get-PublicFolder the Error is

    Can't log on to the Exchange Mailbox server 'servername'. No existing 'PublicFolder' matches the following Identity: '\'. Make sure that you specified the correct 'PublicFolder' Identity and that you have the necessary permissions to view 'PublicFolder'..
        + CategoryInfo          : NotSpecified: (0:Int32) [Get-PublicFolder], MapiLogonFailedException
        + FullyQualifiedErrorId : 3A9BBC97,Microsoft.Exchange.Management.MapiTasks.GetPublicFolder

    using my mail-enabled user I can see these permissions at the top level

    Public folder management has the following rights assigned

    {ViewInformationStore}
    {AdministerInformationStore}
    {ModifyPublicFolderACL}
    {MailEnablePublicFolder}
    {ModifyPublicFolderQuotas}
    {ModifyPublicFolderAdminACL}
    {ModifyPublicFolderExpiry}
    {ModifyPublicFolderReplicaList}

    {ModifyPublicFolderDeletedItemRetention}

    Organization Management has

    {ViewInformationStore}
    {AdministerInformationStore}
    {ModifyPublicFolderACL}
    {MailEnablePublicFolder}
    {ModifyPublicFolderQuotas}
    {ModifyPublicFolderAdminACL}
    {ModifyPublicFolderExpiry}
    {ModifyPublicFolderReplicaList}
    {ModifyPublicFolderDeletedItemRetention}

    {AllExtendedRights}

    Thursday, April 5, 2012 4:13 AM
  • Hi

        I find similar error because of their do migration like exchange 2003 to 2010.
        legacyExchange is modified.



    Terence Yu

    TechNet Community Support

    Thursday, April 5, 2012 4:34 AM
  • Yes the public folders would have been migrated from 2003 > 2007 > 2010. Is there an AD attirbute that needs updating?
    Thursday, April 5, 2012 4:46 AM
  • Hi

       You can launch the properties of public folder database store in Adsiedit, and then verify the value of msExchOwningPFTree.

        If the value is correct, it is legacy exchange problem. You need to modify so many value and meet high risk. I can't do it through forum.

       Workaround: You can create mail-enable admin account and disable mailbox.  Maybe it will meet your need.

    Terence Yu

    TechNet Community Support

    Thursday, April 5, 2012 5:20 AM
  • The msExchOwningPFTreevalue is equal to

    CN=Public Folders,CN=Folder Hierarchies,CN=Exchange Administrative Group ,CN=Administrative Groups,CN=Domain Name,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=Domain,DC=COM

    Thursday, April 5, 2012 6:15 AM
  • Hi
      I check my test lab value. It is correct. 
      Do you try workaround?


    Terence Yu

    TechNet Community Support

    Thursday, April 5, 2012 6:18 AM
  • Hi
      Do you have anything update on your issue ?

    Terence Yu

    TechNet Community Support

    Monday, April 9, 2012 7:01 AM
  • If I add a mailbox it works, then as soon as I disable the mailbox the user cannot connect to the public folders.
    Tuesday, April 10, 2012 1:25 AM
  • Hi
       I will talk with my colleague about your issue and update your case when I find other clue.
       If it is urgent error, you can open MS support ticket.

    Terence Yu

    TechNet Community Support

    Tuesday, April 10, 2012 1:33 AM
  • I opened a support case on this, the issue was resolved by setting the HomeMDB attribute under system attendant on the server hosting the public folder database. (it was set to 'not set')

    see this link http://technet.microsoft.com/en-us/library/dd535374(EXCHG.80).aspx

    • Marked as answer by DanF78 Monday, April 30, 2012 5:32 AM
    Monday, April 30, 2012 5:31 AM