locked
Word 2013 - Error inserting an HTML file in a word document RRS feed

  • Question

  • Hello,

    Here is an issue i'm having:

    Open a blank doc in Word 2013

    Click Insert - Object - Create from file. Then select an html file, click insert and ok.

    i'm always getting the below error message:

    I can reproduce this issue on multiple machines.

    Office 2013 preview and Office 2013 RTM are getting same error.

    Anyone else ?

    Thanks


    • Edited by Christophe_P Tuesday, October 30, 2012 9:25 AM image attachment
    Tuesday, October 30, 2012 9:24 AM

Answers

  • Hi Christophe_P,

    I’m able to repro the behavior in my test environment as per your repro steps.

    An Office repair does NOT impact the issue for me.

    I’ll report the issue to the Office product group.

    A possible workaround:

    1. In a Word 2013 document>Insert tab > Text group > Click Object
    2. In the Object dialog, click the Create New tab
    3. Select Microsoft Word Object; then click OK
    4. In the newly embedded/activated Word doc object, click Insert tab > Text group > Click the Object dropdown arrow; then choose “Text from File…”
    5. In the Insert File dialog, navigate to; then select the html file; then click Insert.

    Bill Go - MSFT

    • Marked as answer by Christophe_P Wednesday, November 21, 2012 8:52 AM
    Monday, November 19, 2012 1:59 AM

All replies

  • Try run repair from Programs and Features.


    Sincerely,
    Max Meng
    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    • Edited by Max Meng Wednesday, October 31, 2012 2:51 AM
    Wednesday, October 31, 2012 2:51 AM
  • Hi Max,

    It's not machine related. Affecting about 200 machines.

    Could you please confirm you can or cannot reproduce the issue ?

    Thanks

    Wednesday, October 31, 2012 8:21 AM
  • Hi Christophe,

    Yes, when I checked the issue this morning, I was able to reproduce the behavior, and solved by repair my Office which is installed using the Click-to-Run technology.

    When checked this issue on another machine just before I post this reply, I was also able to reproduce this behavior, but failed to fix it by repairing the Office (Which is installed using MSI package).

    I'll update the post if I can find anything helpful.


    Max Meng
    TechNet Community Support
    A new Office has arrived, try it now.
    A beautiful Start. It begins here. Windows 8 and Windows RT.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, October 31, 2012 9:03 AM
  • Thanks for your interest in this issue. Appreciated.

    Let me know your finding.

    Wednesday, October 31, 2012 9:15 AM
  • Hello Max,

    Any update ?

    Thanks

    Tuesday, November 6, 2012 4:10 PM
  • I am having the same issue (and getting the same error) when trying to Insert > Object > Create from File > Any image file (.jpg, .png, .tiff, etc.). I tried to repair the click-to-run installation but did not seem to do anything for me - do you have any other workaround?
    Thursday, November 8, 2012 9:33 PM
  • I am also having the same issue. I'm running x64 bit RTM version of Office 2013. Any solutions?

    JussiL

    Monday, November 12, 2012 1:25 PM
  • Max or any moderator,

    Could we have an update on this ?

    Thanks

    Saturday, November 17, 2012 11:34 PM
  • Hi Christophe_P,

    I’m able to repro the behavior in my test environment as per your repro steps.

    An Office repair does NOT impact the issue for me.

    I’ll report the issue to the Office product group.

    A possible workaround:

    1. In a Word 2013 document>Insert tab > Text group > Click Object
    2. In the Object dialog, click the Create New tab
    3. Select Microsoft Word Object; then click OK
    4. In the newly embedded/activated Word doc object, click Insert tab > Text group > Click the Object dropdown arrow; then choose “Text from File…”
    5. In the Insert File dialog, navigate to; then select the html file; then click Insert.

    Bill Go - MSFT

    • Marked as answer by Christophe_P Wednesday, November 21, 2012 8:52 AM
    Monday, November 19, 2012 1:59 AM
  • Hi Bill,

    I appreciate your help on this one.

    I confirm your workaround is working.

    Thanks to have reported the issue to the Office product group.


    Wednesday, November 21, 2012 8:54 AM
  • Hi Max,

    i use Office 2013 32-Bit German on an Win 7 Pro and i have the same issue but i tryed to insert ANY Object like jpg, bmp, vsd and so on.

    The error message is exactly the same but in german. The curious is, that the objects i tried to insert are not html.

    Today some MS-Updates were installed but the result is the same.

    Do you - or someone else - an solution therefor?

    Thank you in advance,

    Freeman

    Wednesday, February 13, 2013 5:57 PM
  • Same problem here, appeared from nothing, Word still updates old png objects, but refuses to add new ones!
    Saturday, June 8, 2013 5:39 PM
  • Hi,

    I have the same issue and running a Office repair did not fix the issue stated above. I may raise a call with MS on the issue.

    Thoughts?

    Thanks 

    Emilios

    Friday, June 14, 2013 10:25 AM
  • Hi All,

    By pure fluke I found that this can be done as previous within Office 2010.

    Have a try of this.

    1. from the menu bar click Insert -->Object

    2. Then on the "Create New" Tab scroll down to the bottom of the Object Type List and select "Package"

    3. Then Check the "Display as Icon" check box

    4. Then browse to the file location for the .HTM file

    5. Then Click Next

    6. Give it a label or leave this as the file name then click "Finish"

    You may want to change the icon but that is up to you.

    This worked for me and is a pain but I suspect this is a security issue that's why you cannot simply drag and drop .htm files.

    Thanks

    Thursday, June 20, 2013 1:53 PM
  • Emilios, thanks for trying, but that doesn't work for me.  

    Step 4 involves changing tabs from Create New  to Create from File, so how would the attributes selected in Steps 2 and 3 be retained, after changing the tab?

    Clearly this is a MS Office 2013 problem - why isn't Microsoft addressing it? It used to work perfectly well in Office 2010.

    Monday, August 5, 2013 10:12 AM
  • This worked like a charm though little pain but worth trying to make your stuff complete.

    This one worked with Office 2013 on my machine running Windows 8.1.

    Thanks for sharing,

    Sandeep



    • Edited by Sandeep Phogat Saturday, December 7, 2013 10:41 PM
    • Proposed as answer by Gene_PS Friday, January 3, 2014 7:49 PM
    • Unproposed as answer by Gene_PS Friday, January 3, 2014 7:50 PM
    Saturday, December 7, 2013 10:39 PM
  • Hi Chrisophe_P,

    I don't think that Word 2013 is able to import .jpg files as an object so I found that if you use Object to create a Package and then insert the .jpg into the Package, it will work.  Here are the steps:

    1. Insert Tab > Test Group > Click on 'Object'

    2. In Object dialog, click the 'Create New' tab

    3. Scroll down to Package (I always used the 1st Package label) and highlite it

    4. Click the box for' Display as icon'

    5. Click the 'Change Icon...' button

    6. In Change Icon dialog click the 'Browse' button and find your .jpg picture and double click on it.

    7. Change Caption title "Package" to the title you want

    8. Click the 'OK' button

    9. In Object dialog click the 'OK' button

    10. A Create Package dialog will appear, click the 'Browse' button and the folder holding your .jpg should appear.  If not, search for your .jpg and double click on your .jpg document.

    11. Click the 'Next' button

    12. Click the 'Finish' button

    Your Word document should have your icon inserted into it and if you double click the icon your picture will appear.

    Fyi...  This procedure worked for me and my colleagues and this issue only seems to appear in Word 2013, not in Excel 2013.

    Gene_PS

    • Proposed as answer by Pratik Shouche Tuesday, September 1, 2015 2:21 PM
    Friday, January 3, 2014 8:14 PM
  • Gene_PS, Christophe_P

    Using Windows 8 and Office 2013 Professional.

    I have encountered the same issue when attempting to insert a .jpg file into a Word 2013 document - either in the body of the document, or in the header or footer.  If I simply paste the object directly it appears in position in the Word docx document but when I  save as a PDF the images disappear completely.  It's as if they were never there.  The rest of the document text is fine - just the images that are "censored".

    If I use the workaround suggested by Bill Go - MSFT on 21 November 2012 the images appear in place and when saved as a PDF they are still preserved in place.

    It's a bit fiddly to have to do it that way. but it does work - so thanks go to Bill Go!

    Does anyone from Microsoft have any indication whether this "undocumented feature" is likely to be fixed anytime during the lifetime of Office 2013?

    Chris B


    Friday, June 13, 2014 1:34 AM
  • That did work on my PC as well,

    Thanks

    Thursday, July 10, 2014 2:54 AM
  • You could also try creating a .zip file of the problematic file extension (e.g. jpg etc.) and insert it as an object.

    I had to do it this way, since the aim was to encrypt a file with password and send it via email, 7zip encryption was causing problems when it was being opened at destination PC & hence I zipped the jpg file using windows standard zip capability and then inserted the zip file as an object in the normal way into a word file, then password protected the word file and attached it to the email & all worked fine at destination PC.

    Environment I tried it on:

    Office 2013 64 bit

    Windows 7 Ultimate 64 bit 

    • Edited by S0heil Tuesday, July 22, 2014 12:52 PM
    Tuesday, July 22, 2014 12:49 PM
  • Thanks for the workarounds. I have a doc created a few years ago in Word 2010 that have embedded .HTM files in them but after upgrading to Word 2013 and trying to add more to this doc, I get the same error as the OP. The first workaround proposed as an answer just inserted the HTM file into the doc. I wanted the icon instead so the second workaround posted by Emilios Theori works but the embedded file shows up as "Package" rather than the named file. I really hope MS fixes this as now I need to find a different method to doing this in the future. 
    Tuesday, July 22, 2014 5:49 PM
  • I know this is an old thread, but I had the same issue. It turned out to be Chrome and IE fighting over ownership of html files. Once I re-associated IE as the default browser for html files and hypertext links this problem went away.
    Friday, June 5, 2015 6:56 PM
  • I searched and i found this workaround:If i delete a registry key HKEY_CLASSES_ROOT\.jpg (.png; and more). Error in Word 2013 is gone. But if i want open this object, from document. I must choice default program for open this object.

    Everything works. The problem occurs when the second user logs on PC. User must redo the association for the file type. The Association is then stored in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.png

    Does anyone have an idea how this association done on a PC and not on the user?



    Friday, October 30, 2015 1:24 PM
  • Dear Colleagues,

    I just had the problem in inserting an image with png extension into word 2013 . I read this thread but did not get any answer.

    I managed to cope with this issue . hope this work with anyone else using word 2013.

    just save the image on your hard drive . open the word document . drag the png into your word file using mouse button.

    Thursday, November 12, 2015 12:23 PM
  • It's true.

    Maybe it's under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FileAssociation

    Thursday, November 19, 2015 11:42 AM