locked
Issue with IE 11 pretending www. To intranet site after failed connection restored RRS feed

  • Question

  • Hi

    We have an issue where if for any reason our intranet site goes down any attempt to connect adds a www to the address http://www.intranet when connectivity is restored this does not correct itself and continues to add the www. Preventing connection. We can correct this by deleting the internet cache on the machine however this creates massive problems as a lot of our users depend on being able to connect to intranet sites to work, intranet cache deletion is prevented by security policy and can only be performed by an admin, internet cache deletion is not preferred for security and convenience reasons plus this affects over 10,000 users worldwide resulting in a huge inconvienience, loss of productivity and man hours required to rectify by IT support.

    I have looked at all the obvious options available in the internet settings but none of them prevent this behaviour. I would almost be bold enough to say that this is a bug in IE, certainly a failing as it cannot be said to offer any advantage to the user.

    Any advice on how to prevent this behaviour and allow IE to recconect automatically when the site becomes available without IT intervention would be greatly appreciated or perhaps I can convince MS to fix this bug.

    Thanks, Gary

    Monday, March 5, 2018 9:16 AM

All replies

  • I have looked at all the obvious options available in the internet settings but none of them prevent this behaviour.

    It will be a combination of them plus some registry settings.  Use ProcMon to help find them.  For example, in Advanced Options we have Go to an Intranet site for a single word entry... and in Content there once was a setting about what would be added as a prefix and a suffix depending on whether you pressed some modifier keys when you hit Enter.  I don't know where those have gone but imagine you may find them in the registry or in the group policy settings.

    Heh.  I just typed  intranet  in the Address bar and instead of just pressing Enter I pressed Alt+Ctrl+Enter and that generated a WWW URL for that host.  Where is that coming from?  How do we control it?  Etc.

    Good luck



    Robert Aldwinckle
    ---

    Monday, March 5, 2018 5:55 PM
    Answerer
  • Hi,

    try

    Tools>Internet Options>Advanced tab, check "Go to an intranet site for a single-word entry in the Address bar".... you may have to flush your dns.

    Close and re-open IE before re-testing.

    Regards.


    Rob^_^

    Tuesday, March 6, 2018 10:20 PM