locked
RDS 2012 R2 Collection - Published Remoteapps not visible RRS feed

  • Question

  • Hello,

    I have a strange issue with a RDS Deployment I´m setting up for a customer.

    RDS Roles setup:

    Server1: RD Licensing / RD Gateway

    Server2: RD Connection Broker / RD Sessions Host / RD Web Access

    I´m all done with the LOB Apps as well as adding ~30 users and migrated their profiles, I have set up UPD etc. All is working great and I´m almost ready to take it into production...apart from this annoying thing.

    I have created a Session Collection and published some remoteapps.

    However when I log in to the rdweb site it doesn´t show the published Remote Apps.I have tried to unpublish / republish, reboot and so on to no avail.

    How can I troubleshoot and solve this?

    Sure I could delete the session collection and create a new one, but what will happen with the created UPDs that has all the customized settings for the users (store all ?

    Can those be redeployed to the new Session Collection ?

    Also, I cannot be sure that this will even fix the issue.

    Any advise are very welcome.


    Thx /Tony

    Sunday, March 22, 2015 11:32 PM

Answers

  • Hello Darmesh,

    I did not assign any specific permissions, domain users is set. I ended up moving the RDGW role to the RDSH server though I know it´s not BPA. However this customer does not have more than one available Public IP. And as they wan´t to use both RDWeb and RDP through RDGW that was the solution. Othern than that I had to fix 2 things in IIS on the RDSH.

    1. Change the RDWebAccess Application Pool identity from ApplicationPoolIdentity to NetworkService

    2. RDWeb/Pages-Applications Settings, put in remote.company.com as value for "DefaultTSGateway

    Volia it works. As a sidenote I also added the "reghack" ShowInPortal" value 1 so the full desktop connection is also available in the RDweb portal, not supported I know, but will keep it for now.

    Any comments to this solution ?


    Thx /Tony





    Tuesday, March 24, 2015 10:15 AM

All replies

  • Hi Tony,

    Did you assign any specific permission to this user?

    Please remove the old applications from the RD Connection Broker's registry. Yeah, you may delete the entire old collection from the registry.
    Below is the key to look for the old published RemoteApp.  Each RemoteApp will be a separate subkey:
    HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Terminal Server\ CentralPublishedResources\ PublishedFarms\ <collectionAlias>\ Applications

    If you are creating new collection you need to customize the setting once again for UPD users but hey can redeploy to new session collection. For more information you can also refer following article.

    The Case of Invisible RemoteApp Programs (a.k.a. No RemoteApp Programs Listed on RD Web Access Site)
    http://social.technet.microsoft.com/wiki/contents/articles/5974.the-case-of-invisible-remoteapp-programs-a-k-a-no-remoteapp-programs-listed-on-rd-web-access-site.aspx

    Hope it helps!

    Thanks.

    Dharmesh Solanki

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, March 24, 2015 7:30 AM
  • Hello Darmesh,

    I did not assign any specific permissions, domain users is set. I ended up moving the RDGW role to the RDSH server though I know it´s not BPA. However this customer does not have more than one available Public IP. And as they wan´t to use both RDWeb and RDP through RDGW that was the solution. Othern than that I had to fix 2 things in IIS on the RDSH.

    1. Change the RDWebAccess Application Pool identity from ApplicationPoolIdentity to NetworkService

    2. RDWeb/Pages-Applications Settings, put in remote.company.com as value for "DefaultTSGateway

    Volia it works. As a sidenote I also added the "reghack" ShowInPortal" value 1 so the full desktop connection is also available in the RDweb portal, not supported I know, but will keep it for now.

    Any comments to this solution ?


    Thx /Tony





    Tuesday, March 24, 2015 10:15 AM