none
Error protecting Primary DPM Server RRS feed

  • Question

  • I've recently updated to DPM 2012 SP1 Rollup 2 and I can no longer backup my DPMDB.  In the past I've been backing it up using my Secondary server just fine.  I now receive the below error when attempting a sync.  I have tried backing up the DB on the primary itself and backing up a .bak version of it on both the primary and secondary -- I receive the same error.  I've tried modifying disk allocation to no avail.

    DPM failed to synchronize changes for SQL Server 2008 database DBname on DPMserverName because the snapshot volume did not have sufficient storage space to hold the churn on the protected computer (ID 30115 Details: VssError:Insufficient storage available to create either the shadow copy storage file or other shadow copy data.
     (0x8004231F))

    Tuesday, May 7, 2013 6:23 PM

Answers

  • Hi,

    What did this return ?  Vssadmin add shadowstorage /For=C: /on=C: /maxsize=unbounded 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Scott Cypher Tuesday, May 7, 2013 9:52 PM
    Tuesday, May 7, 2013 9:45 PM
    Moderator

All replies

  • Hi

    Check the free space on the C: drive (or the drive where the DPMDB is located on the primary DPM Server)

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 7, 2013 6:47 PM
    Moderator
  • Hi Mike -

    Plenty of free space on the drive where the DB is located. 

    Tuesday, May 7, 2013 7:01 PM
  • Hi,

    There has to be VSS errors in the application event log, or Volsnap errors in system event log, what do those details show.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 7, 2013 7:07 PM
    Moderator
  • Volsnap errors every sync fail, no VSS errors.

    Event ID:      39
    Description:
    When preparing a new volume shadow copy for volume C:, the shadow copy storage on volume C:\...2dd-4d19-a0a6-09f8c41f576a could not be located in non-critical space.  Consider using a shadow copy storage volume that does not have any shadow copies.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="volsnap" />
        <EventID Qualifiers="49158">39</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-05-07T19:42:50.682272700Z" />
        <EventRecordID>140843</EventRecordID>
        <Channel>System</Channel>
        <Computer>DPMServerName</Computer>
        <Security />
      </System>
      <EventData>
        <Data>\HarddiskVolumeShadowCopy1253</Data>
        <Data>C:</Data>
        <Data>C:\...2dd-4d19-a0a6-09f8c41f576a</Data>
        <Binary>000000000300300000000000270006C0000000007F0000C008000000000000000000000000000000</Binary>
      </EventData>
    </Event>

    Tuesday, May 7, 2013 7:45 PM
  • Hi,

    OK - it seems that somehow the shadow copy storage space for C: somehow ended up on another volume which does not have adequate space.

    Please run VSSADMIN LIST SHADOWSTORAGE and see what it looks like for the C: volume.  The default configuration should be that shadowstorage for C: is also on C: as seen below.

    C:\Windows\system32>vssadmin list shadowstorage
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    Shadow Copy Storage association
       For volume: (C:)\\?\Volume{4f20dbdb-6205-11df-a86d-806e6f6e6963}\
       Shadow Copy Storage volume: (C:)\\?\Volume{4f20dbdb-6205-11df-a86d-806e6f6e6963}\
       Used Shadow Copy Storage space: 0 B (0%)
       Allocated Shadow Copy Storage space: 0 B (0%)
       Maximum Shadow Copy Storage space: UNBOUNDED (100%)

    You can delete the shadow storage for C: then re-associate it as follows:

    vssadmin Delete ShadowStorage /For=C:

    Vssadmin add shadowstorage /For=C: /on=C: /maxsize=unbounded


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 7, 2013 8:03 PM
    Moderator
  • It kicks out quite a few.  There is one that seems to correspond with the volsnap error:

    Shadow Copy Storage association
       For volume: (C:\Program Files\Microsoft System Center 2012\DPM\DPM\Volumes\Replica\Microsoft Hyper-V VSS Writer\vol_b32ca131-62dd-4d19-a0a6-09f8c41f576a\)\\?\Volume{239382c2-adf2-11e2-93f6-001b214cb3ad}\
       Shadow Copy Storage volume: (C:\Program Files\Microsoft System Center 2012\DPM\DPM\Volumes\DiffArea\Microsoft Hyper-V VSS Writer\vol_b32ca131-62dd-4d19-a0a6-09f8c41f576a\)\\?\Volume{239382c8-adf2-11e2-93f6-001b214cb3ad}\
       Used Shadow Copy Storage space: 247 GB (43%)
       Allocated Shadow Copy Storage space: 250 GB (43%)
       Maximum Shadow Copy Storage space: UNBOUNDED (3020636360%)

    Tuesday, May 7, 2013 8:52 PM
  • Hi,

    I don't think that is correct, that seems to be for a Hyper-V VM backup.

    You can get the C: volume GUID by running mountvol.exe - then you can search the shadowstorage for that GUID.

    C:\Windows\system32>mountvol
    Creates, deletes, or lists a volume mount point.

    MOUNTVOL [drive:]path VolumeName
    MOUNTVOL [drive:]path /D
    MOUNTVOL [drive:]path /L
    MOUNTVOL [drive:]path /P
    MOUNTVOL /R
    MOUNTVOL /N
    MOUNTVOL /E

        path        Specifies the existing NTFS directory where the mount
                    point will reside.
        VolumeName  Specifies the volume name that is the target of the mount
                    point.
        /D          Removes the volume mount point from the specified directory.
        /L          Lists the mounted volume name for the specified directory.
        /P          Removes the volume mount point from the specified directory,
                    dismounts the volume, and makes the volume not mountable.
                    You can make the volume mountable again by creating a volume
                    mount point.
        /R          Removes volume mount point directories and registry settings
                    for volumes that are no longer in the system.
        /N          Disables automatic mounting of new volumes.
        /E          Re-enables automatic mounting of new volumes.

    Possible values for VolumeName along with current mount points are:

        \\?\Volume{4f20dbdc-6205-11df-a86d-806e6f6e6963}\
            *** NO MOUNT POINTS ***

        \\?\Volume{598052e5-362d-11e0-bd87-0019b9f81999}\
            E:\

        \\?\Volume{4f20dbdb-6205-11df-a86d-806e6f6e6963}\
            C:\

        \\?\Volume{9b53c92e-496a-11e2-acc6-0019b9f81999}\
            C:\Program Files\Microsoft DPM\DPM\Volumes\DiffArea\Non VSS Datasource Writer\vol_3a4326a2-ab4d-42e9-aa9e-7ff14a20e197\

        \\?\Volume{566d2e9a-68cd-11e2-b153-0019b9f81999}\
            C:\Program Files\Microsoft DPM\DPM\Volumes\DiffArea\SqlServerWriter\vol_3688aadc-c1d6-4214-bb89-a4dd4486d855\

    Or, since we know we need to fix it, Just run these two commands from administrative command prompt and that should fix the issue.

    vssadmin Delete ShadowStorage /For=C:
    Vssadmin add shadowstorage /For=C: /on=C: /maxsize=unbounded


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, May 7, 2013 9:16 PM
    Moderator
  • OK - I see that:

    Possible values for VolumeName along with current mount points are:

        \\?\Volume{eac6324a-0f03-11e2-9f64-806e6f6e6963}\
            *** NO MOUNT POINTS ***

        \\?\Volume{eac6324b-0f03-11e2-9f64-806e6f6e6963}\
            C:\

        \\?\Volume{23938421-adf2-11e2-93f6-001b214cb3ad}\
            C:\Program Files\Microsoft System Center 2012\DPM\DPM\Volumes\Replica\File System\vol_4812328f-bc76-4af2-b255-7b2b3b0c7958\

        \\?\Volume{239382c8-adf2-11e2-93f6-001b214cb3ad}\
            C:\Program Files\Microsoft System Center 2012\DPM\DPM\Volumes\DiffArea\Microsoft Hyper-V VSS Writer\vol_b32ca131-62dd-4d19-a0a6-09f8c41f576a\

    Running "vssadmin Delete ShadowStorage /For=C:" returns an error however.

      Error: The specified volume shadow copy storage association was not found.

    Tuesday, May 7, 2013 9:36 PM
  • Hi,

    What did this return ?  Vssadmin add shadowstorage /For=C: /on=C: /maxsize=unbounded 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Scott Cypher Tuesday, May 7, 2013 9:52 PM
    Tuesday, May 7, 2013 9:45 PM
    Moderator
  • Didn't run it as I was thrown off by the error.  It added successfully. 

    And a sync worked as well, thanks Mike!

    Tuesday, May 7, 2013 9:53 PM