locked
Server 2016 TP5 change language RRS feed

  • Question

  • I have a TP5 english image and installed the german language with the language pack image over lpksetup. Now I wanted to switch to german and changed every language setting but the names and descriptions from features and roles in ServerManager are still in english. After this I installed an german image to verify if the features and roles are always in english but they were in german. So I hope someone has an idea how I can change the language from a base image.

    I tried to use PowerShell Cmdlets and Dism:

    Set-WinUILanguageOverride de-DE

    Dism /image:C:\test\offline /Set-AllIntl:de-DE

    The most things are changed but the name and description from features and roles in ServerManager are still in english.

    Thanks in advance


    • Moved by BrianEhMVP Tuesday, September 20, 2016 2:46 PM
    • Edited by Bootless Tuesday, September 20, 2016 3:05 PM
    Tuesday, September 20, 2016 8:04 AM

Answers

  • Okay, seems like I got it working.

    I added the language over the GUI and downloaded the language pack over the "Options" button.

    Then i executed the following CMDlets:

    Set-WinUserLanguageList de-DE -Force
    Set-Culture de-DE
    Set-WinHomeLocation -GeoId 94
    Set-WinsystemLocale de-DE

    After this I see that the system downloads the "german handwritings" and then I set settings with intl.cpl

    control.exe intl.cpl,,/f:"C:\Users\Administrator\Desktop\mui.xml"

    The content of mui.xml is the following:

    <gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend">
    <!-- User List -->
    <gs:UserList>
    <gs:User UserID="Current" CopySettingsToSystemAcct="true" CopySettingsToDefaultUserAcct="true"/>
    </gs:UserList>
    </gs:GlobalizationServices>

    After this I reboot the system and everything is fine.

    Best regards

    • Marked as answer by Bootless Wednesday, October 5, 2016 3:13 PM
    Wednesday, October 5, 2016 3:13 PM

All replies

  • Hi,

    I don't find Tp5 related official documents because it is a preview version.But I found user interface language articles about windows server 2012r2,you could check for reference:

    1.In Server Manager, role and feature data is displayed in the base language of the system, also called the system default GUI language, or the language selected during installation of the operating system.

    REF:Manage the Local Server and the Server Manager Console

    https://technet.microsoft.com/en-us/library/jj134147(v=ws.11).aspx

    2.No MUI function is available to set the system default UI language.

    User Interface Language Management

    https://msdn.microsoft.com/en-us/library/windows/desktop/dd374098(v=vs.85).aspx

    According your description,I suppose TP5 still use this.

    Considering TP5 is a preview version, you could go to  the Windows Server User Voice site to give feedback,thank you.


    Best Regards,
    Cartman
    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 21, 2016 6:27 AM
  • I am checking to see if the problem has been resolved. If there's anything you'd like to know, don't hesitate to ask.


    Best Regards,
    Cartman
    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, September 23, 2016 6:36 AM
  • Hi, thanks for your help. Unfortunately I didn't managed to change the Language from Roles and Features in a known way. Somehow I changed the language once but don't know how I did that. I am using the following Cmdlets:

    • Set-WinUserlanguageList "de-DE" -Force
    • Set-WinUILanguageOverride "de-DE"
    • Set-WinSystemLocale "de-DE"
    • Set-Culture "de-DE"
    • Set-WinDefaultInputMethodOverride "0407:00000407"
    • Set-WinHomeLocation -GeoId "94"

    I am using the actual Windows Server 2016 Eval, installed the languagepacks via GUI beforehand and can't manage to change the language that is shown in Server Manager under Roles and Features with a script.

    Hopefully you found something out or someone has an idea what I am doing wrong.

    (Btw. strange is that I can give a string like "de-DE" to Set-WinDefaultInputMethodOverride and that this will not get caught but I get an System.Exception when I try to get Get-WinDefaultInputMethodOverride)

    Thanks in advance and best regards



    • Edited by Bootless Tuesday, October 4, 2016 1:43 PM
    Tuesday, October 4, 2016 11:27 AM
  • Okay, seems like I got it working.

    I added the language over the GUI and downloaded the language pack over the "Options" button.

    Then i executed the following CMDlets:

    Set-WinUserLanguageList de-DE -Force
    Set-Culture de-DE
    Set-WinHomeLocation -GeoId 94
    Set-WinsystemLocale de-DE

    After this I see that the system downloads the "german handwritings" and then I set settings with intl.cpl

    control.exe intl.cpl,,/f:"C:\Users\Administrator\Desktop\mui.xml"

    The content of mui.xml is the following:

    <gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend">
    <!-- User List -->
    <gs:UserList>
    <gs:User UserID="Current" CopySettingsToSystemAcct="true" CopySettingsToDefaultUserAcct="true"/>
    </gs:UserList>
    </gs:GlobalizationServices>

    After this I reboot the system and everything is fine.

    Best regards

    • Marked as answer by Bootless Wednesday, October 5, 2016 3:13 PM
    Wednesday, October 5, 2016 3:13 PM
  • Hi,

    Thank you for sharing to us.


    Best Regards,
    Cartman
    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 6, 2016 1:18 AM