locked
Excel 2010 + Issues when opening an Office Data Connection (ODC) file from Office SharePoint 2010 Data Connection Library RRS feed

  • Question

  • Hi 

    Unfortunately, I could not get any Help from any source with respect to an issue I am facing with SharePoint Data Connection Library and opening reports from a trusted sharepoint location.
    We have configured Excel Web Services in our SharePoint 2010 environment. Added Trusted Data Connection Library and Trust file locations. When a user opens the Office Data Connection file (ODC) from a trusted Data Connection Library it directly opens in Excel 2010 client interface. So far good. Then we see the following issues as below:
    1. However we see an Edit Excel option button, dont know why. (infact we dont need it)
    2. When click the Edit button some times see error "problem connecting to the data ............
    3. Sometimes on clicking the Edit Work Sheets says the connection was locked for edit by.........
    4. Even after publishing the workbook, and open the Excel from published location, we see an error saying error occured at transport layer......

    5. Also the number formats changes, we see a different format when accessing the cube data directly from Excel than when accesses from an ODC file from SharePoint Data Connection Library

    Are there any setting in SharePoint 2010 Central Administration to resolve this issue?

    Just wondering, if this is a bug with SharePoint 2010 product or with Excel 2010. Unfortunately I don have any clue of what is happening behind the scenes.

    Appreciate if someone could help me to resolve the issue. http://social.msdn.microsoft.com/Forums/eu/sharepointgenerallegacy/thread/711cacb4-09c8-437b-ae9c-bfc059b2d10e

    If not a solution to the problem, atleast a contact of a Microsoft support team member who can help me with this issue, so that I can directly interact with them, as I have to get this resolved at the earliest.


    Best Regards, Paramesh.


    Wednesday, November 28, 2012 9:18 AM

Answers

  • Hi All,

    Atlast found a workaround with the help of a Microsoft asscociate. Let me first thank to Andrei Nutu (Microsoft associate) whi gave me a beautiful work around for the issue.

    The issue was that, the file puts a lock on on the odc file shared in the Data Connection library when some one edits the file, I mean click on Edit Document button in the opened Excel. This will result in one of the top two issues mentioned in the first post.

    So what is the resolution:

    1. Create a new document library. In the settings, ensure allow management of content types is selected and open in client application option.

    2. Create a new Excel by opening from the odc file. Do not add any content, at this point of time your excel will just have only the connection. Now save this excel file to your local disk, some location on your system.

    3. In Step 1 we have created a Document library, navigate to the library settings page, you will document (default content type) listed undercontent types. Click that. Then click on advanced setting. Now upload the previously saved file as template in that settings and click OK. Now your file has become a template with the connection string.

    4. If you are directly creating a new file from Documents --> New Document and will see the file open with connection and dat which can be saved to a different location ina SharePoint of any location.

    5. What if, if you want to have a similar approach like clicking link to invoke the new document...... then the post http://www.macaw.nl/weblog/2012/8/extreme-new-document-button-makeover had a great information

    Use the script

    CreateNewDocumentWithProgID( 
      'http://sharepoint/Templates/template.dotx', 
      'http://sharepoint/Shared Documents/', 
      'SharePoint.OpenDocuments', 
      false);

    And you are done.

    Thank you again to Andrei Nutu and Macaw.


    Best Regards, Paramesh.

    Monday, December 17, 2012 9:17 PM

All replies

  • I am surprised not to see a single response yet. All Microsoft technology aspirants... you there?

    Best Regards, Paramesh.

    Tuesday, December 11, 2012 1:40 PM
  • Hi All,

    Atlast found a workaround with the help of a Microsoft asscociate. Let me first thank to Andrei Nutu (Microsoft associate) whi gave me a beautiful work around for the issue.

    The issue was that, the file puts a lock on on the odc file shared in the Data Connection library when some one edits the file, I mean click on Edit Document button in the opened Excel. This will result in one of the top two issues mentioned in the first post.

    So what is the resolution:

    1. Create a new document library. In the settings, ensure allow management of content types is selected and open in client application option.

    2. Create a new Excel by opening from the odc file. Do not add any content, at this point of time your excel will just have only the connection. Now save this excel file to your local disk, some location on your system.

    3. In Step 1 we have created a Document library, navigate to the library settings page, you will document (default content type) listed undercontent types. Click that. Then click on advanced setting. Now upload the previously saved file as template in that settings and click OK. Now your file has become a template with the connection string.

    4. If you are directly creating a new file from Documents --> New Document and will see the file open with connection and dat which can be saved to a different location ina SharePoint of any location.

    5. What if, if you want to have a similar approach like clicking link to invoke the new document...... then the post http://www.macaw.nl/weblog/2012/8/extreme-new-document-button-makeover had a great information

    Use the script

    CreateNewDocumentWithProgID( 
      'http://sharepoint/Templates/template.dotx', 
      'http://sharepoint/Shared Documents/', 
      'SharePoint.OpenDocuments', 
      false);

    And you are done.

    Thank you again to Andrei Nutu and Macaw.


    Best Regards, Paramesh.

    Monday, December 17, 2012 9:17 PM