locked
Unable to get Scroll bar in Sharepoint integrated SSRS report RRS feed

  • Question

  • Hello Everyone,

    We host SSRS reports in sharepoint site for MSPS 2010(microsoft project server).

    when we run the report and expands the last parameter drop down to select the values(multi select parameter) all the values are not visible as those values get trimmed when they go below the web browser. I am using IE8. Ideally the scroll bar should get adjusted so that the page can be scrolled down to see all the parameter values but scroll bar doesn't get expanded.

    Please suggest me how to adjust UI of sharepoint page or any config change at report level.

    Thanks in advance :)


    Sushant

    Friday, February 1, 2013 8:15 AM

Answers

  • Hi,

    I got the answer to the problem after searching lot of stuff on sharepoint page settings and SSRS -sharepoint integrated mode. So i thought of mentioning resolution here so that others can be benifited by this.

    There is a default page "RSViewerPages.aspx" in the Sharepoint integrated SSRS. this page is used to display report in PWA site(page in screen shot). so we need to edit the HTML tag in this page which controls the auto scroll bar.

    The location of the page on the server is:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\ReportServer\RSViewerPage.aspx.

    Thanks,

    Sushant Yadav

    -----------------------------------------

    If you found this help then Please vote as helpful by clicking green triangle


    Sushant

    Tuesday, February 5, 2013 5:49 AM

All replies

  • Hi Sushant ,

                      Have u checked your report in another browser? if not please chk sometime compatibility issues raise this kind of prob.

    Thanks,

    Vinay

                    

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer
    • Edited by MeShare Friday, February 1, 2013 9:20 AM
    Friday, February 1, 2013 9:10 AM
  • Hi Vinay,

    Actual that application is meant only for IE8 , its a client requirement.

    Thanks,

    Sushant


    Sushant

    Friday, February 1, 2013 9:19 AM
  • Hi,

    I got the answer to the problem after searching lot of stuff on sharepoint page settings and SSRS -sharepoint integrated mode. So i thought of mentioning resolution here so that others can be benifited by this.

    There is a default page "RSViewerPages.aspx" in the Sharepoint integrated SSRS. this page is used to display report in PWA site(page in screen shot). so we need to edit the HTML tag in this page which controls the auto scroll bar.

    The location of the page on the server is:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\ReportServer\RSViewerPage.aspx.

    Thanks,

    Sushant Yadav

    -----------------------------------------

    If you found this help then Please vote as helpful by clicking green triangle


    Sushant

    Tuesday, February 5, 2013 5:49 AM
  • Hi Sushant,

    We are experiencing this same issue.  Would you please describe what exactly you changed and what you changed it to?

    Thanks,

    Josh

    Monday, January 26, 2015 3:39 PM
  • Hi Josh,

    i followed following steps-

    Resolution

    We need to change the HTML property of this page. “RSViewerPage.aspx” page is a default page created by Sharepoint server while installing Project server Instances. We can get RSViewerPage.aspx in server where PWA instances at default location:

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\LAYOUTS\ReportServer\RSViewerPage.aspx.

    Steps to implement change-

    1-      Open the “RSViewerPage.aspx” page using visual studio or Notepad.

    2-      Look for the tag- <HTML>,

    <html dir="<%$Resources:wss,multipages_direction_dir_value%>" runat="server" style=""background:yellow;">hidden;width:100%;height:100%">

    Here the property of “overflow” tag will be hidden by default

    3-      Change the property of “overflow” tag to auto-

    4-      <html dir="<%$Resources:wss,multipages_direction_dir_value%>" runat="server" style=""background:lime;">auto;width:100%;height:100%">

    Risks:

    It’s a configuration page Change for all the instances created on one single server. If Configuration page is  improperly edited, there are chances that reports in sharepoint integrated mode may not work properly.

    Take a backup of “RSViewerPage.aspx” page before editing the tag. If edited page gets corrupted then replace that with original page. The service will get restored.


    Sushant

    If you found it helpful, Please Mark as Answer.
    Tuesday, January 27, 2015 6:53 AM
  • hi

    it works for SharePoint 2016? i try to reset this configure in sharepoint 2016 environment but it does not work! any suggestions, thanks.

    BR.

    Fanghao


    peardong

    Monday, August 7, 2017 10:33 PM