none
executable on fileshare getting exclusive lock (write+read) on itself while other users already accessing it ( sbs2003 ) RRS feed

  • Question

  • hi all,

    i'm currently experiencing a locking problem with a client.

    They run our software from a shared directory on sbs2003 SP2 on windows 7 64-bit clients

    when looking at compmgmt - open files i see locks from multiple users in open mode "read", then after a while a user quits and relaunches the excutable and then he gets open mode "write+read", this blocks all subsequent launches of the executable with a sharing violation ( analyzed in process monitor )

    oplocks are disabled on the server and a capture of network traffic revealed the request for an oplock but it was not granted

    when looking at the machine causing the problem the only thing locking the executable is the executable itself. inside the image of the running executable there are no foreign threads ( antivirus or other )

    i'm stumped and looking for fresh ideas on how to find the culprit

    Tuesday, August 20, 2013 10:57 AM

Answers

  • Hi msTimbo,

    please disable SMB2 on both of servers and clients.

    To disable SMB2 change or add the  following Registry value:

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters SMB2 = 0

    after that, please reboot the server and clients.

    Best Regards,

    Mike

    Thursday, August 22, 2013 11:14 AM

All replies

  • Hi ,

    Thank you for posting your issue in the forum.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Justin Gu

    Wednesday, August 21, 2013 12:13 PM
    Moderator
  • Hi msTimbo,

    please disable SMB2 on both of servers and clients.

    To disable SMB2 change or add the  following Registry value:

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters SMB2 = 0

    after that, please reboot the server and clients.

    Best Regards,

    Mike

    Thursday, August 22, 2013 11:14 AM