locked
Word 2010 could not create the work file - error message when opening Word email attachments RRS feed

  • Question

  • Using Windows 7 and Word 2010, I suddenly cannot open Word documents emailed to my yahoo account without 4 error messages appearing:

    1. Word could not create the work file.  Check the temp environment variable

    2. This document could not be registered.  It will not be possible to create links from other documents to this document

    3. Word could not fire the event

    4. If despite these error messages, I am able to click on the Enable Editing button, a further warning pops up in Word - Changes have been made that affect the global template, Normal.  Do you want to save these changes?

    Any suggestions?  I have un-installed and re-installed Office 2010 but with no success, the probelm is still there

    Many thanks

    • Moved by Carey FrischMVP Monday, August 30, 2010 12:11 AM Move to appropriate forum category (From:Windows Vista Setup)
    • Moved by Sally Tang Tuesday, August 31, 2010 7:21 AM (From:Office 2010 Application Compatibility)
    Sunday, August 29, 2010 11:18 AM

Answers

  • The error message "Word could not create the work file. Check the temp environment variable". Can be caused by incorrect registry values in the key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders.
    Click on the Windows Start and in the start search field, type
    Regedit
    and press enter.
    In the registry editor, browse to:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders
    On the right hand pane, check the value data for Cache.
    It has to be %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files.
    If it is different, double click on Cache and type:
    %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files
    under value data and click ok. Close the registry and  restart the computer and check if it works.


    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "perdita" wrote in message news:ade00dbd-4dc1-49ba-89e2-d43af5c85356@communitybridge.codeplex.com...

    Using Windows 7 and Word 2010, I suddenly cannot open Word documents emailed to my yahoo account without 4 error messages appearing:

    1. Word could not create the work file.  Check the temp environment variable

    2. This document could not be registered.  It will not be possible to create links from other documents to this document

    3. Word could not fire the event

    4. If despite these error messages, I am able to click on the Enable Editing button, a further warning pops up in Word - Changes have been made that affect the global template, Normal.  Do you want to save these changes?

    Any suggestions?  I have un-installed and re-installed Office 2010 but with no success, the probelm is still there

    Many thanks


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    • Marked as answer by Sally Tang Friday, September 3, 2010 7:12 AM
    Tuesday, August 31, 2010 7:51 AM

All replies

  • Hi,

     

    Can you open your Word program or other Word documents on the computer?

     

    1.       Please right-click on Computer and select Properties.

    2.       Select the Advanced system settings.

    3.       Select the Environment Variables button.

    4.       Check the location of TEMP & TMP (usually c:\temp, or c:\windows\temp )

    5.       Make sure the setting exists, first of all, then check that there is such a location on your hard drive. Check these folders and delete the temp files.

     

    If this does not work, try the steps in this KB to delete the Word registry keys:

    How to troubleshoot problems that occur when you start or use Word 2010, Word 2007, Word 2003, or Word 2002

    http://support.microsoft.com/kb/921541

     

    Best Regards,

     

    Sally Tang

    Tuesday, August 31, 2010 7:30 AM
  • The error message "Word could not create the work file. Check the temp environment variable". Can be caused by incorrect registry values in the key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders.
    Click on the Windows Start and in the start search field, type
    Regedit
    and press enter.
    In the registry editor, browse to:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\Current Version\Explorer\User Shell Folders
    On the right hand pane, check the value data for Cache.
    It has to be %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files.
    If it is different, double click on Cache and type:
    %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary Internet Files
    under value data and click ok. Close the registry and  restart the computer and check if it works.


    -- Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "perdita" wrote in message news:ade00dbd-4dc1-49ba-89e2-d43af5c85356@communitybridge.codeplex.com...

    Using Windows 7 and Word 2010, I suddenly cannot open Word documents emailed to my yahoo account without 4 error messages appearing:

    1. Word could not create the work file.  Check the temp environment variable

    2. This document could not be registered.  It will not be possible to create links from other documents to this document

    3. Word could not fire the event

    4. If despite these error messages, I am able to click on the Enable Editing button, a further warning pops up in Word - Changes have been made that affect the global template, Normal.  Do you want to save these changes?

    Any suggestions?  I have un-installed and re-installed Office 2010 but with no success, the probelm is still there

    Many thanks


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    • Marked as answer by Sally Tang Friday, September 3, 2010 7:12 AM
    Tuesday, August 31, 2010 7:51 AM
  • Can't thank you enough for this. It has solved the problem in a way I can understand and apply. I have a mere cavil -- or so I suppose -- could I bring it to your attention?

    On my version of Windows 7, there is no directory "Appdata," nor of "Local," so the direcitons in the registry key you supply could cause problems eventually?

    For now, it works as it did when I first installed it.

    Thanks and regards,

    Andrew Rosenbaum

    Saturday, January 15, 2011 11:06 PM
  • Those directories will be there, but  to see them, you will need to access the Folder Options dialog via the Organizer>Folder and Search Options menu in Windows Explorer and then on the View tab of the Folder Options dialog, select the radio button for "Show hidden files, folders, and drives" under "Hidden files and folders".


    Hope this helps.

    Doug Robbins - Word MVP,
    dkr[atsymbol]mvps[dot]org
    Posted via the Community Bridge

    "arosarosa" wrote in message news:e8f44577-56d9-43c6-94cf-163d5b31709a@communitybridge.codeplex.com...

    Can't thank you enough for this. It has solved the problem in a way I can understand and apply. I have a mere cavil -- or so I suppose -- could I bring it to your attention?

    On my version of Windows 7, there is no directory "Appdata," nor of "Local," so the direcitons in the registry key you supply could cause problems eventually?

    For now, it works as it did when I first installed it.

    Thanks and regards,

    Andrew Rosenbaum


    Doug Robbins - Word MVP dkr[atsymbol]mvps[dot]org
    Sunday, January 16, 2011 12:39 AM
  • I had the same problem and followed Sally's steps. I changed the locations of TMP and TEMP to a new folder I created called C:\temp_do_not_delete on both the user side and the system side. This solved the problem but only for a brief time. The same problem occured again with Word, shortly after doing a complete install of Adobe Create Suite CS6. So I went to C:\temp_do_not_delete and cleaned out everything that was deletable. Now Word is happy again. My guess is that the Adobe install filled up C:\temp_do_not_delete and I hit some type of size limit on the folder which crashed Word.

    Is there some way to reserve space for C:\temp_do_not_delete. If so, how much would it be reasonable to set aside?

    Thanks for your help,

    Rich in Sunny Amarillo

    Tuesday, June 12, 2012 8:49 PM
  • I got all teh way to seeing c:\temp, or c:\windows\temp in the Environment Variables/System Variables section.  But you lost me with "Check that their is such a location on your hard drive" (How Do I Do That) and "Check these folders and delete the temp files" (You mean the "temp files" on the hard drive or in the Environment Variables/System Variables box.

    Please advise.  I'm desperate.

    Friday, July 6, 2012 11:01 AM
  •  Followed your advise but the entry is as it is supposed to be.

    Friday, July 6, 2012 11:07 AM
  • Just click - start -

    type in help - select - windows help and support-and press enter

    A help file opens -

    close is--- and you are done..........

    Friday, March 15, 2013 2:32 AM