locked
Disable Lync SIP OPTIONS Requests RRS feed

  • Question

  • Hi,

    We are experiencing the following error with one of our SIP gateway providers. MEDIATIONSERVER_GATEWAY_OPTIONS_FAILED (Event ID: 25051). Until they can sort this we need to be able to disable the SIP OPTIONS request check Lync is doing as it fails. Once we have 5 failures the gateway is marked as down even though we can use it!

    To reset the down 'flag' we have to restart the mediation service. Then after about 7 minutes the gateway is marked as down and we start again.

    Hope someone can help.

     

    Thanks and regards,


    Alex.

    Monday, July 18, 2011 10:44 AM

Answers

  • What CU has been applied? If the gateway cant respond to to the SIP options requests and you are on CU2 you may need to regress to a previous CU. In CU2 a failure to respond meant the gateway is marked as down. Previous to this CU release this was not the case.

     

    Cheers
    Chris


    http://voipnorm.blogspot.com/
    • Marked as answer by Sharon.Shen Friday, July 29, 2011 8:03 AM
    Wednesday, July 20, 2011 4:47 PM

All replies

  • Hi,Alex,

    You have two option to disable the sip request.One is through Lync Control Panel and the other is in PowerShell.

    Open Lync Control Panel,go to Voice Routing then locate trunk configuration and clear out the tag of item "enable refer support".

    Or Disable Refer in PowerShell: Set-CsTrunkConfiguration –Idenity <Xds Identity> -EnableReferSupport $false

    More details about Set-CsTrunkConfiguration syntax please look at http://technet.microsoft.com/en-us/library/gg398238.aspx

    Regards,

    Sharon

    Tuesday, July 19, 2011 7:30 AM
  • I don't think there is a way to disable OPTIONS at present. Indeed OPTIONS are used to monitor the Gateway availability. If you have only one Gateway (or provider acting as gateway), the call ultimately will be send to this destination even if marked as "Down" due to the lack of choice". Besides the annoyance of the error in the log, nothing will prevent the call to be established if the provider respond to your request.

     

    Drago


    http://www.lynclog.com
    Tuesday, July 19, 2011 11:36 AM
  • Hi,

    The trunk config is already set to disable refer support. My thoughts where the same as yours Drago; however it does not seem to be the case:

    Once I receive the 25051 error 5 times the following error is logged and you cannot make a call to the gateway until you restart the mediation service to clear the 'down' flag. Existing calls and inbound are not affected.

     

    25061 : The Mediation Server service has encountered a major connectivity problem with these gateway peer(s).

    Affected PSTN Gateway Service Cluster(s):

    xxx.xxx.xxx.xxx

    Cause: MEDIATIONSERVER_GATEWAY_OPTIONS_FAILED (Event ID: 25051) was recorded 5 times. Check other MOM alerts for more details. The MEDIATIONSERVER_GATEWAY_IP_NOT_AVAILABLE (Event ID: 25036), MEDIATIONSERVER_GATEWAY_TLS_NEGOTIATION_FAILED (Event ID: 25040) are examples of events that signal connectivity error conditions with the gateway peer.

    Resolution:

    If the failure is MEDIATIONSERVER_GATEWAY_IP_NOT_AVAILABLE (Event ID: 25036), make sure that the correct listening IP and port for the gateway have been configured in the PSTN gateway object in management store and that the gateway is up and running and able to accept incoming connections from the Mediation Server. If the failure is MEDIATIONSERVER_GATEWAY_TLS_NEGOTIATION_FAILED (Event ID: 25040), make sure that both the Mediation Server and the gateway are configured for TLS and that the CA for the Gateway's certificate is the trusted certificate path on the Mediation Server and the CA for the Mediation Server's certificate is in the trusted certificate path on the gateway.

    Wednesday, July 20, 2011 7:15 AM
  • Puzzling, indeed. Due to the lack of alternative gateway(s), Lync MUST attempt to use the (only) available gateway even if it marked "down" (caller could hear few beeps before Ringing).

    If this assumption is wrong, will MSFT please clarify the mechanism/logic Lync applies?

     

    Drago


    http://www.lynclog.com
    Wednesday, July 20, 2011 3:13 PM
  • What CU has been applied? If the gateway cant respond to to the SIP options requests and you are on CU2 you may need to regress to a previous CU. In CU2 a failure to respond meant the gateway is marked as down. Previous to this CU release this was not the case.

     

    Cheers
    Chris


    http://voipnorm.blogspot.com/
    • Marked as answer by Sharon.Shen Friday, July 29, 2011 8:03 AM
    Wednesday, July 20, 2011 4:47 PM
  • Thanks, Chris! Good to know... but this is not good.

     

    Drago


    http://www.lynclog.com
    Wednesday, July 20, 2011 8:30 PM
  • When the gateway is marked as unavailable I do not get any outbound call routing.

    I have set the EnableReferSupport to false using PowerShell and still the gateway is marked offline. Anyone have any further ideas rather than backout CU2?

    Regards

    Ben

     

     

    Wednesday, October 5, 2011 11:35 AM
  • Thanks,

    Refer has been disabled since day one.

    Removing KB 2503810 is the only way to get it to work.  Lync still generates the same errors, it just doesn't shut down the route to the PSTN.

     


    Ian 'Skip' Guyer
    Monday, December 5, 2011 12:12 AM
  • Thanks,

    That's accurate until KB2503810 has been installed. 

     


    Ian 'Skip' Guyer
    Monday, December 5, 2011 12:14 AM
  • Ben,

    That's you're only option unless you want to spring for a new Gateway that's on Microsoft's approved list.  They did tell me how to change the response from the Gateway to fix it, but since it's generated by third party software, that's above my pay grade.

    I found removing KB2503810 let's you go back to running with errors instead of down with errors.

     


    Ian 'Skip' Guyer
    • Edited by Ian Guyer Monday, December 5, 2011 12:18 AM
    Monday, December 5, 2011 12:17 AM
  • Interestingly, I have reproduced this behavior - gateway was removed from the network and furthermore could not reply to OPTIONS request. Waited 15 minutes (event 25051 was registered) but later (more than 15 minutes), when the gateway was introduced back, Mediation promptly requested OPTIONS (actually it never stopped to do so), received 200 OK and the call was routed via this gateway. This is the expected behavior - I have confirmed it with the Mediation team.

    The environment is CU4.

     

    Drago


    http://www.lynclog.com
    Monday, December 5, 2011 1:08 AM
  • Drago,

    Interesting indeed.   After reintroducing gateway to the network, did it stay up longer than 10 minutes?

    As I understand it, if the OPTIONs command from the Mediation Server is not responded to 5 times, or the 200 OK response is not the proper format (my case - the Gateway doesn't have the 'VIA header in the SIP 200 OK response - it was OCS compatible, but it is no longer Lync compatible with CU2+), the Mediation Server marks the PSTN Gateway as down.  Lync issues the OPTIONs command approximately every 1.5 minutes, so 5 x 1.5 = 7.5 minutes.



    Ian 'Skip' Guyer
    Monday, December 5, 2011 1:36 AM
  • All,

    Not sure if this helps but it might point someone in a direction to investigate further.

    I've been having issues with a Lync deployment Cancelling SIP invites out to an Avaya gateway when the server doesn't resond fast enough.  After lots of head scratching and getting nowhere I came across a post by Attila_HUN (http://ipfone.hu/lync-mediation-server-cancel-problem/) which might help with the issue you're having.

    It looks like Lync uses the OutboundRouting.exe.CONFIG file to set the time it waits for a SIP response of Session Progress or Ringing.  The default is around 9 seconds which isn't enough in our case as mobile carriers and international numbers are sometimes taking more than that to respond.  I've doubled the value this evening and am hoping that improves/resolves the situation.

    In the file there are also values for 'FailuresForGatewayDown' and 'FailuresForGatewayLessPreferred' which can be set to anything between 5 and 600.  I can't find any documentation for the keys in these config files so if anyone has any please post them up but this might point you at something which could help.  It might be possible to set your value to a much higher level before the gateway thinks it is down.

    Cheers,

    Gerry.

    Monday, February 20, 2012 6:50 PM
  • All,

    Not sure if this helps but it might point someone in a direction to investigate further.

    I've been having issues with a Lync deployment Cancelling SIP invites out to an Avaya gateway when the server doesn't resond fast enough.  After lots of head scratching and getting nowhere I came across a post by Attila_HUN (http://ipfone.hu/lync-mediation-server-cancel-problem/) which might help with the issue you're having.

    It looks like Lync uses the OutboundRouting.exe.CONFIG file to set the time it waits for a SIP response of Session Progress or Ringing.  The default is around 9 seconds which isn't enough in our case as mobile carriers and international numbers are sometimes taking more than that to respond.  I've doubled the value this evening and am hoping that improves/resolves the situation.

    In the file there are also values for 'FailuresForGatewayDown' and 'FailuresForGatewayLessPreferred' which can be set to anything between 5 and 600.  I can't find any documentation for the keys in these config files so if anyone has any please post them up but this might point you at something which could help.  It might be possible to set your value to a much higher level before the gateway thinks it is down.

    Cheers,

    Gerry.

    I am also interested in the description of these values. Just dont expect the answer from the forum admins, they will shout the answer in chorus: NOT SUPORTED (thats the jolly-joker if nobody internally at MS knows the answer :) )! However anybody else is more than welcome to shed some light.

    • Edited by Rich.Pa Tuesday, May 29, 2012 6:18 AM
    Saturday, March 24, 2012 10:08 AM
  • Hello Alex,

    Have run into the same issue in my environment too.. Any suggestions?

    Thanks,

    Madhu

    Monday, March 18, 2013 12:19 PM