none
Anywhere Access: Only shows IIS Welcome page

    Question

  • I set up Anywhere Access and it had an issue with port forwarding the first try.  I changed some things and set it up correctly.  But now when I go to the URL from any browser on or off of my network, I only see the IIS Welcome page.  This is for Windows Server 2016.  On 2012 I used to see the Remote Web Access login page.  Is there a way to set that up?  I repaired and reconfigured Anywhere Access many times.  Still I only get the IIS Welcome page.
    • Edited by djb77v Tuesday, October 18, 2016 10:04 AM
    Tuesday, October 18, 2016 10:03 AM

Answers

  • I also experience the same issue on Essentials 2016. I can manually go to https://mydomain.com/remote and log in successfully to Access Anywhere so it does work.

    The root folder of the Default Website on Essentials 2012 points to C:\Program Files\Windows Server\Bin\WebApps\Site

    The root folder of the Default Website on Essentials 2016 points to C:\inetpub\wwwroot

    The following folder path C:\Program Files\Windows Server\Bin\WebApps\Site does exist on Essentials 2016 and if I manually change the Default Website root path to C:\Program Files\Windows Server\Bin\WebApps\Site then Access Anywhere loads but the page says RWW is not configured.

    • Marked as answer by djb77v Thursday, October 20, 2016 10:08 AM
    Wednesday, October 19, 2016 10:19 AM

All replies

  • Hi, 

    Make sure that you have configured the router/network correctly, “Windows Server 2012 Essentials: Router Setup” can also be considered as a reference for WS 2016:
    http://social.technet.microsoft.com/wiki/contents/articles/14153.windows-server-2012-essentials-router-setup.aspx

    Reference “Troubleshoot Remote Web Access connectivity in Windows Server Essentials” to check the details:
    https://technet.microsoft.com/en-us/library/jj635096(v=ws.11).aspx

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 19, 2016 8:45 AM
    Moderator
  • I also experience the same issue on Essentials 2016. I can manually go to https://mydomain.com/remote and log in successfully to Access Anywhere so it does work.

    The root folder of the Default Website on Essentials 2012 points to C:\Program Files\Windows Server\Bin\WebApps\Site

    The root folder of the Default Website on Essentials 2016 points to C:\inetpub\wwwroot

    The following folder path C:\Program Files\Windows Server\Bin\WebApps\Site does exist on Essentials 2016 and if I manually change the Default Website root path to C:\Program Files\Windows Server\Bin\WebApps\Site then Access Anywhere loads but the page says RWW is not configured.

    • Marked as answer by djb77v Thursday, October 20, 2016 10:08 AM
    Wednesday, October 19, 2016 10:19 AM
  • I have the same issue.  As stated above, I can add /remote to the end of my domain and access Anywhere Access, and login validates.  

    Please keep us updated if you figure out what is going on!

    Gerrit

    Thursday, October 20, 2016 2:52 AM
  • I also experience the same issue on Essentials 2016. I can manually go to https://mydomain.com/remote and log in successfully to Access Anywhere so it does work.

    The root folder of the Default Website on Essentials 2012 points to C:\Program Files\Windows Server\Bin\WebApps\Site

    The root folder of the Default Website on Essentials 2016 points to C:\inetpub\wwwroot

    The following folder path C:\Program Files\Windows Server\Bin\WebApps\Site does exist on Essentials 2016 and if I manually change the Default Website root path to C:\Program Files\Windows Server\Bin\WebApps\Site then Access Anywhere loads but the page says RWW is not configured.


    Adding "/Remote" to the end of the URL worked.  Thanks so much!  I never would have figured that out, since the Anywhere Access settings window gives the wrong URL.  Astonishing that after like 2 years in beta this was never spotted.  Thanks again!

    • Edited by djb77v Thursday, October 20, 2016 10:11 AM
    • Proposed as answer by MontanaVike Tuesday, November 29, 2016 8:37 PM
    Thursday, October 20, 2016 10:09 AM
  • I loaded up Essentials 2016 TP5 and experienced the same whereby if you go to https://remote.mydomain.com, it doesn't redirect to https://remote.mydomain.com/remote like in Essentials 2012.

    Not sure if this is a change by design or not, but it does seem counterintuitive to end users.

    Thursday, October 20, 2016 4:10 PM
  • I was having the exact same issue that you are describing above. This is the workaround I employed, 

    After installing two Server 2016 Essentials servers this week, I found Anywhere Access on both servers didn’t work properly. When I browsed to the Remote Web Access URL (mycompany.remotewebaccess.com) , I was always greeted with the Internet Information Services (IIS) page. I figured I may have setup something wrong, so I double-checked my settings but everything was setup correctly.

    I then went to mycompany.remotewebaccess.com/remote and the site then came up fine. 

    Step One: Open Internet Information Services (IIS)

    Step Two: Go to Sites > Default Web Site > HTTP Redirect

    Step Three: Check the box Redirect requests to this destination: “Enter company URL with /remote at the end.

    Check the box “Only redirect requests to content in this directory (not subdirectories)”

    Step Four: Click Apply    You should be set now. If this doesn’t work for you, restart the Default Web Site.

     I believe this is a bug with Server 2016. Server 2012 and 2012R2, this worked perfectly without having to do this HTTP Redirect.   I will keep you posted if I learn more.


    Merlin Halteman

    • Proposed as answer by Paolo Centroni Monday, February 20, 2017 10:03 PM
    Friday, October 28, 2016 11:17 PM
  • Thanks Merlin!!  Worked perfectly.
    Saturday, November 12, 2016 8:50 PM
  • Thanks Merlin you saved my first 2016 Essentials install - of course the 2 i have deployed now are complaining about a best practices issue of having the redirect set haha!
    Saturday, December 03, 2016 11:03 PM
  • Thanks. Saved me a lot of head scratching :-)
    Sunday, December 04, 2016 4:42 PM
  • Merlin, worked perfectly for me, thank you so much.
    Monday, February 20, 2017 10:04 PM
  • It is by design because the old redirect messes with work folders

    You simply need to type https://domain.com/remote


    Grey

    Tuesday, February 21, 2017 11:39 AM
    Moderator
  • Grey: IMO one should not have to type an app name to get the default functionality. Merlin's HTTP redirect seems like a decent workaround.

    All:  Another thread on this topic:  https://social.technet.microsoft.com/Forums/windowsserver/en-US/a3b65ed7-299f-4921-82f8-0d2560539fcc/rwa-login-page-redirect-if-you-expect-it-to-work-one-way?forum=ws16essentials

    Saturday, July 29, 2017 6:47 PM