none
Anywhere Access: Only shows IIS Welcome page

    Question

  • I set up Anywhere Access and it had an issue with port forwarding the first try.  I changed some things and set it up correctly.  But now when I go to the URL from any browser on or off of my network, I only see the IIS Welcome page.  This is for Windows Server 2016.  On 2012 I used to see the Remote Web Access login page.  Is there a way to set that up?  I repaired and reconfigured Anywhere Access many times.  Still I only get the IIS Welcome page.
    • Edited by djb77v Tuesday, October 18, 2016 10:04 AM
    Tuesday, October 18, 2016 10:03 AM

Answers

All replies

  • Hi, 

    Make sure that you have configured the router/network correctly, “Windows Server 2012 Essentials: Router Setup” can also be considered as a reference for WS 2016:
    http://social.technet.microsoft.com/wiki/contents/articles/14153.windows-server-2012-essentials-router-setup.aspx

    Reference “Troubleshoot Remote Web Access connectivity in Windows Server Essentials” to check the details:
    https://technet.microsoft.com/en-us/library/jj635096(v=ws.11).aspx

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 19, 2016 8:45 AM
    Moderator
  • Deleted
    • Marked as answer by djb77v Thursday, October 20, 2016 10:08 AM
    Wednesday, October 19, 2016 10:19 AM
  • I have the same issue.  As stated above, I can add /remote to the end of my domain and access Anywhere Access, and login validates.  

    Please keep us updated if you figure out what is going on!

    Gerrit

    Thursday, October 20, 2016 2:52 AM
  • I also experience the same issue on Essentials 2016. I can manually go to https://mydomain.com/remote and log in successfully to Access Anywhere so it does work.

    The root folder of the Default Website on Essentials 2012 points to C:\Program Files\Windows Server\Bin\WebApps\Site

    The root folder of the Default Website on Essentials 2016 points to C:\inetpub\wwwroot

    The following folder path C:\Program Files\Windows Server\Bin\WebApps\Site does exist on Essentials 2016 and if I manually change the Default Website root path to C:\Program Files\Windows Server\Bin\WebApps\Site then Access Anywhere loads but the page says RWW is not configured.


    Adding "/Remote" to the end of the URL worked.  Thanks so much!  I never would have figured that out, since the Anywhere Access settings window gives the wrong URL.  Astonishing that after like 2 years in beta this was never spotted.  Thanks again!

    • Edited by djb77v Thursday, October 20, 2016 10:11 AM
    • Proposed as answer by MontanaVike Tuesday, November 29, 2016 8:37 PM
    Thursday, October 20, 2016 10:09 AM
  • Deleted
    Thursday, October 20, 2016 4:10 PM
  • I was having the exact same issue that you are describing above. This is the workaround I employed, 

    After installing two Server 2016 Essentials servers this week, I found Anywhere Access on both servers didn’t work properly. When I browsed to the Remote Web Access URL (mycompany.remotewebaccess.com) , I was always greeted with the Internet Information Services (IIS) page. I figured I may have setup something wrong, so I double-checked my settings but everything was setup correctly.

    I then went to mycompany.remotewebaccess.com/remote and the site then came up fine. 

    Step One: Open Internet Information Services (IIS)

    Step Two: Go to Sites > Default Web Site > HTTP Redirect

    Step Three: Check the box Redirect requests to this destination: “Enter company URL with /remote at the end.

    Check the box “Only redirect requests to content in this directory (not subdirectories)”

    Step Four: Click Apply    You should be set now. If this doesn’t work for you, restart the Default Web Site.

     I believe this is a bug with Server 2016. Server 2012 and 2012R2, this worked perfectly without having to do this HTTP Redirect.   I will keep you posted if I learn more.


    Merlin Halteman

    • Proposed as answer by Paolo Centroni Monday, February 20, 2017 10:03 PM
    Friday, October 28, 2016 11:17 PM
  • Thanks Merlin!!  Worked perfectly.
    Saturday, November 12, 2016 8:50 PM
  • Thanks Merlin you saved my first 2016 Essentials install - of course the 2 i have deployed now are complaining about a best practices issue of having the redirect set haha!
    Saturday, December 3, 2016 11:03 PM
  • Thanks. Saved me a lot of head scratching :-)
    Sunday, December 4, 2016 4:42 PM
  • Merlin, worked perfectly for me, thank you so much.
    Monday, February 20, 2017 10:04 PM
  • It is by design because the old redirect messes with work folders

    You simply need to type https://domain.com/remote


    Grey

    • Proposed as answer by RickHan Saturday, April 7, 2018 1:45 AM
    Tuesday, February 21, 2017 11:39 AM
    Moderator
  • Grey: IMO one should not have to type an app name to get the default functionality. Merlin's HTTP redirect seems like a decent workaround.

    All:  Another thread on this topic:  https://social.technet.microsoft.com/Forums/windowsserver/en-US/a3b65ed7-299f-4921-82f8-0d2560539fcc/rwa-login-page-redirect-if-you-expect-it-to-work-one-way?forum=ws16essentials

    Saturday, July 29, 2017 6:47 PM
  • Thanks.  1 month of trying to figure this out.
    Friday, April 6, 2018 9:57 PM
  • Easy workaround, and should have been documented.

    Anyone else notice that all the context sensitive help is gone?

    All the docs are now online, and they use Bing to search. Bing motto: a million results is much better than one correct one.

    I filed a bug against the help being unusable. Not holding my breath, though.


    Rick Hantz

    Saturday, April 7, 2018 1:48 AM
  • Have a look here Remote Web Access does not redirect as expected

    Mariëtte Knap
    www.server-essentials.com | Linkedin | Migrations done the easy way

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, April 9, 2018 4:58 PM
  • Off topic but wanted to voice about poor documentation.

    1st "Gotcha!"

    https://docs.microsoft.com/en-us/windows-server-essentials/install/install-and-configure-windows-server-essentials
    b.  Choose Server migration to install Windows Server Essentials and join this server to an existing Windows domain.
    --- This will dcpromo and attempt to acquire the FSMO.  Whoops. Hope you planned on working on this all weekend.  What, you didn't run DCDiag first?

    2nd "Gotcha"

    The "MIGRATION TOOL" DOES NOT EXIST.  ANYWHERE.

    Migrate Windows Small Business Server 2011 Standard to Windows Server Essentials

    10/03/2016  3 minutes to read  Contributors  Schumann Ge Liza Poggemeyer Corey Plett

    Note
    To avoid problems during migration, the Windows Server Essentials product development team strongly recommends that you read this document before you begin the migration.

    Migration process summary

    This Migration Guide includes the following steps:
     
    …. Step 5

    https://docs.microsoft.com/en-us/windows-server-essentials/migrate/prepare-your-source-server-for-windows-server-essentials-migration#BKMK_MPT

    To install and run the Migration Preparation Tool on the Source Server
    1. Insert Windows Server Essentials DVD1 in the DVD drive on the Source Server.

    2. Open Windows Explorer, browse to the \support\tools folder of the DVD, and then double-click the sourcetool.msi file. 

    THE TOOL DOES NOT EXIST.  I scoured the Internet for almost 3 hours, found references to downloading the 2012 ISO.  Nope, not there either.  Downloaded 2012R2 ISO.  Nope.  Sorry, no "sourcetool.msi"

    I called Microsoft support, and could not get past the cashiers.  One wanted $600 for the call, another wanted to use up my one, server down Action Pack benefit.  I tried to explain and was redirected to create a support request online.  Same thing.  You cannot create the request without paying $600.

    Being an "Old-Pro" for 25 years, I ran DCDiag and fixed several problems with AD before proceeding, and manually acquired the FSMO as the LAST STEP in my migration plan..

    Maybe it was on the DVD, but it sure as heck was not on the ISO.

    3 Hours lost to poor documentation, could have been the whole weekend.

    How much non-billable time have you lost to shoddy documentation non-documentation ?


    • Edited by RickkeeC Friday, May 4, 2018 3:51 AM
    Friday, May 4, 2018 3:47 AM
  • Have a look at my migration guides at Migration guides for Windows Server 2012 or 2016 Essentials. Those are end-to-end solutions that always work.

    Mariëtte Knap
    www.server-essentials.com | Linkedin | Migrations done the easy way

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Sunday, May 20, 2018 10:14 AM
  • When i make the changes you recommend in Server 2016 Essentials, it shows me a 404 page from the clients hosting company saying that the /remote page does not exist

    Saturday, July 7, 2018 5:27 PM
  • A. Regina,

    Unfortunately, this board does not identify the post that you clicked "Reply" on. Please quote the post to clarify what changes you performed and who "you" refers to.

    As for the 404 error, it sounds like you are using the URL for the client's public web site. You'll need a separate URL pointing to their in-house server, e.g. remote.contoso.com (if you set up your own certificate) or contoso.remotewebaccess.com (if you use the free certificate service provided with Essentials).

    Saturday, July 7, 2018 5:39 PM
  • When i make the changes you recommend in Server 2016 Essentials, it shows me a 404 page from the clients hosting company saying that the /remote page does not exist


    Clients hosting company?  2016 Essentials is on site correct?

    Grey


    Saturday, July 7, 2018 5:43 PM
    Moderator
  • You need a Host A record for remote.domain.com and point it to the public IP address of your Internet connection. The reason you get that error is that DNS is not configured or it has something like @ meaning anything in front of domain.com will point to some other IP address.

    DNS is crucial setting up RWA.


    Mariëtte Knap
    www.server-essentials.com | Linkedin | Migrations done the easy way

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Saturday, July 7, 2018 7:56 PM
  • Any chance you can tell me exactly what one needs to do in order to accomplish what you're saying? Like a step by step to set this up correctly?

    Thursday, July 12, 2018 7:08 PM
  • Do you mean how to setup DNS? It differs from registrar to registrar but this may help How do I set up host records for a domain? - Domains - Namecheap.com

    Mariëtte Knap
    www.server-essentials.com | Linkedin | Migrations done the easy way

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, July 12, 2018 7:28 PM
  • No I guess not. The issue seemed the same as the one I was having as I was reading it but I guess it's not. I may just make a different thread. Thank you for the quick response.
    Thursday, July 12, 2018 7:59 PM