locked
Linksys USB Wi-fi users! RRS feed

  • Question

  • After much digging, I have finally found out how to get my Linksys WUSB54GS wi-fi adapter working (perfectly) in Windows Vista Beta 2!

    1. Downloaded this file and extracted it to a folder.

    2. Connected the Adapter to my computer while booted in Vista.

    3. Loaded the device manager, located the adapter and selected "update driver."

    4. Directed the wizard to the folder, where it automatically located and installed the driver (confirm that you want to install it despite it not being "signed").

    5. Used the integrated Windows Wi-fi utility to find and connect to my wireless network!

    It's that simple. I hope this will help others with the same problem.

    Tuesday, July 11, 2006 8:04 PM

All replies

  • Thanks for the link. I can now connect to the Internet without a glitch; however, I cannot browse to shares on my local workgroup (Windows XP servers). After the folder contents appear, Vista simply locks up. [x86 Free Build 5520.16387.060816-1900]

    You say it has worked perfectly for you. How is your connectivity to Windows XP?

    Saturday, August 26, 2006 4:39 PM
  • I tried that but it didnt work. There was a problem with the driver it said:
    Reinstall the drivers for this device. (Code 18)

    A service installation section in this INF is invalid.


    To reinstall the drivers for this device, click Reinstall Driver.

    Do you know why this would happen?
    Wednesday, August 30, 2006 12:17 AM
  •  

    anybody know why my linksys wusb54gsc usb adapter will not work on windows XP?

    i tried everything i can think of. when it shows up in network connections.. it tends to freeze up network connections until i unplug it.. and the software that was supplied does not work either.

    in the past the linksys software ran perfectly.. and previously, i think i had WZC configured.. but i cant figure out how to get it going again. i had to reinstall windows because of problems i was having.. updated all drivers.. now it just dosent work..

    i have a compaq presario, 3400AMD processor, 512MB memory.. anywho... someone help!!!!!!!!!!!!!!

    Wednesday, October 29, 2008 8:02 PM
  • Chances are you are using Win XP with SP3 and to the best of my knowledge Linksys Adapter WUSB54GSC is not supported in SP3. You need to use Win XP with SP 1 or SP 2. The adapter will however work with Vista.
    Thursday, October 29, 2009 7:58 PM