locked
App-V get Dll Missing error when running the application from the client. RRS feed

  • Question

  • Hi everyone

    I'm packaging applications with App-V 4.6 SP1 for a Windows 7 VDI environment. the users are Standard users and not Administrators on VDI.

    I'm stuck with an application that after I sequenced it I got an error message of a missing DLLs
    after rechecking , The DLLs were sequenced and they are located in the package, under Windows\system32 folder.

    if there's a special step-by-step troubleshooting for missing DLL errors besides LOCAL_INTERACTION_ALLOWED to make the package work i'd be glad to have some.

    from what I checked - if I delete the CSIDL_SYSTEM folder in the package and copy the DLL files locally to the VDI environment - the application works!

    My actions:

    • I tried to make a startup script the xcopying the dll files from the package to the system32 folder (I don't mind it happens every startup) but then I get the UAC message with credentials prompt as the users don't have permission to write to the System32 folder.
    • I created a silent EXE file with domain admin priviledges that does this action and when I doubleclick it I also get the UAC prompt!
    • I also tried to copy the files to the %LOCALAPPDATA%\Microsoft\VirtualStore\Windows\system32 but the application does not recognize the files from that location. (any trigger I should add for this to work...?)
    • I wanna avoid placing the Dll's inside my gold image because only 5% of my organization uses this application.
    • GPP doesn't help me because it will cause startup delays + I can only perform this with Computer Configuration as User Configuration doesn't have permission to perform this action.
    • I'm not willing to cancel UAC as it's one of Windows 7 best features.
    • I tried to add the __CompatLayer=runasinvoker variable but it didn't help as well

    I would be happy solution from the situation above. either a way to sequence the dlls and make it work or to copy them to the system32 without getting the UAC message.

    thanks.

    Saturday, May 19, 2012 10:19 AM

All replies