locked
UAG - Enterprise Vault Publishing for Exchange RRS feed

  • Question

  • Hey all,

    I am trying to publish Enterprise Vault for Exchange 2010 via the UAG application trunk and running into problems. 

    1) My Portal homepage is Exchange 2010 which listens for owa.company.com and hosts the FBA Listener.

    2) This authenticates back to Exchagne 2010 perfectly.

    3) I have a legacymail.company.com Application that controls the Exchange 2003 redirects.(Exchange 2003 hosts a 'enterprisevaultproxy' virtual directory that is setup with an additional 'path' in UAG to handle this)  **UAG and 2003 mail\Enterprise Vault works.)

    4) I am publishing an application specific hostname app for vault.company.com where it connects to the Vautl Server backend.  I have configured the ExternalWebApplicationURL for Enterprise Vault on the Exchange owa External directory.

    I just can't get it to publish the Archive Explorer and Search Archives correctly.  I am curious if anyone has been successful with this configuration,

    Justin

    Monday, March 21, 2011 11:06 PM

Answers

  • Hi Amigo.

    1) Yes, you need to extend the URL Set to include the EV path. You can allow the whole path or restrict /owa/Enterprisevault/scripts,  /owa/Enterprisevault/images with regular expressions

    2)

    a) Yeah, that one is a nice one ;-)

    b) The portal link is the initial path that will be launched in the browser when the user hits the icon in the portal. That one is ok but you can also remove the /enterprisevault as explain bellow. You can also restrict the valid paths in the General Tab of the application properties and also filter the valid requests with a specific URL Set for that application

    b.1) Uncheck the "add portal and toolbar link" in the Portal Link tab. This way the user will not see an icon for the application, but when he hits the Search or whatever link in EV he will send the request to UAG and UAG will match the name with the pusblishing of EV

    c) Yes

    If any of the responses are useful, please, take a second to mark it as "answer"

    Regards


    // Raúl - I love this game
    • Marked as answer by cred_olt Tuesday, March 22, 2011 5:35 PM
    Tuesday, March 22, 2011 5:05 PM
  • Raul,

    Thanks...I will mark you as an answer....for anyone that cares...here is exactly what I had to do:

    1) Exchange 2010 Application - Allow the /owa/Enterprisevault/* access

    2) Vault Application specific hostname - points to the Vault server for 443 and path /EnterpriseVault/*. (SSO, portal link of vault.company.com)

    3) Added the following entries to the Application settings on both CAS Servers:

    EnterpriseVault_ExternalWebAppURL=https://vault.company.com/enterprisevault

    EnterpriseVault_ExternalHostNames=owa.company.com


    • Marked as answer by cred_olt Tuesday, March 22, 2011 5:35 PM
    • Edited by cred_olt Tuesday, March 22, 2011 7:38 PM
    Tuesday, March 22, 2011 5:35 PM

All replies

  • Hi Amigo. I have recently finished a deployment of UAG with EV involved. In my environment the public name of EV and OWA were different. I published Exchange on one side and the public name of Archiving on other side as an "application specific hostname" web application. There seems to be (I was told by my customer) a big difference between EV in Exchange 2003 and 2010 because the "proxy" function is no longer available in 2010 and that leads to have two different applications published. Can you see any error in Web Monitor? Can you trace with an HTTP debugger at the client side to look for broken links?

    P.S: EV seems to have a very flexible architecture and depending of the scenario it can be configured in many different ways. For me, the most suitable way to configure it for UAG publishing is the same one that is documented for ISA publishing. http://www.symantec.com/business/support/index?page=content&id=TECH61472

    Hope it helps


    // Raúl - I love this game
    Tuesday, March 22, 2011 8:39 AM
  • Raul,

    Thank you for the response...I think we will be heading down the path of using a separate public name for the vault as well.  a couple questions for you:

    1) When publishing the OWA 2010 Application, does it require you to allow /owa/Enterprisevault/* to read the icons and determine the redirect URL?

    2) When publishing the Application Specific Hostname for EV.company.com:

    a - public name - ev.company.com

    b - portal link - https://ev.company.com/enterprisevault/

    c - Authentication - SSO

    Thanks,

    Justin

    Tuesday, March 22, 2011 2:40 PM
  • Hi Amigo.

    1) Yes, you need to extend the URL Set to include the EV path. You can allow the whole path or restrict /owa/Enterprisevault/scripts,  /owa/Enterprisevault/images with regular expressions

    2)

    a) Yeah, that one is a nice one ;-)

    b) The portal link is the initial path that will be launched in the browser when the user hits the icon in the portal. That one is ok but you can also remove the /enterprisevault as explain bellow. You can also restrict the valid paths in the General Tab of the application properties and also filter the valid requests with a specific URL Set for that application

    b.1) Uncheck the "add portal and toolbar link" in the Portal Link tab. This way the user will not see an icon for the application, but when he hits the Search or whatever link in EV he will send the request to UAG and UAG will match the name with the pusblishing of EV

    c) Yes

    If any of the responses are useful, please, take a second to mark it as "answer"

    Regards


    // Raúl - I love this game
    • Marked as answer by cred_olt Tuesday, March 22, 2011 5:35 PM
    Tuesday, March 22, 2011 5:05 PM
  • Raul,

    Thanks...I will mark you as an answer....for anyone that cares...here is exactly what I had to do:

    1) Exchange 2010 Application - Allow the /owa/Enterprisevault/* access

    2) Vault Application specific hostname - points to the Vault server for 443 and path /EnterpriseVault/*. (SSO, portal link of vault.company.com)

    3) Added the following entries to the Application settings on both CAS Servers:

    EnterpriseVault_ExternalWebAppURL=https://vault.company.com/enterprisevault

    EnterpriseVault_ExternalHostNames=owa.company.com


    • Marked as answer by cred_olt Tuesday, March 22, 2011 5:35 PM
    • Edited by cred_olt Tuesday, March 22, 2011 7:38 PM
    Tuesday, March 22, 2011 5:35 PM
  • Hi Amigo. Why did you need the Manual URL replacement? If the EV is configured to send the vault.company.com to the browser then the request will match the name of the "application specific hostname" and will be handle by UAG and sent to the internal server defined in the application properties.

    Regards


    // Raúl - I love this game
    Tuesday, March 22, 2011 6:02 PM
  • You are correct Raul...adjusted and working.
    Tuesday, March 22, 2011 7:38 PM
  • Great :)
    // Raúl - I love this game
    Tuesday, March 22, 2011 8:32 PM
  • Nice work Raul...very handy ;)
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Wednesday, March 23, 2011 11:59 PM
  • Hello,

    Were you able to get the virtual vault cache synchronization working as well? It is breaking for me when it tries to list archives during the synchronization process for the Virtual Vault Synchronization?

    Did you modify your Desktop Policy specifically the OWA listing to contain your specific external web url?

    I have everything but Virtual Vault Synchronization working

    Thursday, April 7, 2011 7:09 PM