locked
How to block an external email address from sending email to Exchange 2007 Organization? RRS feed

  • Question

  • Hi,

    We have an Exchange 2007 organization. To block an email address (it's a googlegroups address, by the way) I enabled sender filtering on my Edge Servers and entered that email address. But the emails from that address keep coming through. I have a few other email addresses added to sender filtering and it is working fine for those but for that particular address i don't know why. Could someone please suggest how to make it work for that particular (googlegroups) address?

    Thanks in advance
    Sunday, October 11, 2009 8:22 AM

All replies

  • I have created a Transport rule on my Edge servers. On the Conditions page, i selected when the From address contains the specific words (entered my yahoo email address for test purposes) and from users Outside the organization . On the Actions page, i selected reject the message with the status code . It worked fine but i'll have to wait and check if it will work for that email address.

    Regards
    • Marked as answer by Undying Lament Saturday, October 17, 2009 7:47 AM
    • Unmarked as answer by Undying Lament Saturday, October 24, 2009 7:09 AM
    Sunday, October 11, 2009 9:07 AM
  • Hi,

    Besides the transport rule option you can also use the anti-spam agents which are by default installed on the Edge transport server. Then add the address to the blocked senders list and the sender will be blocked.

    If you don't habe an Edge server just install the anti-spam agents using the install-antispamagents.ps1 script in Powershell.The script can be found in the default script directory in the Exchange dir.

    Regards,

    Johan
    blog: www.johanveldhuis.nl
    Sunday, October 11, 2009 11:27 AM
  • Dear Johan,

    Thanks for the reply. As i mentioned in my original post, i had already added the email address to Blocked Sender's list but it did not work.

    regards
    Sunday, October 11, 2009 11:40 AM
  • One of the other workaround would be to enable the recieve emails from authenticated users only on that DL.
    Vinod |CCNA|MCSE 2003 +Messaging|MCTS|ITIL V3|
    Monday, October 12, 2009 12:51 PM
  • Hi,

    Any update regarding the issue? Whether the Transport Rule is able to work for the  specific email address?

    In addition, I suggest you configure a client to telnet to Exchange Server to check whether the Sender Filter still not work for the specific email address.

    XFOR: Telnet to Port 25 to Test SMTP Communication
    http://support.microsoft.com/kb/153119/en-us

    If the Sender Filter still not work, whether it is possible to let me know the problem email address? You can send the email address to me (v-mishen @ microsoft.com)

    Thanks,
    Mike
    Wednesday, October 14, 2009 3:38 AM
  • Sorry about the lack of update (I got busy). Yes, i already did the telnet tests and got the message that the sender is denied. So, i suppose it's working fine. But what i don't understand is why it did not work in the first place. I mean why did i have to create a transport rule just for that address when the sender filtering was working for other addresses.

    Regards
    Wednesday, October 14, 2009 6:43 AM
  • UPDATE:

    Hi,

    I just checked the message tracking log on my edge servers and found that emails from the culprit address are still coming through. I'm really annoyed by this. I don't know why the sender filtering and transport rule is failing to work for that particular email address (they are working for other emails). Mike I'm sending you the email address. Thanks for the help.

    Regards
    Saturday, October 24, 2009 7:09 AM