locked
Site template RRS feed

  • Question

  • In My sitecollection there is a site. So i created a Sitetemplate named "abctemplate" from the existing site in the site collection using /_layouts/savetmpl.aspx and i can create a new site abc.aspx  using the newly create site template abctemplate.

    After that i tried to create a site template named xyztemplate from the abc.aspx site which is created by using abctemplate. then it is throwinme an error :

    This page is not using a valid page layout. To correct the problem, edit page settings and select a valid page layout."

    can anyone tell me why it is showing me this error.

    Thnks!

    Tuesday, September 27, 2011 7:30 PM

Answers

All replies

    • Go to Site Content and Structure
    • Find the Pages library in question
    • View Properties of trouble page
    • Edit item
    • Change content type to e.g. Article page
    • ...Content should load...
    • Click Ok - this should direct you back to the Site Content and Structure page.
    • Edit page settings
    • You should see the text 'Current page layout is not valid. Please select a valid page layout from the drop down list and apply it.'
    • Click 'OK'
    • Page layout should now be reassigned.

    Thanks & Regards Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, September 27, 2011 8:56 PM
  • Hi Zoeb S,

    When i click on Site content and structure it is throwing me this error : Feature '00bfea71-e717-4e80-aa17-d0c71b368996' for list template '8998' is not installed in this farm. The operation could not be completed.

    So when i goggled this error i found the this link. http://technet.microsoft.com/en-us/library/cc287893(office.12).aspx. by looking at the link i ran 

    stsadm -o getsitelock -url http://server_name

    by putting my site url then it showed me 

    <SiteLock Lock="none" />

    so i am thinking my site is not locked. then why wudn't it let me open content and structure??

    Thanks in advance!

    Tuesday, September 27, 2011 9:17 PM
  • Did you enable the publishing feature on the Existing site and then saved it as a Template ? 
    Thanks & Regards Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, September 27, 2011 10:52 PM
  • Using save site as a template is not supported and does not work correct for sites which have the publishing feature enabled or contain content which was created through the publishing feature (e.g. pages library).

    The supported method to create templates for publishing sites is to use site definition templates. For more information, visit the following Microsoft Web site:
    http://msdn.microsoft.com/en-us/library/ms434313.aspx

    More details:

    http://blogs.technet.com/b/stefan_gossner/archive/2007/09/19/save-site-as-template-option-and-the-publishing-feature.aspx

    http://support.microsoft.com/kb/925189/en-us


    Microsoft CSS - This post is provided "AS IS" with no warrenties and confers no rights.
    Wednesday, September 28, 2011 8:26 AM
  • Yes i enabled publishing feature on the site and then saved it as a template.
    Wednesday, September 28, 2011 7:09 PM
  • Then you won't be able to do it. check Stefan's reply and you will have to follow the steps mentioned in his blog. Hope this helps
    Thanks & Regards Posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, September 28, 2011 7:17 PM