none
Page cannot be displayed when strange character is in the url (i.e. umlaut) RRS feed

  • Question

  • Hello everyone,

    One of our customers is working on a Windows Server 2012R2 (Remote Desktop) with Internet Explorer 11. Fully updated.
    Links on their website can have strange characters (ë, ü, û) in them*. They exist in variables send with the URL, so not in the domain name itself.
    When using such a link, the webpage cannot be displayed. 

    I cannot give an example of the website itself, its on a protected area, but it is reproducable by manipulating a link. Fot example:

    http://www.bing.com/?test=test

    http://www.bing.com/?test=tëst

    The real problem is, this only happen on the this particular server. On other systems, with the same IE version, the pages are loaded and displayed.

    Another browser on the same Server does display the pages.

    Tried several settings, but nothing seems to fix this. 

    * For whatever reason they do not use url encoding on the webserver end, please do not give this as solution. Because it does work on other systems, there must be something to make it working. 

    Monday, June 16, 2014 3:15 PM

Answers

  • Sorry for the late reply.

    The problem is solved. It was a setting in the NETASQ Firewall. 


    Firefox did URL encoding before it was send. That is why it only happened with Internet Explorer.

    • Marked as answer by CreatoX Tuesday, July 1, 2014 12:49 PM
    • Edited by CreatoX Tuesday, July 1, 2014 12:50 PM
    Tuesday, July 1, 2014 12:48 PM

All replies

  • only happen on the this particular server. 

    So, trace both cases and compare the responses.  Tracing with IE's Developer Tools, Network capture should probably be enough to spot some differences.  (F12, Ctrl-4, F5)


    Robert Aldwinckle
    ---

    • Marked as answer by Karen HuModerator Tuesday, July 1, 2014 12:30 PM
    • Unmarked as answer by CreatoX Tuesday, July 1, 2014 12:43 PM
    Monday, June 16, 2014 6:34 PM
    Answerer
  • View>Encoding>UTF-8

    Rob^_^

    • Marked as answer by Karen HuModerator Tuesday, July 1, 2014 12:30 PM
    • Unmarked as answer by CreatoX Tuesday, July 1, 2014 12:43 PM
    Tuesday, June 17, 2014 7:34 AM
  • Sorry for the late reply.

    The problem is solved. It was a setting in the NETASQ Firewall. 


    Firefox did URL encoding before it was send. That is why it only happened with Internet Explorer.

    • Marked as answer by CreatoX Tuesday, July 1, 2014 12:49 PM
    • Edited by CreatoX Tuesday, July 1, 2014 12:50 PM
    Tuesday, July 1, 2014 12:48 PM