locked
Problem running WSUS maintenance script RRS feed

  • Question

  • Ok, WSUS is running on Windows server 2008 r2 without problems. Server has SQL Server 2008 r2 running as well. With Windows 10 coming soon, it's time to prepare WSUS to deal with it. So Windows 10 categories are checked in the WSUS console. Now it seems WSUS will refer to Windows 10 as Windows Vista. And we don't want that, so I tried to fix this according to page http://titlerequired.com/2015/07/22/windows-10-on-wsus-shows-as-windows-vista/

    I composed the SQL script, but it won't run. The command to run the script looks like this: sqlcmd -I -i WsusDBMaintenance.sql -S \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query

    WsusDBMaintenance.sql being the script responsible for, among maintenance, renaming Windows 10 to, well, Windows 10.

    Thing is, there's no database engine called MICROSOFT##SSEE on the box. If I check SQL Server Management Studio, there's a database engine called <servername> holding SUSDB. But specifying <servername> instead of MICROSOFT##SSEE results in the same error message "Named Pipes Provider: Could not open a connection to SQL Server". Tried fiddling the name like removing the MSSQL$ part, specifying SUSDB etc. but it won't budge.

    It's probably something I overlook, so how can I get that script running?

    Tuesday, July 28, 2015 10:36 AM

Answers

  • you're not using the internal WSUS DB, you have a full SQL database by the sound of it

    by default, named pipes are disabled in SQL installations for security reasons.  you can either enable named pipes which I wouldn't recommend. you can open up to SUSDB in SQL management studio and run the .sql script right there within the GUI. or if you insist of running it via command line, you need to change your syntax:

    sqlcmd -I -i WsusDBMaintenance.sql -S <servername>\SUSDB

    • Proposed as answer by Steven_Lee0510 Wednesday, July 29, 2015 6:33 AM
    • Marked as answer by Simon Weel Wednesday, July 29, 2015 7:14 AM
    Tuesday, July 28, 2015 12:50 PM

All replies

  • you're not using the internal WSUS DB, you have a full SQL database by the sound of it

    by default, named pipes are disabled in SQL installations for security reasons.  you can either enable named pipes which I wouldn't recommend. you can open up to SUSDB in SQL management studio and run the .sql script right there within the GUI. or if you insist of running it via command line, you need to change your syntax:

    sqlcmd -I -i WsusDBMaintenance.sql -S <servername>\SUSDB

    • Proposed as answer by Steven_Lee0510 Wednesday, July 29, 2015 6:33 AM
    • Marked as answer by Simon Weel Wednesday, July 29, 2015 7:14 AM
    Tuesday, July 28, 2015 12:50 PM
  • Hi Simon,

     \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query is the named pipe of the WSUS's database when we use the WID.

    If we use a SQL server to host the database, please follow armin19's instruction above.

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, July 29, 2015 6:52 AM
  • you're not using the internal WSUS DB, you have a full SQL database by the sound of it

    by default, named pipes are disabled in SQL installations for security reasons.  you can either enable named pipes which I wouldn't recommend. you can open up to SUSDB in SQL management studio and run the .sql script right there within the GUI. or if you insist of running it via command line, you need to change your syntax:

    sqlcmd -I -i WsusDBMaintenance.sql -S <servername>\SUSDB

    Thanks! If I strip the \SUSDB part, the script runs fine.
    Wednesday, July 29, 2015 7:14 AM